WordPress.org

Ready to get started?Download WordPress

Forums

Newbie question about directories, html, and urls (5 posts)

  1. bigdog61
    Member
    Posted 5 years ago #

    I want to add a WP blog to an existing site, with a "Blog" link in the navigation menu. I've installed WP and it works correctly, but I can't figure out how to make the blog a separate page within the existing site. I changed the Blog Address setting, but it said that the URL was not found. Do I need to create a new HTML page?

  2. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    As I understand it, you have an existing site (HTML I presume) at http://example.com and you've installed WordPress at http://example.com/blog/
    Why would you want to make a separate page out of a blog? Why not link to it instead in your main navigation or at sidebar?

  3. bigdog61
    Member
    Posted 5 years ago #

    That's what I'm trying to do. I've installed WP in "example.com"; in the Settings, I have both the WP Address and Blog Address URLs set to "example.com," but now when I click on Save Changes, it says "URL not found"; it was working earlier with those settings. Here's my question: Assuming I can fix the problem I just mentioned, how do I create a link to the blog if the blog address is "example.com", the same as the site's existing home page?

  4. moshu
    Member
    Posted 5 years ago #

    It cannot work in example.com if you already have a site there. Period.
    You have to move it into the /blog folder under the root.
    Moving_WordPress

  5. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    Thanks moshu for getting to the "root" of the problem :-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.