WordPress.org

Ready to get started?Download WordPress

Forums

Newbie need help with this error (11 posts)

  1. egypty
    Member
    Posted 5 years ago #

    hello all im new to wordpress world i use this theme NewsPress 1.0

    i got this error

    Warning: include(layouts/) [function.include]: failed to open stream: No such file or directory in /home/kol7aga/public_html/wp-content/themes/newspress/home.php on line 13

    Warning: include() [function.include]: Failed opening 'layouts/' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/kol7aga/public_html/wp-content/themes/newspress/home.php on line 13

    also in this theme Premium News - CNN Edited 1

    i got this error

    Warning: include(layouts/) [function.include]: failed to open stream: No such file or directory in /home/kol7aga/public_html/wp-content/themes/The Gazette Edition/home.php on line 16

    Warning: include() [function.include]: Failed opening 'layouts/' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/kol7aga/public_html/wp-content/themes/The Gazette Edition/home.php on line 16

    i dont know how to solve this please help me

  2. Libor Jelinek
    Member
    Posted 5 years ago #

    Dear Egypty, are you sure that you have subdirectory named "layouts" under your theme directory (i.e. wp-content/templates/nameOfYourTemplate/layouts)?

    Error message means that subdirectory layouts doesn't exist or is inaccessible.

    Libor

  3. egypty
    Member
    Posted 5 years ago #

    Dear Libor its exist

    /public_html/wp-content/themes/newspress/

  4. Evita
    Member
    Posted 5 years ago #

    Mmmmm, and where is the subdirectory layouts?
    Your error: Failed opening 'layouts/'

  5. egypty
    Member
    Posted 5 years ago #

    its here

    /public_html/wp-content/themes/newspress/layouts

  6. Libor Jelinek
    Member
    Posted 5 years ago #

    Last thing that can cause the problem can be layout directory permissions...

    Set "chmod 777" on layout directory (rwxrwxrwx) (permission to read, write and execute for owner, group, other) (using FTP client if you have your WP on remote server) and try it again.

    Libor

  7. metina
    Member
    Posted 5 years ago #

    Could youy solve the problem?
    I also have same problem :(

  8. jbbrwcky
    Member
    Posted 5 years ago #

    Could you post the home.php file please?

  9. grayfilm
    Member
    Posted 5 years ago #

    home.php file as requested

    [code]
    <?php get_header(); ?>

    <div class="col1">

    <?php include(TEMPLATEPATH . '/includes/featured.php'); ?>

    <?php
    $showplace = get_option('premiumnews_show_video_feat');
    if ( $showplace ) { include(TEMPLATEPATH . '/includes/video.php'); }
    ?>

    <?php

    $layout = get_option('premiumnews_layout');

    include('layouts/'.$layout);

    ?>

    <?php
    $showplace = get_option('premiumnews_show_video_feat');
    if ( !$showplace ) { include(TEMPLATEPATH . '/includes/video.php'); }
    ?>

    </div><!--/col1-->

    <?php get_sidebar(); ?>

    <?php get_footer(); ?>
    [/code]

  10. grayfilm
    Member
    Posted 5 years ago #

    layouts folder located in

    wp-content/themes/Template_Name
    i.e.
    wp-content/themes/Template_Name/layouts

  11. grayfilm
    Member
    Posted 5 years ago #

    i have found the solution.

    install and activate theme
    go to wordpress admin panel under DESIGN.
    select PREMIUM NEWS OPTIONS.
    you must go down the line and just enable or fill in those options. at least some or most of them. i didnt change all the options only the ones that i thought were important, which will be the ones at the top (GENERAL SETTINGS + FRONT PAGE LAYOUT)

    save.
    if you look on your home page you will notice the error message is gone. you can now customieze other things as you wish.

    good day and good luck to all.
    this problem should be solved

    when you finish just save.

Topic Closed

This topic has been closed to new replies.

About this Topic