WordPress.org

Ready to get started?Download WordPress

Forums

New wordpress is a blank site (11 posts)

  1. aabel
    Member
    Posted 4 years ago #

    I just got my first wordpress up and running today but nothing shows up! I can get into the admin part just fine and everything else seems to be ok. I haven't added any plugins or fancy themes. There is no .htaccess file or whatever that is. Neither the classic nor the default theme shows.
    http://www.adriannesbackyard.com

    thoughts?

  2. buddha trance
    Member
    Posted 4 years ago #

    If there is no .htaccess file, add one at the root level (or in the directory where you have wordpress installed)

    Create a simple text file (don't use a rich text editor) with the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    and call it whatever you like, then when uploaded rename it .htaccess
    give it permissions 644

    There should be one, but maybe it couldn't be created automatically. See if doing so returns the blog to normal display.

  3. alism
    Member
    Posted 4 years ago #

    (It looks like IIS rather than Apache, so wouldn't have an .htaccess)

  4. aabel
    Member
    Posted 4 years ago #

    Sorry buddah, it didn't work. I did try deleting everything (including the database) and starting over... same problem. Could this be happening because I setup my database incorrectly? Just a guess.

  5. ke vinritt
    Member
    Posted 4 years ago #

    Did you install it through CPanel or any other software?

  6. aabel
    Member
    Posted 4 years ago #

    I did not use CPanel or phpMyAdmin. Dotster just has a button that says add new database, choose the type of database (MySQL, MqSQL 5 or MS SQL) and then I'm entering the database name and username/password. I chose MySQL as my database type. Now there is an option to go into phpMyAdmin once I click on the created database, but what I see in there is WAY over my head.

  7. buddha trance
    Member
    Posted 4 years ago #

    @aabel - See if this article helps you
    http://www.velvetblues.com/web-development-blog/my-wordpress-blog-is-blank/

    Make sure all the files are uploaded (maybe the server timed out and something is missing)

    Plugins and themes are not your issue, since you said you didn't add any...

    The problem could also be in the wp-config file, if there is an empty line added (especially at the bottom) while you were configuring it.

  8. buddha trance
    Member
    Posted 4 years ago #

    Here is another article mentioning also a possible memory problem, with a fix in wp-settings
    http://www.hightechdad.com/2009/06/10/fixing-blank-empty-or-white-wordpress-pages-after-upgrade/

  9. aabel
    Member
    Posted 4 years ago #

    To my knowledge (and I've re-uploaded the files now from my home internet connection instead of my work connection just in case that was timing out) all the files are uploaded. Velvetblues.com suggests to upload the .zip file and unpack it on the server... I don't have the option to do that with FileZilla.

    Strangely I found that my wp-config file did not have ?> at the end of it! I just downloaded the newest update yesterday so that troubles me. Is there any word that the newest version is corrupt? Anyway, I made sure there was no carriage return after the ?>

    The change in the memory didn't work. I'm just going to have to pay someone to do this for me I guess. Perhaps I'll try the guy who wrote the hightechdad post. Thank you for troubleshooting with me. Once I find out the problem I will let yall know.

  10. buddha trance
    Member
    Posted 4 years ago #

    @aabel - I just downloaded a fresh copy of 2.8.6 and you are right, the closing ?> is missing from the wp-config file!!!
    When upgrading, the original file is not overwritten, so my latest version worked just fine. I'll try to notify this.

    Of course, you have renamed wp-config-sample.php into wp-config.php, right?

    Another option you could try, is to start with an earlier version, get is running, and then do the automatic upgrade. Maybe it will work that way and there is something faulty with the latest full version download...

    Try with 2.8.5 here http://wordpress.org/download/release-archive/
    but then "upgrade" to 2.8.6 because there is a security fix.

    Hope this helps.

  11. buddha trance
    Member
    Posted 4 years ago #

    Please, disregard my post above. The missing ?> closing tag from wp-config in 2.8.6 is not an error. It was done on purpose, as clarified here
    http://wordpress.org/support/topic/335570?replies=3

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags