WordPress.org

Ready to get started?Download WordPress

Forums

Showtime
New WordPress Broke this Plugin (8 posts)

  1. BrowCo
    Member
    Posted 1 year ago #

    Ever since the update of WordPress, the plugin isn't working anymore.

    I see the error of:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/XXXXXXXX/23/50/2005023/web/wp-content/plugins/showtime/showtime.php on line 167 and defined in /home/XXXXXXXX/23/50/2005023/web/wp-includes/wp-db.php on line 990

    I am not much of a coder, but it seems to be a common problem on some other plugins...just not sure how to fix it.

    Anyone know of any way to fix or patch this up? I love this plugin and my site isn't the same with it deactivated. :(

    http://wordpress.org/extend/plugins/showtime/

  2. phoros
    Member
    Posted 1 year ago #

    I've stopped updating WP a long time ago (on 3.1.3.) due to several heavy changes I've made in few plugins and the core of WP itself. Mostly to avoid situations like yours. Maybe you could go back to a version of WP which worked properly and freeze it with this? Just a tip, not a way out, sorry for spam-like-wisdom.

  3. BrowCo
    Member
    Posted 1 year ago #

    I've thought about doing that, but I've had worst experiences in the past running out of date WP. :(

  4. rogerneale
    Member
    Posted 1 year ago #

    I updated my WP too and it's broken the "Now Showing" section with the same error message.

    I'll get onto my WP programmer and see if he can work out how to fix it.

  5. BrowCo
    Member
    Posted 1 year ago #

    Awesome. Thanks rogerneale! Let me know what you come up with.

  6. rogerneale
    Member
    Posted 1 year ago #

    My programmer has fixed it for me.

    Apparently there are two possible fixes around this,

    1) You can edit the wp-config.php file and find this line of code

    "/** Sets up WordPress vars and included files. */require_once(ABSPATH. 'wp-settings.php');"
    and add "error_reporting(0);" underneath it without the quotations.

    Then re-upload the wp-config.php file back to the server again, that should resolve the issue.

    2) If you are using CPanel (Control Panel) for managing your hosting, you can turn off "display_errors" within the php.ini configuration and that should also fix it

    You can see mine in operation again at http://www.elasticfm.co.uk/?page_id=247

    Hope one of these solutions helps you.

  7. BrowCo
    Member
    Posted 1 year ago #

    Wow that works perfectly! I had a feeling that it would be a simple patch.

    Thanks so much for the help and suggestions!

  8. rogerneale
    Member
    Posted 1 year ago #

    I'm glad that we were able to help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic