WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] New VPS has blank Admin (14 posts)

  1. Martin
    Member
    Posted 11 months ago #

    After using the plugin successfully with shared hosting with Hostgator, I'm trialling a VPS.
    I notice that as soon as I activate this plugin, every Admin screen is blank.
    Now pardon my VPS or command line knowledge but could this be caused by the exec() thing I have read about?
    And if it is, any idea whereabouts I go to enable it?

    Sorry for sounding like a newbie. It's because I am when it comes to raw server admin :)

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    That is usually a javascript conflict or a W3TC issue (from what others have said, I've never been able to reproduce the error). Check your server error logs for more information (/var/log/apache2/error.log if you're using Apache for your web server).

  3. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    find anything out?

  4. rmada
    Member
    Posted 11 months ago #

    Hi nosilver4u...I have exactly the same issue after moving from shared hosting to a VPS. Sadly, there's nothing in the error log that would point me into the right direction. The same thing happens with CW Optimizer btw.

    If you have any idea what else I could check please let me know...I really miss using this plugin. Thanks

  5. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    Martin & rmada:

    while disabling exec() should not cause this issue, I can't think of anything else that would affect both plugins. From my recollection, CW doesn't use any javascript or anything else of that nature.

    So, check your php.ini file for the disable_functions settings and make sure 'exec' is not in the list. If it is, remove it, and restart apache.

    If either of you can set me up with a test account on your VPS, I could take a look myself to speed things up. Use the contact form over at shanebishop.net to send me login details.

  6. rmada
    Member
    Posted 11 months ago #

    Oh, I'm on WP 3.6.1 - also happens on a clean WP install without a cache plugin like W3TC

  7. rmada
    Member
    Posted 11 months ago #

    Tried to send you an email. Not sure if it went through though. CN kicks in saying the site is offline.

  8. rmada
    Member
    Posted 11 months ago #

    Ah, ok. I turned the WP debug mode on, it says: exec() has been disabled for security reasons

    But it's not listed under disable_functions. Safe mode is off too.

  9. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    make sure you check the correct php.ini file. For example, on my debian server, there's one for apache, one for the cli (command line), and if you're using cgi mode or something, there could be a different one for that. To find out more information about your php configuration, you can create a php file (name it something like info.php or test.php) and put it in your web folder with this code:

    <?php phpinfo(); ?>

    Load the file with your browser, and see what it says for your php.ini, and the disable_functions.

  10. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    If you're still stuck, try the contact form again, looks like my webserver was a bit slow this morning a couple times.

  11. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    Martin, check to see if your vps has suhosin enabled. It is possible that the exec function is being blocked by suhosin via this settings:

    suhosin.executor.func.blacklist

    You can either just remove 'exec' from the list and restart apache, or completely disable suhosin (most newer distros don't use it anymore).

  12. Martin
    Member
    Posted 11 months ago #

    Well I can't really add too much.
    I originally started with Centos and Zpanelx for the admin which is when this error happened and I disabled the plugin. After getting peeved off with Zpanel, I deleted the VPS image and went with Ubuntu 12.04 and Virtualmin and this problem went away so I'm happily Optimizing now.
    Sorry I can't help any further.

  13. nosilver4u
    Member
    Plugin Author

    Posted 11 months ago #

    Martin, sounds like you had the exact same setup as rmada (centos with zpanelx), and the exec() function was being blocked by suhosin. The next version will have proper detection for suhosin in php. Ubuntu is what we run on our server at work, so that is a good pick.

  14. Martin
    Member
    Posted 11 months ago #

    I lived and learnt :)
    Now learning to optimise the thing haha

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.