WordPress.org

Ready to get started?Download WordPress

Forums

Profile Builder - front-end user registration, login and edit profile
[resolved] New version has fatal error (34 posts)

  1. RetroFacto
    Member
    Posted 1 year ago #

    Just updated to the new version of the plugin, hoping it would fix the problem I'm having with the Lost Password recovery.

    Unfortunately, it was worse than that, I got a fatal error when trying to activate the upgrade.

    : Call to undefined function wppb_return_bytes() in /home1/tweetbox/public_html/localmusicteacher/wp-content/plugins/profile-builder/index.php on line 67

    http://wordpress.org/extend/plugins/profile-builder/

  2. yr4ik
    Member
    Posted 1 year ago #

    in /wp-content/plugins/profile-builder/index.php (line: 67 and 69)
    rename wppb_return_bytes -> return_bytes

  3. julia312
    Member
    Posted 1 year ago #

    I'm having the same problem:

    Fatal error: Call to undefined function wppb_return_bytes() in /home/dacapkim/public_html/wp-content/plugins/profile-builder/index.php on line 67

  4. qstudio
    Member
    Posted 1 year ago #

    @yr4ik fix seems to get around the problem - thanks

  5. julia312
    Member
    Posted 1 year ago #

    Yes, that works, thanks.

  6. Sean Donovan
    Member
    Posted 1 year ago #

    Yup, same bug and @yr4ik fix worked. Thanks. (@developers - ??)

  7. Rajan V
    Member
    Posted 1 year ago #

    @yr4ik thanks please explain why this error coming i m learner in WordPress

  8. barinagabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    and sorry for the activation error in the new version. We are working on it as we speak.

    Gabriel

  9. RetroFacto
    Member
    Posted 1 year ago #

    Thank you.

  10. barinagabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Version 1.1.44 should fix this, and another bug we found!

  11. myroxie
    Member
    Posted 1 year ago #

    I have this same problem, but my site is now down because of it. I only discovered it because I use Infinite WP to manage my sites and it installs a Worker plugin on the site and when I tried to access the site to update something, I got this fatal error. Then when I tried to get into the backend of the site I got a white screen with the error on it. NO MORE SITE!!!
    Fatal error: Call to undefined function wppb_return_bytes() in/home/goodwo7/public_html/writerscelebratewriters.com/wp-content/plugins/profile-builder/index.php on line 67

  12. myroxie
    Member
    Posted 1 year ago #

    I tried the "fix" and now I can't even get to my site at all. Not even the blank screen with the error message is showing up. I made the change to lines 67 and 69 and I reuploaded the index.php and overwrote the original (which I saved). And now, nothing!!!!

    Fatal error: Call to undefined function wppb_return_bytes() in/home/goodwo7/public_html/writerscelebratewriters.com/wp-content/plugins/profile-builder/index.php on line 67

  13. RetroFacto
    Member
    Posted 1 year ago #

    I'm assuming you have FTP access to your site?

    Delete the profile-builder folder entirely, and then open up your wordpress admin backend, go to plugins and download it again.

    There is a new version with the fixes. That should do the job. And all your setting will be as they were.

  14. myroxie
    Member
    Posted 1 year ago #

    Actually, now I;m getting a 500 error.
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@writerscelebratewriters.goodworx.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

  15. RetroFacto
    Member
    Posted 1 year ago #

    If this is all since you started amending the files for profile builder, I strongly suggest you delete the profile builder folder and re-install.

  16. barinagabriel
    Member
    Plugin Author

    Posted 1 year ago #

    I subscribe! Using a ftp managere, like filezilla or total commander, delete the profile builder folder manually and just re-install the latest version.

    Gabriel

  17. myroxie
    Member
    Posted 1 year ago #

    The site came back up, but with all widgets gone-- including profile builder and the user-submitted form, login, etc. but it also messed up another plugin I'm using.

  18. myroxie
    Member
    Posted 1 year ago #

    I do have ftp access, but if I delete the whole folder and reinstall it from scratch, why won't I lose all my settings?

  19. RetroFacto
    Member
    Posted 1 year ago #

    DELETE ONLY THE PROFILE BUILDER FOLDER!!

    Because your settings are stored in the database and not in the files.

    I'm not sure what else you've done but it sounds like you've created one heck of a mess in there. Be careful.

  20. myroxie
    Member
    Posted 1 year ago #

    Why couldn't I just update it through WordPress? In the usual way?

  21. myroxie
    Member
    Posted 1 year ago #

    All I did was download the index.php from the Profile Builder plugin folder. Then I made the suggested changes to lines 67 and 69 and then I reuploaded it to the same location. I didn't touch anything else.

  22. RetroFacto
    Member
    Posted 1 year ago #

    If you are now able to fully get back into the wordpress admin, then you should be able to update it yes.

  23. myroxie
    Member
    Posted 1 year ago #

    It's all back. Don't know why it went away. Don't know why it's back. But I'm pleased that it is.

    I updated the plugin through WP. I checked the Widgets page and there were NO widgets even registered there. Then I did some diddling around with my theme framework (Headway) and resaved some pages and, voila, it's working again. thanks for your support.

  24. RetroFacto
    Member
    Posted 1 year ago #

    Hurrah!

    Glad it's working, sounds like you had added problems with your theme.

    :)

  25. barinagabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Awesome! I will have to thank you too, RetroFacto for your involvement!

  26. RetroFacto
    Member
    Posted 1 year ago #

    No problem. Happy to help. And if you need anyone to test out new versions of the PRO version ...

    ;-)

    ha ha

  27. myroxie
    Member
    Posted 1 year ago #

    God only knows why. I swear. I didn't touch it. I was very, very careful ONLY to change lines 67 and 69. Didn't get anywhere near any other folders in the backend. I swear. All's well that ends well, but I wish I had more understanding about why these things happen. I just started a thread on Headway's support forum. So maybe there's an answer. Somewhere. Thanks.

  28. karlg6
    Member
    Posted 1 year ago #

    Profile Builder 1.1.54 on WordPress 3.5.1 does not activate, giving errors:

    Warning: require_once(wppb_plugin_dir/functions/basic.info.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/73/4999173/html/wp-content/plugins/profile-builder/functions/functions.load.php on line 71

    Fatal error: require_once() [function.require]: Failed opening required 'wppb_plugin_dir/functions/basic.info.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/73/4999173/html/wp-content/plugins/profile-builder/functions/functions.load.php on line 71

    It was working until I updated it :( . I tried uninstalling and reinstalling it, and deleting the directory and reinstalling it, but it's made no difference (except I've now also lost the profile builder data).

  29. barinagabriel
    Member
    Plugin Author

    Posted 1 year ago #

    @karlg6

    Hello, and thank you for reporting this. This error says that the script is trying to include a file, which he doesn't see, in this case profile-builder/functions/basic.info.php ... but if you download the archive and check, the file does exist.

    So what I would recommend is that you deactivate (not uninstall, but I suppose you already uninstalled it also), and then install it again.

    If it still doesn't work, send me FTP credentials, and a wp account with admin rights to gabriel@cozmoslabs, and I will take a look at it myself. Also add a link to this thread, please.

    We are sorry for any problems caused, but we will help you fix it.

    Regards,
    Gabriel

  30. myroxie
    Member
    Posted 1 year ago #

    I don't know if it's due to the update, but I just checked my site with Profile Builder in use, and when I view it as a non-logged in visitor, I am given the opportunity to login, but not to register. Under Register, it gives this message:Only an administrator can add new users. I tried deactivating and reactivating and it didn't make any difference.

    The site is http://writerscelebratewriters.com and the page is http://writerscelebratewriters.com/submit-a-memoir/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic