WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
new version (8 posts)

5 stars
  1. zappmania
    Member
    Posted 1 year ago #

    its a great plugin but currently is not working for me even after upgrading to new version didn't solve this.

    I am using AWS Ubuntu server apache with varnish

    we have disabled all the plugins. and tried every thing as mentioned but it is still not able to connect.
    XMLRPC file always shows "XML-RPC server accepts POST requests only" which looks fine.

    I have also checked the cURL and it looks fine.

    for more details check this page : http://www.zappmania.in/test.php

    compatibility test details :

    SITE_URL: http://www.zappmania.in
    HOME_URL: http://www.zappmania.in
    
    TEST: HTTP Connection
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Sat, 27 Jul 2013 07:27:53 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [vary] => Cookie
                [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => OK
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )
    
    TEST: HTTPS Connection
    Array
    (
        [headers] => Array
            (
                [server] => nginx
                [date] => Sat, 27 Jul 2013 07:27:54 GMT
                [content-type] => text/plain;charset=utf-8
                [connection] => close
                [vary] => Cookie
                [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
                [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                [cache-control] => no-cache, must-revalidate, max-age=60
                [pragma] => no-cache
                [x-hacker] => Jetpack Test
            )
    
        [body] => OK
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )
    
    TEST: Self Connection
    WP_Error Object
    (
        [errors] => Array
            (
                [http_request_failed] => Array
                    (
                        [0] => Operation timed out after 5001 milliseconds with 0 bytes received
                    )
    
            )
    
        [error_data] => Array
            (
            )
    
    )

    Above ALL Was the History Now this is working perfectly Fine..

    Thanks

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi there!

    It seems you didn't receive my last email in reply to your support request last week.

    As I mentioned there, something in your server configuration seems to modify the output of the cURL requests to your site. One of our developers mentioned that the problem could be linked to your Varnish configuration. Could you try to make the changes suggested in this post, and let me know if it helps:
    http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/

    Thanks!

  3. zappmania
    Member
    Posted 1 year ago #

    Hi there,

    As already mentioned I have checked all of this and nothing works.
    the reply i got mentioned that my sites cURL is not working properly.

    But i am already using other plugins which is using cURL and running without a glitch.

    [Signature moderated]

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    As I mentioned in our email exchange, something seems to be filtering the output of the cURL output.

    When making a test connection to your site, I get the following result:

    $ curl -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://www.zappmania.in/xmlrpc.php' && echo
    HTTP/1.1 200 OK
    Server: cloudflare-nginx
    Date: Fri, 16 Aug 2013 12:06:45 GMT
    Content-Type: text/plain
    Transfer-Encoding: chunked
    Connection: keep-alive
    Set-Cookie: __cfduid=d24f9703a855f71fadc0ab276f32c45e51376654795917; expires=Mon, 23-Dec-2019 23:50:00 GMT; path=/; domain=.zappmania.in
    X-Powered-By: PHP/5.3.10-1ubuntu3.6
    Cache-Control: max-age=691200
    Expires: Sat, 24 Aug 2013 12:06:36 GMT
    Vary: User-Agent,Accept-Encoding
    X-Varnish: 428103120
    Age: 0
    Via: 1.1 varnish
    CF-RAY: 9edffda7ab40583
    
    XML-RPC server accepts POST requests only.

    However, that's the expected output:

    $ curl -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://wordpress.com/xmlrpc.php' && echo
    HTTP/1.1 200 OK
    Server: nginx
    Date: Fri, 16 Aug 2013 12:08:08 GMT
    Content-Type: text/xml; charset=UTF-8
    Content-Length: 181
    Connection: keep-alive
    X-hacker: If you're reading this, you should visit automattic.com/jobs and apply to join the fun, mention this header.
    X-Frame-Options: SAMEORIGIN
    
    <?xml version="1.0" encoding="UTF-8"?>
    <methodResponse>
      <params>
        <param>
          <value>
          <string>Hello!</string>
          </value>
        </param>
      </params>
    </methodResponse>

    Something in your server configuration seems to be filtering the output of this request. Could you check your server configuration for modules that could cause this issue?

    Thanks!

  5. Pothi
    Member
    Posted 1 year ago #

    @Jeremy

    As I mentioned there, something in your server configuration seems to modify the output of the cURL requests to your site. One of our developers mentioned that the problem could be linked to your Varnish configuration.

    You are right. I have been watching this thread as well. Here's the result of test connection from my end...

    curl -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://www.zappmania.in/xmlrpc.php' && echo
    HTTP/1.1 200 OK
    Server: cloudflare-nginx
    Date: Fri, 16 Aug 2013 13:16:52 GMT
    Content-Type: text/plain
    Transfer-Encoding: chunked
    Connection: keep-alive
    Set-Cookie: __cfduid=d0851e5ccf259a8cc1239cf7ae322cf151376659008789; expires=Mon, 23-Dec-2019 23:50:00 GMT; path=/; domain=.zappmania.in
    X-Powered-By: PHP/5.3.10-1ubuntu3.6
    Cache-Control: max-age=691200
    Expires: Sat, 24 Aug 2013 13:16:49 GMT
    Vary: User-Agent,Accept-Encoding
    X-Varnish: 428103249
    Age: 0
    Via: 1.1 varnish
    CF-RAY: 9ee66b4e68603a6
    
    XML-RPC server accepts POST requests only.

    After a few seconds, I did the same test again and here's the result...

    curl -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://www.zappmania.in/xmlrpc.php' && echo
    HTTP/1.1 200 OK
    Server: cloudflare-nginx
    Date: Fri, 16 Aug 2013 13:16:56 GMT
    Content-Type: text/plain
    Transfer-Encoding: chunked
    Connection: keep-alive
    Set-Cookie: __cfduid=dd1d4ec9172ab1bddef97ec804e7dd62b1376659016145; expires=Mon, 23-Dec-2019 23:50:00 GMT; path=/; domain=.zappmania.in
    X-Powered-By: PHP/5.3.10-1ubuntu3.6
    Cache-Control: max-age=691200
    Expires: Sat, 24 Aug 2013 13:16:49 GMT
    Vary: User-Agent,Accept-Encoding
    X-Varnish: 428103250 428103249
    Age: 4
    Via: 1.1 varnish
    CF-RAY: 9ee66e2e2ba03a0
    
    XML-RPC server accepts POST requests only.

    It clearly shows that Varnish caches the output (of 'xmlrpc.php') that shouldn't be cached. Also, it is not a good idea to have Cache-Control: max-age=691200 for such requests.

    @zappmania

    You can get an overview on how to bypass such requests in Varnish from this code sample.

    I hope that helps. I also hope you'd start a support thread (instead of review thread), when something doesn't work for your site with any plugin hosted here.

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    @zappmania, As stated to you many times before, please stop using signatures on WordPress.org forums.

    Now see this article: http://codex.wordpress.org/Forum_Welcome#Being_.27Mod_Watched.27_or_Banned .

  7. zappmania
    Member
    Posted 1 year ago #

    Hi Andrew,
    I was not aware of this before but will keep this in mind.
    I was putting my sites address for only that if there is someone out there who can visit my site and can help me out on this.

    Thanks

  8. zappmania
    Member
    Posted 11 months ago #

    Hi there,

    Now the plugin is working fine and I am really happy with the performance.

    My rating now is 5 Star.. :d

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.