WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New User Issues with Site address URL (3 posts)

  1. maximillianrg
    Member
    Posted 8 months ago #

    Hello, my name is Max, and thank you for reading this post. I've never used wordpress so be gentle, this is my first time.

    My issue is that my new site defaults to maxgilpin.info/wordpress1/ rather than maxgilpin.info and I've burned 8+ hours trying to fix this without success. My ISP is register.com and they are no help at all. here is what I have tried

    - WP 3.5.1 was installed through the register.com control panel
    - WP is installed in a folder called wordpress1
    - WP was updated to 3.7.1 and all plug ins are current
    - Changed site address url from http://maxgilpin.info/wordpress1 to http://maxgilpin.info and then move the index.php and .htaccess from the wp folder to the root folder but no luck.

    Any Suggestions would be most appreciated

  2. Daniel Kanchev
    Member
    Posted 8 months ago #

    Hi Max,

    The issue is most probably that you're site is still configured to use the old address which includes the sub-folder. You need to move all the files from the sub-folder to the main root web folder. After that edit the wp-config.php file and add following two lines:

    define('WP_HOME','http://maxgilpin.info');
    define('WP_SITEURL','http://maxgilpin.info');

    This way you will configure the site to use the main URL without the sub-folder. For more details and other options you can check this link:

    http://codex.wordpress.org/Changing_The_Site_URL

  3. maximillianrg
    Member
    Posted 8 months ago #

    The problem is resolved - here are the steps I went through:

    1)Logged into my register.com control panal and removed wordpress

    2)Logged into my domain using ftp and deleted wordpress1 directory, index.php and .htaccess file

    3)Logged into my register.com control panal and installed wordpress 3.5.1 in wpress directory

    4) Logged into WP and updated to 3.7.1

    5) Tested : defaults to example.com/wpress/

    6) Logged into WP and changed site address (URL) from http://example.com/wpress to http://example.com

    7) Logged into my domain using FTP and – copied index.php4 and .htaccess from wpress to root directory.

    8) Tested : Fatal error: require(): Failed opening required ’/data/21/3/60/16/3223505/user/3598901/htdocs/wp-blog-header.php’(include_path=’.:/usr/share/php:/usr/services/vux/lib/php’) in /data/21/3/60/16/3223505/user/3598901/htdocs/index.php on line

    9) Logged into WP, went to setting > permalinks and presses save changes

    10) Tested : Fatal error:

    11) Edited index.php in root and replaced
    require( dirname( FILE ) . ’/wp-blog-header.php’ ); with
    require(’./wpress/wp-blog-header.php’);

    12) Tested – Worked

Reply

You must log in to post.

About this Topic