WordPress.org

Ready to get started?Download WordPress

Forums

124

NEW: Upgrade to 1.5.2 (95 posts)

  1. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Read the dev blog.

    Backing up your database and files is recommended before ANY upgrade

    ==== The official method.====
    Upgrade just like any other upgrade:
    - delete
    /wp-admin
    /wp-includes (but NOT your languages folder!!)
    all wp-* files at root EXCEPT wp-config.php
    (Leave /wp-content and /wp-images alone.)

    - upload the replacements for what you have deleted (so don't upload /wp-content or /wp-images)

    Use the link in the Dev blog to read the Codex page on upgrading.

    There is no need to run upgrade.php after doing this.

    ====The UNofficial method====
    Right now I don't have the changelog, but a list of the changed files is below. If you do it this way, you are on your own as far as support is concerned.
    wp-admin/categories.php
    wp-admin/edit-page-form.php
    wp-admin/post.php
    wp-admin/upload.php
    wp-admin/users.php
    wp-commentsrss2.php
    wp-includes/comment-functions.php
    wp-includes/functions-post.php
    wp-includes/pluggable-functions.php
    wp-includes/template-functions-category.php
    wp-includes/version.php
    wp-settings.php
    xmlrpc.php

    These can be downloaded from here:
    http://firasd.ath.cx/wordpress-changed-final.zip

    =====
    Before posting questions, please read all other posts in this thread and also the Codex page. It may well save you time.

  2. vkaryl
    Member
    Posted 9 years ago #

    Thanks Podz - was just trying to get around the thunderstorm to post myself!

    And thanks to Westi/Peter J. Westwood for the version check plugin which notified me immediately that there WAS a new version!

  3. Firas
    Member
    Posted 9 years ago #

    The changed files zip could be down for a few, I'm just verifying some things.

    Update--here you go:
    http://firasd.ath.cx/wordpress-changed-final.zip

  4. fcdm
    Member
    Posted 9 years ago #

    Thank you @podz. Went absolutely smooth!

  5. NekoFever
    Member
    Posted 9 years ago #

    Nice, they've added a 'Save and Continue Editing' box to the page edit screen. As someone who habitually saves every sentence or so that's a real godsend.

  6. Lorelle
    Member
    Posted 9 years ago #

    And it is taking less time on the SAVE for the Write Post screen. Wow. Thanks for the improvements.

  7. For those who are curious, Owen (ringmaster) has posted a "plain english" list of changes in v1.5.2 here: http://wordpress.org/support/topic/41894

  8. bazil
    Member
    Posted 9 years ago #

    Just updated my site, worked like a charm. Also wanted to give a thanks to those that worked up the updates. I feel they responded to this issue quite fast.

  9. elyonline
    Member
    Posted 9 years ago #

    Matt says 'This is a very straight-forward upgrade, you just need to upload the new files over the old'

    Is that OK?

    Thanks

  10. Michael Bishop

    Posted 9 years ago #

    @ely--follow the instructions in the first post, that's what is meant by upload over new. Also, after backing up, it's always best to delete the old files, THEN upload the new files. Overwriting isn't always perfect.

  11. NekoFever
    Member
    Posted 9 years ago #

    Yeah, depending on the FTP program they mostly just get uploaded over the top of the old files and very occasionally this can cause an error since the old one isn't completely deleted. Deleting it and then uploading the new one freshly makes sure that there's no risk of that happening.

    Some FTP programs like the one I use (Transmit) actually make deleting the original file part of the process of uploading a new one, but unless you know that it's best to be safe.

  12. Lorelle
    Member
    Posted 9 years ago #

    We're already starting to get error reports around here that come from people NOT deleting the files FIRST before uploading the new.

    And DO NOT DELETE wp-config.php.

    Follow the instructions at the top of the page and your upgrade will take only a few minutes. Just don't try any shortcuts or you will end up here and we'll ask "did you delete the files before uploading". ;-)

  13. iddapidda
    Member
    Posted 9 years ago #

    Updated last night, worked like a charm.
    Thanks :-)

  14. feuman
    Member
    Posted 9 years ago #

    I used the unofficial way... no problems at all. Thanks for the great work.

  15. swingcheese
    Member
    Posted 9 years ago #

    same for me, thank you...i have an error on some pages, maybe somebody knows why...
    Warning: Invalid argument supplied for foreach() in /homepages/12/d109339308/htdocs/philippe/wp-includes/template-functions-post.php on line 378
    it is on my blog http://www.swingcheese.net
    if you go to the navbar at the following pages
    archive, links and photos (only)
    thank you in advance.
    cheers,
    philippe

  16. Vryce
    Member
    Posted 9 years ago #

    Easy upgrade for me. Thanks for posting these threads each time there is an upgrade.

  17. villas
    Member
    Posted 9 years ago #

    Please !!! DO NOT FORGET THE INTERNATIONALIZATION RULES GUYS !!!

    DO NOT DELETE \wp-includes\languages FOLDER !!!

    THANKS.

    Villas

  18. Joni
    Member
    Posted 9 years ago #

    I went ahead and renamed my two original folders, wp-admin-old and wp-includes-old, and then uploaded the new, folders and all. That way, I could fish around in the old folders for a file if need be. Then once the site looked good to go (after kicking all the tires), I just zappd the two *-old folders.

    HTH someone else.

  19. Firas
    Member
    Posted 9 years ago #

    jonimueller: excellent idea. This should be the recommended way :)

  20. stengazette
    Member
    Posted 9 years ago #

    >>Yeah, depending on the FTP program they mostly just get uploaded over the top of the old files and very occasionally this can cause an error since the old one isn't completely deleted.<<

    That's kind of vague... I've been doing FTP overwrites for probably 10 years now and never encountered the problem. I use ws_ftp pro so maybe that doesn't have the problem, or maybe I've been lucky. The ftp server is (I think) part of Apache, running under Unix. Can you narrow the problem down to specifi ftp clients, servers, or OSs? Actually it sounds like either an OS bug or a transfer mode problem (e.g. overwriting an ascii file with a binary transfer.
    FWIW this is my second upgrade, and I did the first one (...2 to ....3?) this way with no problems, but sure wish it could be automated. Also FWIW my host provides WP with one button installation, and on the last upgrade they told everybody to click the button to install the new version. Never heard about any problems, but they may not have many wp users.
    Thanks... Miles

  21. Mark (podz)
    Support Maven
    Posted 9 years ago #

    jonimueller - I agree with Firas. Top idea !

    stengazette - you would be amazed at the number of errors caused by faulty overwriting. Given that deleting the old files takes but a few seconds, it's worth doing. I would also never trust ANY host that says to upgrade with one click - that puts everything at risk of being changed.

  22. Mark (podz)
    Support Maven
    Posted 9 years ago #

    villas - I have edited the post above. Sorry !

  23. billsaysthis
    Member
    Posted 9 years ago #

    *red face* I upgraded two installs just now and one was fine while the other... isn't. I deleted the wp-config on the bad one accidentally and in trying to recreate it, I'm just not having any luck. I don't recall installing any plugins that should come into play so I copied the good version over and put in the correct values for the four fields. Still, I get the same message:

    "Error establishing a database connection"

    Now I have phpMyAdmin on the server so I checked and the user and wp database, with all the tables, are still there. Any suggestions?

  24. villas
    Member
    Posted 9 years ago #

    '' villas - I have edited the post above. Sorry ! ''

    Thanks Podz .

  25. skippy
    Member
    Posted 9 years ago #

    Make sure that the username and password in wp-config.php are exactly as you typed when using phpMyAdmin.

    Makes sure you're uploading via FTP in ASCII mode.

  26. Marc
    Member
    Posted 9 years ago #

    On a related note: I'm about to upgrade, because I use a large number of plugins it normally take me longer than most experiance. (Yes it's my problem).

    I'll ask here something that that I have posted on the mosquito but will again in the off chance one of the devs will see it.

    Can a function be added that allows a checkbox for enabling and disabling plugins? While I'm far from being a coding geek it would seem to be a simple addon or plugin, any takers?

  27. jennmiller
    Member
    Posted 9 years ago #

    I'm with you, Marc. On one of my sites, I'm "down to" only 22 plugins used ;) Disabling them takes twice as long as actually upgrading.

  28. vkaryl
    Member
    Posted 9 years ago #

    Make that three of us: a global disable/enable for plugins would be SUPERB!

  29. Beel
    Member
    Posted 9 years ago #

    I'm a bad boy, I just leave the "lights" plugged in and hope for the best.

  30. jennmiller
    Member
    Posted 9 years ago #

    I did that one time, Beel, and all heck broke loose. I actually forgot this time and (thankfully) nothing bad happened. *whew*

124

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags