WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] new update messed something up (7 posts)

  1. soreelflix
    Member
    Posted 1 year ago #

    i get

    Warning: Invalid argument supplied for foreach() in /home/soreelfl/public_html/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 1096
    5261

    When i try to upload a image to a post ...and the upload freezes and stays at ..crunching...and then have to exit browser to refresh ....cant upload images now to my site

    never did this until the new update

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    same error as http://wordpress.org/support/topic/something-wrong-invalid-argument-and-cannot-modify-header?replies=2 apparently. What kind of image are you uploading, and did you change any of the options after updating?

    Also, can you post the contents of the debug block on the settings page?

  3. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    also should ask, are you on 1.2.0 or 1.2.1?

  4. soreelflix
    Member
    Posted 1 year ago #

    i have 1.2.1...also the image is a jpeg

    i have tried it with about 10 different photos even a couple oi have already have on my site

    i havent changed any options after updating

    here is the debug info

    jpegtran version: Independent JPEG Group's JPEGTRAN, version 6b 27-Mar-1998
    optipng version:
    gifsicle version:
    GD: OK
    Imagemagick convert installed: NO
    safe mode: Off
    Operating System: Linux
    exec(): enabled
    getimagesize(): OK
    mime_content_type(): OK

  5. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    as it would turn out, it's not really an 'error', but a variable I forgot to initialize. Unfortunately, it trickles down and breaks the output that is supposed to show up when you upload an image. I'll have 1.2.2 out today.

  6. soreelflix
    Member
    Posted 1 year ago #

    ok thanks

  7. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    I should have mentioned that you can also get rid of this error by turning off WP_DEBUG in your wp-config.php
    i'm working on one more quirk for 1.2.2 but hopefully I'll still get it out the door today.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.