WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members
New update 25/11/2013 (9 posts)

  1. liannemurphy
    Member
    Posted 8 months ago #

    Installed the latest version and it broke my website. No content was being display, only the header.

    Re-installed the older version......

    http://wordpress.org/plugins/wp-members/

  2. Chad Butler
    Member
    Plugin Author

    Posted 8 months ago #

    What version of wordpress are you running?

  3. liannemurphy
    Member
    Posted 8 months ago #

    Hi Chad,

    Using this version WordPress 3.5.1

    Thanks

  4. respectyoda
    Member
    Posted 8 months ago #

    You should try updating WordPress to its latest version (3.7.1).

  5. liannemurphy
    Member
    Posted 8 months ago #

    Hey Yoda,

    Ok, I'll try that tonight updating both versions.

    Cheers

  6. Chad Butler
    Member
    Plugin Author

    Posted 8 months ago #

    The 2.8.8 release had a function call in it that was intended to wait until 2.9 - has_shortcode. This tests for the presence of a shortcode, which in this case replaces a function that WP-Members had to check for the WP-Members shortcode.

    The problem here is that has_shortcode was introduced in WP 3.6, so running WP less than 3.6 is going to cause a problem.

    This wasn't supposed to be included until the 2.9 release when we would also institute a more official policy on WP compatibility, supporting more recent versions. I am going to break protocol and roll this back in the 2.8.8 release, since it wasn't supposed to be included. That way, only the users who have downloaded so far will have been effected (and if they are running WP 3.6+, they won't be). I'll post here when the rollback is up.

  7. Chad Butler
    Member
    Plugin Author

    Posted 8 months ago #

    OK, the issue has been corrected in the download package.

    The problem here is that the plugin has been compatible with WP 3.1 and up in the past and I've never instituted an official policy on WP compatibility.

    Starting with 2.9.0, which is expected to be the next release, I will be instituting a more official policy of WP version support for the plugin. This will probably be supporting the current major WP version and one major version prior. For example, at present, WP is version 3.7.1, so we would support WP 3.7.x and 3.6.x.

    Whatever is decided will be included in the release notes. But WordPress site management best practices would dictate that it is a very bad idea to continue to use outdated versions of the software.

    With that in mind, it is a break from protocol to change an update, but this was an unintended issue. Obviously, it is not going to effect any users with WP 3.6 and above (which I certainly would hope would be the vast majority of users). But because there wasn't an appropriate announcement alerting users to the coming shift in compatibility policy, I feel the need to accommodate that.

  8. liannemurphy
    Member
    Posted 8 months ago #

    Hi Chad,

    Thanks for looking into this and updating us. I have updated both versions and seems to be working ok.

    Thanks

  9. respectyoda
    Member
    Posted 8 months ago #

    Chad, that's great you corrected the issue in the download package. This should definitely help a lot of clients by acknowledging the need to keep WordPress updated.

    Liannemurphy, that's good to hear! I wish you the best with your project.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.