WordPress.org

Ready to get started?Download WordPress

Forums

New Themes not listed (17 posts)

  1. SRD
    Member
    Posted 8 years ago #

    Hi Folks,

    I've uploaded three new themes into invidual folders under wp-content\themes.

    They are
    wp-content\themes\slaty
    wp-content\themes\summertime
    wp-content\themes\sublimenal

    However, in WordPress admin Presentation management, under Themes Available, there are only the two default themes.

    I've double-checked the themes are in their own subfolder on the remote host under themes. I've chmod'ed them to 777 and the issue remains.

    Everything else about WordPress is working fine.

    One thing to note is my web host has a feature to automatically install WordPress which I have used. The install directory is \__store\blog, and the blog directory is \blog. \blog is empty except for a .htaccess file performing mod_rewrite to repoint to \__store\blog.

    Hence I have uploaded the themes to
    \__store\blog\wp_content\themes
    which is where the default theme folders are.

    I have even tried uploading theme to
    \blog\wp_content\themes (I created this folder structure from scratch)
    but this makes no difference.

    I don't understand why WordPress can see the two defaults, but not the other three themes. The 5 themes exist side by side in
    \__store\blog\wp_content\themes.

    Do you have any suggestions or work arounds?

    I will try reinstalling in the mean time.

    Thanks and regards,

    Steve

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    wp-content\themes\slaty\style.css
    or
    wp-content\themes\slaty\slaty\style.css

    The top one will work, the bottom one will not.

  3. SRD
    Member
    Posted 8 years ago #

    I've renamed \__store\blog to \old.__store\blog
    and \blog to \old.blog

    I then ran the auto install script, which reinstalled WordPress okay.

    I logged into WordPress admin, selected Presentation, but got a 404.

    I recreated \blog\.htaccess which contains mod_rewrite code to rewrite \blog to \__store\blog, and that issue was fixed. (note: the \blog\.htaccess file is part of the auto-install process).

    I again uploaded the themes to \__store\blog\wt_content\themes, which is where the default themes were already. I jump back into WP Admin and still only the defaults are visible to activate.

    *Confused*

  4. SRD
    Member
    Posted 8 years ago #

    Thanks podz.

    Yes, the location is
    wp-content\themes\slaty\style.css

    Same for the other two.

    Cheers, Steve

  5. SRD
    Member
    Posted 8 years ago #

    I've removed WP completely and installed WP myself, rather than use the web host's auto-install.

    It's working now. :-)

  6. sprboston
    Member
    Posted 8 years ago #

    I too am having a problem with themes. I checked the previous posts and my "themes" do live in the following location on my site:
    ftp://sprboston.com/public_html/wp-content\themes\ocadia\style.css

    But when I go to the "presentations" section of WordPress, the option to selece Ocadia isn't available. is there a way to refresh that page? I see wordpress classic 1.5 and wordpress default 1.5...but not the new one I downloaded from WordPress then uploaded to my files...

    Any ideas? The rest of wordpress seems to be working just fine, although I'd like to adjust the "description" at the top because it's too close to the margins...any ideas there??

    Thanks in advance for your help.

  7. moshu
    Member
    Posted 8 years ago #

    Nope. your stylesheet is here:
    http://www.sprboston.com/style.css

  8. geegee
    Member
    Posted 8 years ago #

    Please help, I don't know alot about code but I have been trying to use the slaty theme. I know how to make links in the admin panel fine. But they aren't showing up anywhere when I look at the site. Do I have to put something in one of the templates to make the links show up? I looked at the demo page for the theme but there's nothing there about how to make links show up. That doesn't seem to work in this theme just using the admin panel and making link categories and links. I have wp 1.5, thanks this is really got me stuck.

  9. chimommy
    Member
    Posted 8 years ago #

    @ Sprboston...

    Looking through your site, it appears your themes folder is located at the following url...

    http://sprboston.com/seanssoapbox.html/wp-content/themes/

    If this is not how it is meant to be, you may have to check the settings in your WP Admin section.

    @ GeeGee...

    I'm not familiar with that theme at all but you may have to add the following to the sidebar.php file in the theme's directory.

    <?php get_links_list(); ?>

  10. geegee
    Member
    Posted 8 years ago #

    Thank you, I tried that but it made my links show up, with no link category titles. They showed up in a grey box with huge spaces between them. The code you gave me above is also in the links.php template but I tried removing that and still no link category titles, same grey box with lotsa space between the links themselves, AND when I moused over the links a blank white image showed. hehe *sigh I appreciate your input though, thanks for trying:)

  11. estjohn
    Member
    Posted 8 years ago #

    Also, I have noticed if somehow a file gets correupt, incomplete, or is not compatible, it wont show up.

  12. geegee
    Member
    Posted 8 years ago #

    Thanks estjohn but that's not the deal. I emailed the theme creator a few days ago, funny he doesn't have links on his page either, he has Categories, but not Link categories/links. He isn't real good at anwering email either. Spend hours and finally find a theme you love but end up NOT loving anymore. *sigh This IS a great theme if you don't care about having links.

  13. Penda
    Member
    Posted 8 years ago #

    GeeGee - this is also a great thgeme if yoyu don't want people commenting on your site using FireFox.

    I can't get any of the links to work on an archived page and no one (especially the creator) seems to know how to make it work.

  14. moshu
    Member
    Posted 8 years ago #

    Penda,
    The archive.php template (almost in all of the themes) uses Template_Tags/the_excerpt in which case - as the description says: HTML tags and and graphics are stripped from the excerpt's content.

    As for not being able to comment on single pages, there is an error message on the site:

    Parse error: parse error, unexpected T_STRING in /home/www/pendasrealm.com/diner/wp-content/themes/slaty/comments.php on line 54

  15. Penda
    Member
    Posted 8 years ago #

    I fixed the parse error - something needed to be commented out, and I took care of it. So that page is now fine except for the fact that no one using FF can post.

    You can however post comments using IE. All of the Links work in IE and you can comment - but not in FF. It is not the "Template_Tags/the_excerpt" tag. I still cannot comment on single pages. I can comment on single pages with my other themes. and they have the "Template_Tags/the_excerpt" in the Archive.php.

    What else?

  16. moshu
    Member
    Posted 8 years ago #

    Don't mix the two issues.
    1 You were complaining about the links "not working" in archive view - that's du to the use of the_excerpt. Replace it with the_content, if you don't like it.
    2. The single.php never uses the_excerpt, so not being able to comment is a totally different issue. Ask the author of the theme to fix it, or switch to another theme.

    Not to mention: don't hijack a topic if your problem is not related :)

  17. Penda
    Member
    Posted 8 years ago #

    Fine - I will start a new topic so you won't help me over there either.

    I may have mistated my original question, but the problem remains - comments can not be posted from FireFox with the SlatyStained theme.

    I wasn't hijacking the thread so much as I was echoing another's (GeeGee's) issues with a stated theme(Slaty).

    Really, If you're not going to help me, then don't post. It's not helpful.

Topic Closed

This topic has been closed to new replies.

About this Topic