WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] New subscribers not being added (30 posts)

  1. DigitalByJess
    Member
    Posted 1 year ago #

    Love the plugin, but subscribers are not being added to the back end. I have a subscribe2 widget on the homepage sidebar as well as on this page:

    Subscribe

    And neither seems to be working. They submit and redirect to the homepage, but no email is added to the subscriber list.

    Thank you!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @DigitalByJess,

    In Subscribe2->Settings under Appearance change the drop down option where it says "Set default Subscribe2 page as ID" to the page title of your Subscribe page.

    You will also need to do the same thing in the widget Settings on the Appearance->Widgets page within WordPress.

  3. DigitalByJess
    Member
    Posted 1 year ago #

    @mattyrob, thank you for the response!

    Subscribe2 > Settings > Appearance already has the page title of the Subscribe page selected. In fact, it is the only available option.

    However, I do not see where there are widget settings with that option. What am I missing?

  4. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @DigitalByJess,

    If you are using the built in Widget (enabled on the Subscribe2->Setting page) it should be in the Widget with you click on it on the sidebar area to open it up for the settings.

  5. DigitalByJess
    Member
    Posted 1 year ago #

    Ah, I was not using the built-in widget. I'm using it now, and it works. Thank you kindly!

  6. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @DigitalByJess,

    You are very welcome - I'm glad it's now working.

  7. hl78
    Member
    Posted 1 year ago #

    Hello,
    At first i didn't understand what exactly the "Set default Subscribe2 page as ID" do..

    1)i added the widget on my HOME page, and pointed it on HOME page, then in the settings i didn't find the home page in the list, so i used the BLOG.
    when i click subscribe it just reloads the home page and nothing happens!

    2) i placed the widget in the BLOG sidebr and pointed the "page as ID" to the BLOG page and inside settings to BLOG page as well... same thing happened, reloaded the BLOG page now but nothing happened.

    should it add the user to the public subscribers list?
    or send an email to the admin?
    or what exactly

    what am i doing wrong here??

  8. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    What should happen when you click Subscribe or Unsubscribe is that the page reloads but gives the user a message like "Confirmation email is on the way" and they should get an email with a confirmation link.

    Some caching plugins stop it working as they serve a cached page instead of the dynamic output.

  9. hl78
    Member
    Posted 1 year ago #

    Thank you for the quick response.

    That is not happening!! it just reloads and no Confirmation appears!
    you say some caching plugins stop it from working, is there a way to trace the problem? or maybe deactivate all other plugins to see if there is a conflict..

    What do you suggest? and resolving steps i can take?

    Regards

  10. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    Caching can be part of a plugin or a theme. To check for conflicts disable all other plugins and revert to a core WordPress theme and try again. If that works introduce your theme and try again and then each of your plugins, one at a time, until it breaks again.

    If reverting all of this fails to get things working it may be down to redirects in .htaccess or a poorly configured server.

  11. hl78
    Member
    Posted 1 year ago #

    Greetings,

    Reverting all of this failed
    I stoped all the plugins and reverted the theme too.

    Is there a thing i can do with the "htaccess", is it a configuation thing?
    About a "poorly configured server", do you suggest i contact server support? and what exactly should i ask them?

    Thank you

  12. hl78
    Member
    Posted 1 year ago #

    Sometimes i get this message in the Admin

    subscribe2/subscribe2.php has been deactivated due to an error: The plugin does not have a valid header.

  13. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    How did you install the plugin?

    If you can access your site via FTP and check that there is a subscribe2 folder in wp-content/plugins/ and inside this folder there should be some files and folders called classes/, admin/, include, and tinymce/.

    If there is another subscribe2 folder there then the plugin is only layer too deep.

    If everything looks as it should erase all files via FTP and upload them from a freshly downloaded version of the plugin. Then go to the Settings page in the plugin and Reset the settings and try again.

  14. hl78
    Member
    Posted 1 year ago #

    I did exactly as you said, but didn't work, i'm frustrated..
    I'm using a goDaddy host, windows host.

    Note: if i add a New Registered Subscriber, an email get sent to the Admin email i'm using that a new Registered Subscriber is being added.
    My problem seems to be with the public Subscriber.

    I don't know what is going on!

  15. hl78
    Member
    Posted 1 year ago #

    I tried sending email from the "send email" section of the subscriber2 and it works, yet the subcribe widget is not working..

    I tried other plugins widgets one named subscribe2 widget and another called subscribe2 widget hack...all didn't work

    the page just do a postback and nothing happens.

  16. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    Which widget are you trying to use? A standalone on or have you enabled the built in one?

  17. hl78
    Member
    Posted 1 year ago #

    I tried Both..
    The built in and the stand alone.

  18. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    It may be because the time column in missing in the subscribe2 database. Use PHPMyAdmin in your site control panel (via GoDaddy) to check the database for the column names. If there isn't one called time then create it and see if that helps.

  19. hl78
    Member
    Posted 1 year ago #

    These are the fields i found in the table "wp_subscribe2"

    id, email, active, date, ip, time, conf_date, conf_time, conf_ip

    time column alreay exist.

  20. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    What URL address can we view your site at?

  21. hl78
    Member
    Posted 1 year ago #

  22. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    Subscribe2 is being directed to page_id=2 but looking at that it doesn't appear to be a WordPress page as it contains about 10 recent posts.

    Have you written a WordPress page to handle the Subscribe2 requests as suggested in the installation instructions? If you have you need to direct the Subscribe2 plugin to use that page in Subscribe2->Settings under the 'Appearance' tab.

    If you haven't written that page then I suggest you either try that and put the subscribe2 shortcode on that page or direct the Widget to use your Home Page in the Widgets settings.

  23. hl78
    Member
    Posted 1 year ago #

    - Well at first as you see i placed the widget at homepage, in the settings-> Appearance i couldn't find the homepage in the dropdown list, yet i found it in the widget dropdown list.
    anyway, what i did now, with the widget showing in homepage, in the widget dropdown i selected homepage. Check it out.

    - in addition, i placed the subscription form in the contact us page using //S and in the subscribe2 settings>appearance i chose contact page.

    The default Permalink Settings for all pages is
    http://wellnessawareness.info/?p=123
    so every page i create has an ?page_id in the querystring.

    I'm trying everthing here

  24. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    You listed the default permalink structure for "posts", pages are handled differently in WordPress and have "?page_id=" in them unless you use a prettier permalink structure.

  25. hl78
    Member
    Posted 1 year ago #

    I'm not sure if i understood, must i use prettier permalink structure fot this to work?

  26. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    No, you need to write a WordPress page. Look in the Admin area down the left hand side under "Pages". It seems just like a regular post but it isn't, it's a Page that has slightly different properties in WordPress.

  27. hl78
    Member
    Posted 1 year ago #

    The homepage is a page and the contact page too.
    I tried the control on a different host and i was able to make to work. will try to reset everything and try again......

    aaaaaaaaaaaaaaaaaaaaaah frustrating
    sorry for the headache

  28. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    I've had a look at your site with Firebug when Subscribe or Unsubscribe is clicked this should pass a $_POST variable of subscribe or unsubscribe to the server, along with an IP value and an email value. Only on your server this isn't working, it's just passing the ip and email so the code doesn't know if it is supposed to be subscribing the address or unsubscribing it.

    I suspect that the server configuration is off somewhere and it's dropping or ignoring some or all $_POST request variables.

  29. hl78
    Member
    Posted 1 year ago #

    I check the page on firebug too, and yeah i only see
    ip and email variables in the post..
    what other variables should show?

    by the way i tried jetpack plugin and the subscribe they have didn't work on my site too, doing same thing...
    so it must be a config thing.

    i'm a .net and a multimedia developer too, but have little knowledge in php

  30. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @hl78,

    There should also be a 'submit' entry called 'subscribe' with the value of the text on the button (so normally 'Subscribe') or an entry called 'unsubscribe' (with a value of 'Unsubscribe').

    I have no idea about .net, or server configuration in general for that matter. I just know that something isn't right on yours. Take this up with your hosting provider or ask on stackexchange or similar about how to configure it correctly to accept PHP form submissions.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic