WordPress.org

Ready to get started?Download WordPress

Forums

New Sites giving incorrect URLs (8 posts)

  1. Gobsheene
    Member
    Posted 3 years ago #

    Hi Guys,

    This is my 1st post and i'm still learning my way through WP3.0.1.

    I have just enabled Multiple sites on our blog and I'm having some issues.

    Instalation seem'ed to run smoothly, but when I try and add a site through super admin or through the my sites section It gives a strange URL.

    This is what I got when I tried to add a site called New.

    http://domainname.comdomainname_comnew

    http://domainname.com being the root
    domainname_com is the database name that the WP is hosted on
    new is the site name.

    My hosts are Dreamhost.

    I dont understand why it is doing this but seems to be the same for normal members and admin members.

    Here is my htaccess file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    and my Config

    < snipped for sensitive info >
    /* Stop editing */

    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;

    define('ABSPATH', dirname(__FILE__).'/');

    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>

    If I have missed anything please let me know :)

    Niall

  2. See at the end of your config file where it has $base = DB_NAME ?

    Take that line out. Dreamhost's one Click installer adds it.

  3. Gobsheene
    Member
    Posted 3 years ago #

    Thanks Andrea, thats fixed it but the themes arnt appearing now, i'll take a trawl of the forum to see if it makes a difference

  4. Subfolder install, when the themes don;t show the styles, it means your htaccess file isn't being read correctly by the server. tell support they need to force mod_rewrite to actually read the file. ;)

  5. Gobsheene
    Member
    Posted 3 years ago #

    Thanks Andrea, you're a star!

  6. Gobsheene
    Member
    Posted 3 years ago #

    Hi Andrea,

    went back to the hosts and they've said everything looks fine, and that it may be a conflict on the oneclick setup they offer.

    Is there anything else that may be at fault before I reinstall manually?

    Permissions and such?

    Niall

  7. Nope, that's pretty much it.

  8. Gobsheene
    Member
    Posted 3 years ago #

    Hi Andrea, just thought i'd drop you a line to say that this is now working much better.

    I even have some new features over the oneclick install version [which was apparently the same!]

    Thanks for all your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.