WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
[resolved] New Sitemap Format Not Displaying - Missing Pages (7 posts)

  1. dabbers
    Member
    Posted 1 month ago #

    Hi,

    I just noticed that the new site map format is not showing on my sitemap. The old format is showing and dozens of new pages are missing from the index:

    http://diamondestatejewelrybuyers.com/sitemap.xml

    When I used the debug function, I see that the plugin is generating the new format and including all new pages. However that is not what is showing up on the link above.

    I am using the latest version of WP and the latest version of the plugin. I have WP Super Cache and All in One SEO plugin installed--but I deactivated them and it had no effect on solving the issue.

    Any ideas what the problem might be?

    Thanks.....D

    https://wordpress.org/plugins/google-sitemap-generator/

  2. arnee
    Member
    Plugin Author

    Posted 1 month ago #

    Hi,

    the new format links to several sub-sitemaps which include all your posts. Click on one of the entries to see them :)

  3. dabbers
    Member
    Posted 1 month ago #

    Hi Arne,

    I don't understand. Are you seeing several sub-sitemaps listed on my main sitemap index: http://diamondestatejewelrybuyers.com/sitemap.xml

    I don't see any of the sub-sitemaps listed there. There are no entries to click on.

    Please advise?

    Thanks....D

  4. arnee
    Member
    Plugin Author

    Posted 1 month ago #

    Ah, you are using an old version of the plugin, please upgrade!

  5. dabbers
    Member
    Posted 1 month ago #

    Hi Arne,

    I am not using the old version. I am using the fully upgraded version. As I mentioned in my original post, when I used the debug function, I see that the plugin is generating the new format and including all new pages. But the new format is not showing up on the actual sitemap index link.

    Please advise.

    Thanks....D

  6. dabbers
    Member
    Posted 1 month ago #

    Hi Arne,

    I found the problem was that even though I had the plugin fully updated, it was still showing the old sitemap on the link. I tried deleting the plugin, clearing cache, and reinstalling the new version, but the old sitemap still was showing. I've had to just delete the plugin and activate the sitemap generator in the All in One SEO plugin to finally get an updated sitemap showing.

    Best....D

  7. arnee
    Member
    Plugin Author

    Posted 1 month ago #

    Thanks for letting me know! :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.