WordPress.org

Ready to get started?Download WordPress

Forums

New site leads to basic 404 not found page (17 posts)

  1. dimpan
    Member
    Posted 4 years ago #

    after i enabled multisite on a clean wordpress 3.0 installation, i can no longer change my permalinks, or everything 404's

    also, no matter what permalinks is set to, i can't go to any sub site, i also get a 404 not found

    new sites are found at http://blog/newsite

    however the main site and posts on the main site continue to function fine

  2. Did you update your .htaccess?

  3. dimpan
    Member
    Posted 4 years ago #

    yes i did, and wp-config.php

    i also made a blogs.dir directory

  4. dimpan
    Member
    Posted 4 years ago #

    New site page
    404 not found page

    If it helps, my server is ubuntu server 10.04 with a clean lamp installation

  5. Are you running wp 3.0 out of a subfolder?

    Like http://domain.com/wp/ ?

  6. dimpan
    Member
    Posted 4 years ago #

    no i extracted it straight to /var/www/
    no sub folder

    so the site is running at http://torblog (internal site only)

  7. stuk88
    Member
    Posted 4 years ago #

    please check your url ... it isnt leading to any site.
    and plase check your url and site info in the admin page.
    you maby just have a redirect to unknown url.

    and if you changed your url resently try checking the url info of the blogs in the main admin by editing the blogs.

  8. so the site is running at http://torblog (internal site only)

    I think you're going to need torblog.something.

  9. dimpan
    Member
    Posted 4 years ago #

    please check your url ... it isnt leading to any site.

    it's an internal only company blog that wont and can't be accessed from the internet

    I think you're going to need torblog.something.

    since its internal only would that matter?

  10. Yes, it matters.

    localhost support was just rolled in with 3.0, but that doesn't mean other single-word local domains are supported.

  11. dimpan
    Member
    Posted 4 years ago #

    Yes, it matters.

    localhost support was just rolled in with 3.0, but that doesn't mean other single-word local domains are supported.

    i've restarted from scratch, new database, new wordpress isntallation, and you can now find the site at http://torblog.softchoice.com
    dns was just pointed an hour ago so it might take a while to update if you can't see the site

    however even with this setup i get the exact same problem, new sites are still 404

  12. no matter what permalinks is set to, i can't go to any sub site,

    From the first post, this tells me mod_rewrite isn't reading your htacess file. That's how the blogs work.

    AllowOverride FileInfo Options in the vhost entry for that domain.

  13. laofo
    Member
    Posted 4 years ago #

    How to enable AllowOverride FileInfo Options in the vhost entry for the domain?
    It seems I got the same error.

    I install WP3.0 and enable Multisites in subdirectory mode. After I modify the configuration files (.htaccess and wp-config.php). The main page of the sites looks good. However, the user and article links are all broken. Neither I click the user name or article topic, both of the links are broken.

    my Website is http://scmer.com and the new site is http://scmer.com/laofo

    Not Found
    The requested URL /laofo was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  14. dimpan
    Member
    Posted 4 years ago #

    in
    /etc/apache2/sites-available/default (or your site you created)
    change the options for Allowoverride

    thanks andrea_r, this worked perfectly, i really appreciate it

    How to enable AllowOverride FileInfo Options in the vhost entry for the domain?

    I found a good document on it here

  15. laofo
    Member
    Posted 4 years ago #

    After contacting with Godaddy, they said AllowOverride FileInfo is not currently available on our Linux shared hosting servers but mod_rewrite on my hosting server has been installed and it is currently functioning correctly.

    @dimpan
    Thanks for your suggestion, but my WP3.0 is installed on Shared servers so I can't change the httpd.conf. I am not sure whether it fits the requirements of WP3.0 MU or not.

  16. GoDaddy does not allow the network to run on their shared servers. At least, they didn't allow MU in either format.

    That's why in the codex it's listed at the top to check with your webhost first, before you enable the network.

  17. laofo
    Member
    Posted 4 years ago #

    Thanks andrea_r.

Topic Closed

This topic has been closed to new replies.

About this Topic