WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
New Relic Framework not set (16 posts)

  1. leggo-my-eggo
    Member
    Posted 1 year ago #

    I have a New Relic pro account, and am using WordPress in mu mode with W3TC in Community mode.

    I can't seem to get New Relic to recognize that I'm using WordPress. I've tried setting:

    php_value newrelic.framework 'wordpress'

    in my .htaccess file, but it doesn't work. Should I manually edit w3tc-config/master.php to add the parameter?

    Also, in my sites' W3TC dashboards, I have a box reading:

    "You do not have sufficient permissions to access this page."

    But I am the site admin in WordPress and the owner of the New Relic account.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. leggo-my-eggo
    Member
    Posted 1 year ago #

    I got the framework part of this worked out. But I'm still seeing the permissions error.

  3. usera
    Member
    Posted 1 year ago #

    have you tried to go to network admin from your 1st blog? I honestly don't think the new version of w3 total cache works with new relic. It keeps giving me a "The API key could not be verified. Please check it and try again.".

    It's annoying because you sign up for the new relic account and get the sales contact from them since you successfully deployed them but it doesn't work from the plugin that started it all.

  4. Hinnerk
    Member
    Posted 1 year ago #

    Yepp, I keep getting "The API key could not be verified. Please check it and try again.", too. Server and some PHP monitoring works, but W3 Total Cache seems not to.

  5. leggo-my-eggo
    Member
    Posted 1 year ago #

    @usera & @hinnerkh, W3 Total Cache works fine with New Relic (my small issue aside). Be sure you're using your API Key, from New Relic, not your License Key. To get your API key in New Relic, go to Account Settings->Integrations->Data Sharing, enable API access, and you will then see the key.

    The issue I'm having with the permissions error only happens in the Network Settings W3TC Dashboard. On each individual blog's W3TC Dashboard, the error is gone.

  6. usera
    Member
    Posted 1 year ago #

    lol... funny enough I did generate that key but it looked so similar to my license key that... I must have used the license key instead.

    I have just inputted into a centos/debian install and do not see your error. However the installation of the new relic php agent does not require any modification to any files. You do need to run their newrelic-install script and restart webserver/php service.

    which install instructions are you looking at?

  7. leggo-my-eggo
    Member
    Posted 1 year ago #

    Well, the new relic php agent is installed and running fine. It has recognized my wordpress framework and all seems to be well. W3TC is running fine, and pulling all the data from new relic. I have no reason to think that there is anything wrong at all really, apart from this error message which only appears on the network w3tc settings page.

  8. Hinnerk
    Member
    Posted 1 year ago #

    @leggo-my-eggo thanks, my bad.

  9. leggo-my-eggo
    Member
    Posted 1 year ago #

    @hinnerkh happy to help. :)

  10. usera
    Member
    Posted 1 year ago #

    if you google that particular error on total cache. it seems to be a glitch either related to another plugin or the plugin which requires deactiving and reactiving.

  11. leggo-my-eggo
    Member
    Posted 1 year ago #

    Every reference I can find to that error and W3TC seems to apply to menu pages not appearing. This is just a little box inside the New Relic Dashboard widget on the W3TC Dashboard page. In any case, de/reactivating the plugin doesn't fix it.

    I think at this point, I'm probably safe just ignoring it.

  12. usera
    Member
    Posted 1 year ago #

    are you talking about this: http://wordpress.org/support/topic/getting-you-do-not-have-sufficient-permissions-to-access-this-page-errors

    but thanks for the key tip. if someone didn't verify it worked I would have given up on that part of the configuration.

  13. leggo-my-eggo
    Member
    Posted 1 year ago #

    @usera, that is not the problem I am experiencing. And I'm glad I could help.

  14. bhagwad
    Member
    Posted 1 year ago #

    My API key is verified, but I'm unable to load the application. Here are the error messages:

    PHP module is not enabled.
    PHP agent is not enabled.
    Application ID is not configured. Enter/Select application name.
    License key could not be detected.

    I use a shared hosting plan on Bluehost using cPanel for administration...

  15. leggo-my-eggo
    Member
    Posted 1 year ago #

    @bhagwad, it sounds as if you have not yet installed the New Relic agent for PHP. This is a different topic than this thread addresses, and doesn't have anything to do with W3 Total Cache. You should try to install the agent as documented here: https://newrelic.com/docs/php/new-relic-for-php. If you have trouble, New Relic can help.

  16. krossekrabbe
    Member
    Posted 1 year ago #

    Thanks to the highly informational "could not verify"-message, it took me 1hr of debugging to figure out that it was a ssl problem in my case.

    sudo apt-get install ca-certificates
    sudo service restart php5-fpm

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic