WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New registrations disabled (6 posts)

  1. ruurik
    Member
    Posted 2 years ago #

    This is the first time I've used WordPress. I just installed WordPress 3.2.1 and chose to have Multisite as I need to have different users contributing to password protected material (all on one domain). After some reading, I thought Multisite was the right decision. Please correct me if I'm wrong.

    The first thing I tried to do was create a password protected page where the user has to login to see it. I thought I would create a 'subscriber' user to test this as my installation user's role is 'Administrator'.

    I found the http://domain.com/wp-signup.php URL but the message reads "registration has been disabled". After some reading online I found that I could enable new registrations in 'Settings -> General'. When I go to that page, there is nothing about registration; just timezone, date format, site language etc.

    So then I read that I need to be Super Admin but I can't be Super Admin until I create another site. I read that I can't add another site until I create or enable a network. I can't enable a network until I use the Network Admin option in the top right 'Howdy' pull-down menu. But I can't do this because Network Admin doesn't appear in my pull-down menu.

    My head is spinning now after going around in circles. I just want new users (as in non-Wordpress users) to be able to register to contribute and write blogs and so forth on my site. Please help me go in the right direction. Thank you!!

  2. Breathe :)

    That shows up on all sites, single or Multi, until you turn on the network. You're okay. In fact, that signup page is allowable for use for single sites (instead of using wp-login.php) so everything's as it should be.

    You DO have to turn on Multisite first, though, if you want that page to work for MULTISITE signup.

    If you just want to turn on registration on a single site install, the General Settings page should have a "Membership" line below your email address.

    If that's not that, have you already started following the steps on http://codex.wordpress.org/Create_A_Network ?

  3. ruurik
    Member
    Posted 2 years ago #

    Hi Ipstenu. Thanks for the "breathe". It's needed sometimes :)

    In my General Settings, there's no membership field. The fields are:

    Site Title
    Tagline
    E-mail address
    Timezone
    Date Format
    Time Format
    Week Starts On
    Site language

    I looked at the Create A Network page. I noticed that by default my wp-config.php already had the line:

    define('WP_ALLOW_MULTISITE', true);

    As I mentioned before though, I don't have the Network Admin menu in the upper right corner. Just 'your profile' and 'logout'.

    If you think I don't need Multisite from what I've written then that's fine with me. The easier the better! But I am still baffled why I don't have a 'membership' line on my settings page.

  4. Okay, if you have that line in your wp-config, then you've STARTED making a Multisite.

    Delete that line and you'll get the membership option back.

  5. ruurik
    Member
    Posted 2 years ago #

    Update. I uninstalled and reinstalled but without Multisite and the 'membership' field in General Settings appeared. Bizarre! If I can do what I need without Multisite then that will be great. I will have a look-see.

  6. ruurik
    Member
    Posted 2 years ago #

    Ha! We had similar ideas. :) Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic