WordPress.org

Ready to get started?Download WordPress

Forums

Quick Page/Post Redirect Plugin
[resolved] New redirects no longer work (old ones work) (4 posts)

  1. jduball4u
    Member
    Posted 1 year ago #

    I recently upgraded my wordpress blog and although the old redirects I created work, new ones are no longer working.

    Here is an example of my old redirects working:

    http://www.jeongyi.com/roy-hanna-engagement-slideshow/
    (redirects to http://www.jeongyi.com/dt_portfolio/roy-hanna-engagement-slideshow/)

    Here is an example of my most recent redirect that doesn't work:

    http://www.jeongyi.com/maggie-danny-engagement-video/
    (should redirect to http://www.jeongyi.com/dt_portfolio/maggie-danny-engagement-video/)

    I checked the code and settings of the new page and old pages and everything is the same. I've tried a bunch of different things to try and get it to work (deactivate / reactivate plugin, change the page URLs to be less similar, republish the page, disable the redirect and then re-enable it).

    Any ideas what might be happening? Any help would be GREATLY appreciated. Thanks!

    http://wordpress.org/extend/plugins/quick-pagepost-redirect-plugin/

  2. jvandemerwe
    Member
    Posted 1 year ago #

    The plugin does not work with the Hypercache plugin.

  3. jduball4u
    Member
    Posted 1 year ago #

    Thanks for your response, but I don't have the Hypercache plugin on my blog.

  4. prophecy2040
    Member
    Plugin Author

    Posted 1 year ago #

    My only thought is that maybe you need to rebuild your permalinks, or they WP permalink structure is bypassing the redirect before it gets to do anything - at which point it does not match the request URL. i.e., in WordPress, a page like /maggie-danny-engagement-video/ would automatically redirect to /something/maggie-danny-engagement-video/ if you changed the structure and someone visited the old link (as long as the slug remained the same and there was no duplicate page in a different category or sub-page). So it is possible that is happening. Try removing the redirect and see if it does it on it's own.

    Regards,
    Don

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic