WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New post page broken links/menu expansion in 3.2 (39 posts)

  1. iwbyte
    Member
    Posted 3 years ago #

    I just set up a new blog via download from wordpress.org, no plugins installed, imported posts from another vanilla (no plugins) blog, and the add/edit post page is being weird. Going to 'add new post', all of a sudden the left nav pulldown menus don't work, and none of the # anchor reference links work (e.g.#edit_timestamp, #status, etc.)

    Tested with FF3, FF5, Safari and latest chrome.

    Tried it with visual editor disabled as well.

    Anyone duplicate this issue?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress? Have you checked the minimum hosting requirements - especially the PHP version?

  3. iwbyte
    Member
    Posted 3 years ago #

    Good thought, but I just reinstalled from scratch, still same problem.
    MySQL Server: 5.1.55
    MySQL client version: 5.1.45
    PHP 5.3.6

    Should work, no?

  4. iwbyte
    Member
    Posted 3 years ago #

    And this is without any import of anything from the old site - just 2 step install of 3.2 fresh on a new site.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Are you running any other WP 3.2 installs on that server?

  6. jdvieira
    Member
    Posted 3 years ago #

    I have the same problem and same version of PHP. Also did a fresh install.

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    Same server configuration?

  8. iwbyte
    Member
    Posted 3 years ago #

    @esmi - one other wp 3.1.4, and this broken 3.2 install - that's it.

  9. kuzjnvn
    Member
    Posted 3 years ago #

    same problem with add new post .... cant write any thing , cant add tags ,i install health check and my server have enough for running how to fix this ???

  10. iwbyte
    Member
    Posted 3 years ago #

    FYI, i'm having this issue as well from another user. And this is a STOCK install, no plugins, default TwentyEleven theme, one single post.

    Now when I go into to add a new post, or edit an existing post the visual editor is not working properly. The text is not visible, but when the area is highlighted it displays as html.

  11. Andrew Ozz
    WordPress Dev
    Posted 3 years ago #

    Do you see any JS errors? Sounds like something may be replacing the version of jQuery that comes with 3.2, or perhaps some JS files didn't update properly.

  12. iwbyte
    Member
    Posted 3 years ago #

    I just checked and /wp-includes/js/jquery/jquery.js is 1.6.1 - i haven't done anything other than downloaded WP 3.2 and installed it and then logged in and tried to edit the default post.

    Is there any way for me to send admin userid & pass?

    http://test.geekaba.com/

  13. Andrew Ozz
    WordPress Dev
    Posted 3 years ago #

    It sounds like JS is not working. Are there any JS errors? Perhaps they will point to what's wrong.

  14. iwbyte
    Member
    Posted 3 years ago #

    I enabled Firebug to look for JS errors and I got this - does it help?

    switchEditors is not defined

  15. iwbyte
    Member
    Posted 3 years ago #

    I get that error when attempting to click on the 'HTML' link in the visual editor.

  16. Andrew Ozz
    WordPress Dev
    Posted 3 years ago #

    Is that the only error? This is part of the wp-admin/js/editor.js file. Perhaps upload a fresh copy of it?

  17. iwbyte
    Member
    Posted 3 years ago #

    That's the only error message I can reproduce in Firebug, but its not the only error - the 'status' and 'schedule' edit links don't work but they don't throw an error message.

    I also get the 'white text, html only' error that's been discussed elsewhere.

    This is a fresh vanilla install, but I went ahead and re-downloaded http://wordpress.org/latest.tar.gz and extracted wp-admin/js/editor.js just in case. Still same issue :(

    Can you see if http://test.geekaba.com/wp-admin/js/editor.js is corrupted/different than the usual?

    I'm on Mac OS X if that helps. I don't have a windows machine to test with unfortunately.

  18. Andrew Ozz
    WordPress Dev
    Posted 3 years ago #

    editor.js looks good... This would suggest that the error is before it gets loaded, but if there's nothing in Firebug I don't see a way to track it.

    The only thing left is to delete everything except wp-config.php and .htaccess and perhaps wp-content/uploads if you have any files there, then upload all files again from a freshly extracted install package.

  19. iwbyte
    Member
    Posted 3 years ago #

    Andrew,

    Thanks for the help, but this really is a plain vanilla install - I just uploaded the latest.tar.gz file, used a blank database and did the setup and that's it - no new posts or content or uploads or config changes made.

    i.e. its not working for me right out of the box, unfortunately. Any other Mac OS X users experiencing issues?

    Can I send you a WP username and password somehow so you can tell me if i'm crazy and imagining it? It is a throwaway site so i'm not worried about it being compromised since i'm going to nuke the site when we get this worked out and work on my real site afterwards.

  20. krispy_b
    Member
    Posted 3 years ago #

    I've just realised this may be the same as my error; http://wordpress.org/support/topic/php-536-breaking-javascript?replies=1

    as my 3.14 and 3.2 upgraded wordpress installations are showing the same behaviour - getting illegal characters in included javascript files in the admin pages.

    i THINK it's the upgrade to PHP which was required somehow conflicting?

  21. MikeAmelung
    Member
    Posted 3 years ago #

    I had these same symptoms with a fresh install of WordPress 3.2. I checked my PHP (5.3.6) error log and noticed 'PHP Fatal error: Call to undefined function json_encode()'.

    Solution: Install and enable JSON extension for PHP.

    As a side note, I have WordPress 3.14 running on an almost identical server with the PHP JSON extension disabled. No issues there.

  22. joeatidc
    Member
    Posted 3 years ago #

    I can confirm the php5-json fixes the white on white edit issue on my installations.

    I had it occur on an upgraded blog and a clean install that I had just done to start troubleshooting. Adding the JSON extension fixed both the upgraded install and the fresh install.

    Nice catch Mike!

  23. iwbyte
    Member
    Posted 3 years ago #

    Works for me too! I'm all fixed, yay!

  24. mmoore5553
    Member
    Posted 3 years ago #

    How do you load this if you are on a shared server and running cpanel ? Would i ask my hosting to configure php 5.2 and json ?

  25. mmoore5553 - Yes.

  26. mmoore5553
    Member
    Posted 3 years ago #

    Thank you

  27. simonssay
    Member
    Posted 3 years ago #

    My host server had php 5.2 but the JSON extensions were not enabled. Enabling them fixed this issue for me as well.

    That seems to be the fix.

    Thanks for the solution.

    -Simon
    -------------------------
    If it weren't for computers we'd probably be in bed at a decent hour.

  28. vyllek
    Member
    Posted 3 years ago #

    hi guys
    do you think this is what is causing my issues on the Jarrah theme I am using? Normally the navigator green lavalamp element follows the pointer / animates. The theme does use jquery. Since upgrading to WP3.2 this no longer animates. Thanks much.

    http://collective-edit.com

  29. bbal
    Member
    Posted 3 years ago #

    Hi, I got same error I think.
    explorer: chrome , server
    Apache/2.0.58 (Unix) mod_ssl/2.0.58 OpenSSL/0.9.8o PHP/5.3.1
    MySQL istemci sürümü: 5.0.51a
    PHP uzantısı: mysql

    No permission for a new page, but I can publish an old draft left from 3.1.4 times. I use default "twenty ten" theme.
    1-I removed all plugins nothing changed.
    2-Reinstalled from a fresh wordpress-3.2-tr_TR.zip except wp-content folder: nothing is changed.

    I thnk it's related with new-post page, because I have a normal working edit page and admin permission with drafts.

  30. bbal
    Member
    Posted 3 years ago #

    It's OK also with quickpress.(means I have permission to publish with quickpress but I have not with new-page.php)
    Hope to help you to solve the problem :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.