WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
New post can not be seen on the homepage (19 posts)

  1. Moretti.a
    Member
    Posted 1 year ago #

    Since I updated the plugin to the latest version I can no longer do see the new articles on my site. Public on average a post every hour (every half hour), but if you do not force the purge cache just does not display new posts on the homepage.

    This did not happen first. What has happened?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. mbrsolution
    Member
    Posted 1 year ago #

    Hi, I have read here in many forums that many are uninstalling the plugin and removing all traces from the server and then reinstalling it again.

    Of course make a backup just in case something goes wrong.

    Try that and see if that helps.

    It is worth a try in my humble opinion.

    Kind regards

  3. Danielle
    Inactive
    Posted 1 year ago #

    By me it was otherwise, purge cache and I didn't see new post, since then I don't touch the purge cache, only empty cache all

  4. Moretti.a
    Member
    Posted 1 year ago #

    I tried to erase everything and reinstall. But it still does not work. I post do not want it to appear ...

  5. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Do you see it when you are logged in? If yes, do you see it as logged out? If no do you have browser cache enabled it could be update/refresh/clearing the browser cache in the browser is required.

    Could you also submit a bug report from the support tab of the plugin so we can look into it further if the if the above procedure does not work.

  6. Moretti.a
    Member
    Posted 1 year ago #

    Thanks for the reply Federick.

    So yes, you're right, when I log in I see the new posts published. From other browsers where logout is not. I have the browser cache is enabled but does not want to work.

    I sent the bug report. Thank you :)

  7. pacovitiello
    Member
    Posted 1 year ago #

    Same issue with the new update: when I publish a new post, if I am logged in I can see it into my homepage. When I log out, it's not visible. So I have to manually "empty all caches" for making it visible for not-logged users. Some setting I should change in the plugin configuration? Thanks.

  8. Moretti.a
    Member
    Posted 1 year ago #

    There is no solution right now. You have to wait for update

  9. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Have you enabled front page purging under Purge Policy on the Page Cache settings page?

  10. ggg377
    Member
    Posted 1 year ago #

    I have the same issue. Front page purging is enabled from Purge Policy.

  11. jsergio123
    Member
    Posted 1 year ago #

    I also have this issue. I have tried uninstalling and re-installing the plugin which did not fix it. The latest update has caused the issue.

  12. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Which Page Cache engine are you using? Does the issue occurr when Browser Cache is disabled as well?

  13. jsergio123
    Member
    Posted 1 year ago #

    My settings are:
    disk enhanced
    disk basic
    APC
    APC

    would you like my whole config file?

    Also I'm not sure about the browser cache...

  14. fox3586
    Member
    Posted 1 year ago #

    I am also having the same issue. I can see the post when logged and purging the cache for the post fixes the issue, but I thought it was supposed to be automatic with new posts.

  15. shmox
    Member
    Posted 1 year ago #

    Same here, can see new posts just after purging page cache...

  16. chadhugo
    Member
    Posted 1 year ago #

    i hadnt seen this topic.

    i have the same problem, is it solved now?

  17. ifs
    Member
    Posted 12 months ago #

    I am having same problem. Please tell till when it will fix.

  18. coralseait
    Member
    Posted 11 months ago #

    Having a similar problem with Genesis 2.0 / Landscape child theme on WP 3.6 with latest W3TC. On other installs I'm not having the issue on G 2.0, but this is my only landscape child site.

  19. purrdesign
    Member
    Posted 11 months ago #

    Having the same problem here. Front page purge policy is enabled. I can see the post on the homepage only if I'm logged in. Logged out users are seeing an older post there instead.

    I've tried manually purging all caches and even purging the cache for this one post. Still, once I log out, nothing. Have tried disabling browser cache, same problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic