WordPress.org

Ready to get started?Download WordPress

Forums

New plugin: Flashfader (slideshow in flash) (28 posts)

  1. lynk
    Member
    Posted 8 years ago #

    Hi all,

    I just finished my first plugin. Flashfader 1.0
    It allows you to put a flash slidehow on your site.

    Upload 2 files in your plugins directory, add one line to a template page and its up.
    Upload of images and configuration (size etc.) via the admin panel.

    download , Flashfader homepage

    marcus

  2. xtool
    Member
    Posted 8 years ago #

    I love the Plugin but question, where do I place the images?

  3. Makki
    Member
    Posted 8 years ago #

    link is dead to download

    "
    Oops...

    Trac detected an internal error:

    'module' object has no attribute 'cgi_start'

    Traceback (most recent call last):
    File "/usr/home/matt/cgi-bin/trac", line 25, in ?
    trac.core.cgi_start()
    AttributeError: 'module' object has no attribute 'cgi_start'
    "

  4. lynk
    Member
    Posted 8 years ago #

    I put up an additional download.

    @xtool
    I am not sure what you mean with "place".
    If you are asking how to put the flash on the frontend of your site, you have to edit the sourcecode of one of your template pages. Did you follow the instructions in the how_to_use.txt ?

  5. xtool
    Member
    Posted 8 years ago #

    Yes I followed your 'how_to_use.txt' but after uploaded them images and made it writable, it gave me these errors:

    Warning: main(/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt): failed to open stream: No such file or directory in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

    Warning: main(/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt): failed to open stream: No such file or directory in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

    Warning: main(): Failed opening '/home/forcefor/public_html/wp//wp-content/flashfader/flashfaderhtml.txt' for inclusion (include_path='.:/usr/local/lib/php') in /home/forcefor/public_html/wp/wp-content/themes/mx4_theme/sidebar.php on line 3

  6. lynk
    Member
    Posted 8 years ago #

    try to change the code in the sidebar to

    <?php include (ABSPATH.'wp-content/flashfader/flashfaderhtml.txt'); ?>

    (remove the / before wp-content/flashfader...)

  7. Makki
    Member
    Posted 8 years ago #

    this is an awesome plugin thanks much

  8. xtool
    Member
    Posted 8 years ago #

    I did thought that was the case but it still didn't work thats why I'm searching for advice or perhaps its taking longer to refresh. I might need to clean my cache over and over. Yes I'm at that point.

    Makki. Did it worked for you the first time? Or you had to edit few lines?

  9. lynk
    Member
    Posted 8 years ago #

    If you changed the code in the sidebar (the / was a bug/typo) and the error message does not appear anymore, this problem seems to be solved.
    Must be something else. Can you provide a link?

  10. Makki
    Member
    Posted 8 years ago #

    I installed the plugin and activated and inserted code into sidebar and worked first time

    here is my code i used in sidebar

  11. <h2>Pixels</h2>
    <!-- Flashfader -->
    <?php include (ABSPATH.'/wp-content/flashfader/flashfaderhtml.txt'); ?>
    <!-- /Flashfader -->
  12. My site is here makkistudios.com

  • xtool
    Member
    Posted 8 years ago #

    Lynk

    Thank you for replying and your help. I just now got home. I retry from scratch. Seems to be working but image is not displaying. Went to my control panel to change it to writable and waiting...

    http://forceforge.com/wp/

    Makki
    Thanks Makki. I had to the same exact line but for strange reason it's not working for me.

    I have time before bed to poke on it a little. Thanks all and g'night. Cheer.

  • lynk
    Member
    Posted 8 years ago #

    I know the reason. Look in the images.xml file.
    The paths to the images are not correct, there is a / missing. The / is in the script. Did you edit flashfader.php and removed it accidentally?
    the line is: $out .= '<image path="'.get_settings('siteurl').'/wp-content/flashfader/'.$value.'.jpg" />';

  • xtool
    Member
    Posted 8 years ago #

    No sir I did not.
    I only edited the <php script line for Sidebar.php then after I saw the error "//" I went and edited images.xml. I can say there was no more errors but now the image are not displaying.

    I have time to troubleshoot some more today. I'll see what I can come up with.(Yeah right)

    Cheer.

  • lynk
    Member
    Posted 8 years ago #

    hi,

    well, you shouldnt have edited images.xml :)
    Go in the flashfader admin, just press save in the display settings. that rewrits the images.xml if its still writeable, because you uploaded a new one. or just change permissions to 777 before

  • xtool
    Member
    Posted 8 years ago #

    Ok. I gave up.

    I destalled the plugin and downloaded your new updated one after that small fix.

    Made ALL of them 777.

    Working now. Thanks a bunch!

  • Atta
    Member
    Posted 8 years ago #

    Is there a problem with running this plugin when PHP is running in SAFE MODE?

    I am having no end of difficulties running this. I copy the two files across to the wp-content/plugins directory, makes sure that the the whole wp-content folder has full permissions, including the two flashfader files.

    I then activate flashfader from Plugin Management page. However, when I go to the Manage and Flashfader, I get a load of error messages .... including something about Safe Mode and others which are basically saying that flashfader wasn't able to create the various .txt files in the flashfader folder. Oddly, it does manage to create the flashfader folder however.

    I don't really get as far as modifying the sidebar.php file as I thought it wasn't working correctly. Would doing this fix the errors?

    Am I doing something wrong, or is it that my ISP' web-server set-up simply doesn't agree with flashfader?

  • lynk
    Member
    Posted 8 years ago #

    it's your php configuration. adding the code to the sidebar won't help. creating a directory works because the function for that is not restricted, the one for creating/opening a file is.

  • Atta
    Member
    Posted 8 years ago #

    Is there a way of modifying flashfader to run in Safe Mode? My ISP' FAQ has this to say on the subject:

    "The PHP engine is compiled as a safe mode enabled Apache module. This makes it execute PHP scripts extremely quickly and safely. If the safe mode is too restrictive for your requirements, eg: you want to create a file upload script, then the php cgi engine can be used instead.

    To run the slower cgi version of PHP your php file should end in .cgi and include at the top of the file the line:

    #!/usr/bin/php"

    The difficulty is that WordPress expects to see PHP files for its plugins so I guess this won't be possible.

  • allthewhile
    Member
    Posted 8 years ago #

    this plugin is so super freaking sweet. Now if I could make a bunch of flash slideshows, that would be coool.

  • allthewhile
    Member
    Posted 8 years ago #

    check out this slideshow i made. it's cool cause i can just add photos to the end of the slideshow as life unfolds.

    http://www.franklinfamily.org/about/

  • resmyrranda
    Member
    Posted 8 years ago #

    I love this plugin, decided I'd use it with my current theme Daisy Rae Gemini. Got my images made, configured the plugin in "Manage", uploaded the images. It works great, just not the right place. lol I don't want the slideshow in my sidebar but in my header. I placed the plugin code just about everywhere in my header template and it shows in the right area, just can't get it to not look skewed to the right too far instead of exactly where the header images should show up. I'm not a php expert and would really appreciate any suggestions. Thanks!

  • resmyrranda
    Member
    Posted 8 years ago #

    Any suggestions anyone?

  • allthewhile
    Member
    Posted 8 years ago #

    link to the site.

  • resmyrranda
    Member
    Posted 8 years ago #

    http://www.resmerized.com

    Thanks for looking allthewhile:) Its the standard Daisy Rae Gemini theme though, the only thing I've modified is the header image, took the flashfader code off cuz it looks funky but its still activated and configured.

  • rizwan
    Member
    Posted 8 years ago #

    Wow, great plugin! Thanks a lot! Works like a charm

  • resmyrranda
    Member
    Posted 8 years ago #

    Anybody know where to put this plugin the Daisyrae Gemini theme so it works in the header? I've put it everywhere and can't seem to get it in the right position.

  • saxynath
    Member
    Posted 8 years ago #

    Does anyone know if this plug in works in conjunction with a video plug-in (for you tube or google such as WPvideo) As im having real problems getting flashfader to work now ive got a google vid on my site, http://www.nathanmonk.com.

    Any help would be appreciated.

  • jonesmac
    Member
    Posted 8 years ago #

    Great plugin. Did you ever write a version that used a .js file to embed to avoid the annoying issues with <object> tag in IE? Some viewers seem to not be able to view the .swf file at all because of the recent update to IE. If you have any ideas, let me know. Thanks

  • Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags