WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New pages 404 error (9 posts)

  1. demain10
    Member
    Posted 4 months ago #

    I have just created a new website. http://www.adventurekentucky.com .

    Any new page I create just 404s. I have read the support forums about permalinks, I have adjusted my permalink settings.

    I have copied the code given code on the permalinks page and pasted it into a .htaccess file on my root directory using the built in FTP on Fatcow.com. Nothing seems to change. I apologize if this problem is old hat, but I really don't understand how any of the other posts on this topic have been resolved. I feel like I am missing some important detail.

  2. Senff
    Member
    Posted 4 months ago #

    What did you paste in .htaccess? Usually you don't need to meddle with that file, as WordPress will take care of it.

    Try deleting your .htaccess file altogether (or better, rename it to htaccess.txt). Then in the WordPress admin, change the permalinks to the default and save it. Change it BACK to the setting you have right now, save it. By doing this, WordPress will generate a new .htaccess file.

    See if that helps?

  3. demain10
    Member
    Posted 4 months ago #

    I actually could not find a .htaccess file anywhere in the directory. I looked through all the folders (I did go into the settings panel and tell it to show hidden files that begin with .). So i created one in TextWrangler and added it to the root directory. It didn't do anything.

    But this is all I pasted into that file:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

  4. demain10
    Member
    Posted 4 months ago #

    I changed the settings to default and all the pages work.

    So, now, I guess the question is why WordPress doesn't seem to generate a .htaccess file when I change the settings. Or Where/how do I need to create a .htaccess file with the given copy/paste code so that I can create pretty permalinks.

  5. Senff
    Member
    Posted 4 months ago #

    Does your server have the mod_rewrite module installed/enabled?

  6. demain10
    Member
    Posted 4 months ago #

    I'm not sure. From what I've read I thought that was supposed to be in the .htaccess file.

  7. tumbleweed65
    Member
    Posted 4 months ago #

    I am having the same problem I also changed the settings to default and now all the pages load but in the address bar they have a odd looking address lie http://www.dracovapes.com/?page_id=14 instead of http://www.dracovapes.com/myaccount how can this be fixed?

  8. tumbleweed65
    Member
    Posted 4 months ago #

    Sweet demain10 are you by chance on ipage? if so when you go to the settings and change it to reflect the showing the address right look down to bottom of the page wordpress says the htaccess file is not writable and you need to paste in this code....... copy that,go to ipage control panel,under additional tools the first one is htaccess editor open that and paste in the code. address look right now =)

  9. demain10
    Member
    Posted 4 months ago #

    Well I finally figured out how to edit my .htaccess file. Thanks to everyone for the help.
    Thanks to tumbleweed65 for the suggestion of where to find that.

Reply

You must log in to post.

About this Topic