WordPress.org

Ready to get started?Download WordPress

Forums

New Page and New Post Admin. Bug (27 posts)

  1. metaman8
    Member
    Posted 4 years ago #

    Hello, recently all of the sudden when ever I am in the Dashboard and I click on either the "Add a new post" or "Add a new page" I encounter problems.

    The problems are the same in both areas. These two dashboard pages hang up during the loading process. They will sit there loading for more than 30 seconds and finally they finish loading. The other problem is that when ever I am trying to type in the text box, it keeps saving a draft about every 30 seconds and it freezes and stops me from typing twice every time it does this.

    Strange thing is that if I go to the edit a post on the Edit Post page it loads up quick with no problems after I have selected a post to edit. The same deal with editing a page, Edit Page after selecting a page loads up normal no problems. This does not make sense to me because these edit pages almost identical to the Add New pages.

    I did some searches on these forums and tried some fixes but they did not work. I turned off all of the admin plugins accept for the key ones like Akismet and Super Cache. This did not fix it so I did the other suggestion I saw on another thread and I reinstalled both the wp-admin folder and also the wp-includes folder. I used brand new fresh 2.84 folders off of a fresh download when I replaced them, and I did not reactivate the plugins before or after.

    When I go to my server's error log it is catching what is doing. However, I am not a diagnostic computer code person. Therefore I do not know what these errors mean. Here is the error that shows up in the error log of my server.

    File does not exist: /home/metaman8/public_html/favicon.ico

    What else can I do to try to fix this.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    That error isn't an indication of what's causing your problem.

    Favicon

    Have you tried:

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. metaman8
    Member
    Posted 4 years ago #

    So you are saying actually go in and clear out the plugins folder?

  4. s_ha_dum
    Member
    Posted 4 years ago #

    Change, or add, the autosave interval in your wp-config.php.

    /** Change autosave default **/
    define('AUTOSAVE_INTERVAL',600);

    That will solve your 'saving a draft problem'.

    You might also try turning off post revisions, assuming you don't need the feature. It might speed things up.

    /** Turn Off Revisions **/
    define('WP_POST_REVISIONS', false);

    I haven't looked at the feature in the new release but when it first came out it gave me all kinds of headaches. Plus, I kinda think it is, or was perhaps, horribly designed and should have used a separate table for the revisions. But I'll not rant...

    The one error you spotted isn't really a big deal. The browser is looking for the little icon that goes at the top left of the URL address bar. On this site it is the WordPress logo.

  5. metaman8
    Member
    Posted 4 years ago #

    Ok, so I went to the plugins folder and deleted all of the plugins that I had deactivated. It still does it.

    So now I have the wp-config.php file open.

    Where do I add in the

    /** Change autosave default **/
    define('AUTOSAVE_INTERVAL',600);

    any particular spot in that file?

  6. metaman8
    Member
    Posted 4 years ago #

    Also I should mention that this started at about the same time that I enabled the feedburner subscription field that was built into my theme which is Pixeled. I can not be sure if it started before of after I did this. Could there be any kind of connection there?

    http://www.altimatrix.com

  7. metaman8
    Member
    Posted 4 years ago #

    It was not the feedburner, I just disabled and checked and it still does it. Therefore, I reenabled it.

  8. s_ha_dum
    Member
    Posted 4 years ago #

    Just add that under the database information. You might want to type it out. Copying can sometimes result is strange characters.

  9. metaman8
    Member
    Posted 4 years ago #

    Ok, Good deal thank you apljdi. I will try that out.

    Also when I was looking at my error log before I was looking at the one on the control panel of the server. I just found the one that is inside of the File Directory and it says that this error happened today.

    [27-Aug-2009 16:34:44] PHP Warning: require(/home/metaman8/public_html/wp-includes/compat.php) [function.require]: failed to open stream: No such file or directory in /home/metaman8/public_html/wp-settings.php on line 246

  10. metaman8
    Member
    Posted 4 years ago #

    Ok, I just opened up the wp-settings.php file to have a look at it. Like I said I have no idea what I am looking at in that file because I am not a code reader person. However, should I replace the wp-settings.php with a fresh one from the 2.84 download? Or is there something else I should do about this/

  11. s_ha_dum
    Member
    Posted 4 years ago #

    That's a juicier error message. It suggests that you haven't uploaded all of your WP files. You should probably try re-ftp-ing your core WP files to make sure they are all there.

    The '600' in the AUTOSAVE_INTERVAL is time in seconds, by the way. Set it to however long you want.

  12. metaman8
    Member
    Posted 4 years ago #

    I tried adding in the

    ** Change autosave default **/
    define('AUTOSAVE_INTERVAL',600);

    it still does it, it must have something to do with that error

  13. s_ha_dum
    Member
    Posted 4 years ago #

    Like I said, try re-uploading your files.

  14. metaman8
    Member
    Posted 4 years ago #

    Posted by apljdi

    That's a juicier error message. It suggests that you haven't uploaded all of your WP files. You should probably try re-ftp-ing your core WP files to make sure they are all there.

    I would rather just replace the files that the error message is correlated to. Do you forsee any reason why the others would need replacing as well?

    The files have been uploaded and the wordpress installation has been working for quite some time without any problem. This glitch was out of the blue. I guess I could have been hacked and the file was modded, who knows?

  15. metaman8
    Member
    Posted 4 years ago #

    Well I just re-ftp'd the wp-settings.php and it still does it.

    aplijdi, when you say "core files" what files does this mean? All of them? I have already freshened up the wp-admin and wp-includes both before and after I deleted the plugins from my server.

    Still not working right, but the annoyance of the draft saving every 30 seconds is now gone. At least it has gotten to a level of usability at this point. Still would like to dial in the rest of it.

  16. s_ha_dum
    Member
    Posted 4 years ago #

    'Core files' are everything that comes in the wordpress zip file minus the wp-content directory. These are the files that everything else depends on. You need to re-upload everything. What you are missing is one of the files in the wp-includes directory. wp-settings includes that file (wp-includes/compat.php) on line 246 but it isn't there, so you get an error.

  17. metaman8
    Member
    Posted 4 years ago #

    Ok, so I replaced all of the core files. When I go to the new post page in the dashboard it still does the stalling while trying to load the text editor. It will load the entire screen except for the buttons from the text editor then those show up about 30-45 seconds after the page started to try to load.

    I checked and the error log is no longer recording the error about missing a file from the wp-includes. At this point I think that I have to start looking at the server. I would think that if it was a server problem that it would do it also for the text editor on the edit page and edit post pages. However, I am not a programmer and am using logic not based off of anything substantial.

    If it is a server problem, what kind of problem should I look for? What should I ask them nomenclature wise?

  18. metaman8
    Member
    Posted 4 years ago #

    I should also add that no matter what other pages I try to open in the Dashboard, they all open snappy and quick like you would expect. However, if I click on one of them while on the new post or new page there is a delay in how long it takes to leave the new post or new page and arrive at the other section of the dashboard. The same goes for when I try to publish a new post or new page. There is a significant delay in how long it takes to leave the page. This is not the case when I click the update button when editing a page or post.

    Since all of the files accept for wp-content have been replaced with fresh 2.84 files then I will now look at the server. I will post back if I find a problem with the server. Thank you for your help everyone.

  19. s_ha_dum
    Member
    Posted 4 years ago #

    I try to open in the Dashboard, they all open snappy and quick like you would expect. However, if I click on one of them while on the new post or new page there is a delay...

    Yeah, that makes sense. You are waiting for whatever it is to stop running/timeout/whatever. Obviously, the hard part is figuring out what is causing the delay. What happens if you switch off Javascript in your browser? Better? The same?

    Did you try turning off post revisions?

  20. metaman8
    Member
    Posted 4 years ago #

    I have contacted the Host (Hostgator) to get them to do a diagnostic. If that does not work I will give turning off post revisions a shot. I have used the post revisions before when I messed up a post, therefore I would like to keep it if possible.

  21. s_ha_dum
    Member
    Posted 4 years ago #

    I have used the post revisions before when I messed up a post, therefore I would like to keep it if possible.

    I know what you mean. I like the idea of post revisions. I just don't like the implementation.

  22. metaman8
    Member
    Posted 4 years ago #

    Ok, so the server administrator at HostGator could not find any issues with the server. He also tried re-installing all but the wp-content folder. Here where his conclusions

    From The Host Gator Admin

    With fresh files installed this was still a problem, I have even tried with out plugins and theme. The only thing left is an over-all bug with WordPress or something in the database. The site is stopping when requesting: Script: http://altimatrix.com/wp-admin/load-scripts.php?c=1&load=jquery,utils,editor,quicktags&ver=33f9a1c72519a04d2fd7dd5a26c9ec8d:19 which cause the browser to lock up and then the page to ask you if you want to stop the script clicking stop the script lets the page load the rest of the way.

    I am going to email him the link to this thread so he can see what is going on. I think he is a little baffled as well.

  23. metaman8
    Member
    Posted 4 years ago #

    I know what you mean. I like the idea of post revisions. I just don't like the implementation.

    I would lean towards the page revisions causing it. On the other hand if that was the problem then it would do it when I was on the almost identical pages in the dashboard of "edit post" and "edit page". The page revision works with those two the same as it does for "new post" and "new page". Plus the latest updates had nothing to do with the page revision function. They where security updates and the problem was non-existent until a few days ago and I have been on my current server with wordpress for a couple of months now making post after post with not problem until now.

  24. metaman8
    Member
    Posted 4 years ago #

    Ok, I just tried out the

    /

    ** Turn Off Revisions **/
    define('WP_POST_REVISIONS', false);

    and it still did it, therefore I re-enabled the post revisions since they where not the culprit

  25. s_ha_dum
    Member
    Posted 4 years ago #

    So its freezing when the Javascript loads. I've seen this 'slow script wanna continue' problem on a very old and very slow Mac. I've never worried about it since the Mac is old and slow.

    I wonder if this has to do with script compression. Its a new feature. could plausibly be to blame. Can't hurt to try, I guess. Add to wp-config.php.

    define( 'CONCATENATE_SCRIPTS', false );

  26. metaman8
    Member
    Posted 4 years ago #

    Just tried the

    define( 'CONCATENATE_SCRIPTS', false );

    still does it, it has to be a database issue. Everything else has been ruled out. Last night I got the program to create a fresh database. However, since there is vital information for the web site in every database table, attempting to transfer some of them and not others was a waste of time and I abandoned the idea and restored the old database so that the site can work.

    At this point the dashboard is usable, it just will take longer to load the new post page. In the mean time I hope that someone can figure this out.

  27. uncoveringpamela
    Member
    Posted 4 years ago #

    Did you ever have any luck figuring this out? I'm having the exact same problem!

Topic Closed

This topic has been closed to new replies.

About this Topic