WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New Multisite, 404 errors (8 posts)

  1. MarkEJohnson
    Member
    Posted 1 year ago #

    I have been working on this, off and on, for a week. I have found lots of comments about problems with the .htaccess file but that doesn't seem to be the issue - it, and the config files, all look correct.

    This is a new install, now tried on two separate servers, each resulting in the same problem - I can create the main site, but when I create the first subdirectory site, I get 404 errors when trying to access it.

    Have checked the .htaccess and wp-config files many times and they all match - is there something else I need to look at?

    .htaccess here:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Thoughts? Incantations? Do I need to find an aging chicken ...?

    Thanks.

  2. alexmcknight
    Member
    Posted 1 year ago #

  3. You get points for knowing about chickens!

    What's the 404 look like? Your main site's install or the server's basic 404?

  4. MarkEJohnson
    Member
    Posted 1 year ago #

    The 404 is the basic server one. (OSX, if it matters.)

    Thanks.

  5. Interesting, it means that your server isn't believing that WP is there at all.

    You may need to set AllowOverride as

    AllowOverride Fileinfo Options All

    (yes, AllowOverride is that stupid)

  6. MarkEJohnson
    Member
    Posted 1 year ago #

    Thanks, Mika - we gave that a whirl and still hit the same wall.

    One of the IT guys thinks he can do a different sort of install (AAPMS?), so we're going to wipe everything out again and see if that works.

    I have never been this stumped in my life ...

    -mark

  7. AAPMS is a new one on me. That's weird, I run Multisite off my local Mac all the time.

  8. MarkEJohnson
    Member
    Posted 1 year ago #

    I had the acronym wrong - AMPPS. Which I'm not sure I understand what it is, but it worked. My IT guys saved me on this one.

    Thanks to everyone who offered help.

    -mark

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.