WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] New Language Blog not Recognized / Change Blog Collection (24 posts)

  1. dannyboy84
    Member
    Posted 1 year ago #

    Hi,

    So I just added a new language and it's not being recognized. I am pretty sure the issue would be solved by the 'Changing the blow collection' solution described here.

    https://github.com/lloc/Multisite-Language-Switcher/wiki/Change-the-blog-collection

    However, I don't know what to do with that code. Could you let me know where to put it? Thanks.

    http://wordpress.org/plugins/multisite-language-switcher/

  2. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    when you add a new language (or a new blog in your network with a new language) you should complete the setup of the plugin also. Is this already done?

    The code (if you really need it) can be inserted in the functions.php of your theme.

    Cheers,
    Dennis.

  3. dannyboy84
    Member
    Posted 1 year ago #

    Yes, I have completed setup. I already have the blog working in two languages, the issue is that a third language that I have just added to the original two is not coming up as an option.

    I'll try inserting in functions.php.

    Thanks!

  4. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    In the most cases this happens if the new blog has no saved plugin-configuration.

    Let me know,
    Dennis.

  5. dannyboy84
    Member
    Posted 1 year ago #

    Hi - adding that code to the functions.php of the theme I was using did not work.

    So, the summary is that I have had a dual language switcher working for several weeks. I added a new blog to the multisite in a new language, completed switcher set up, but the new language does not register. So in the 'Multisite Language Switcher Options' panel of the menu, it still only shows the original two languages at the top, not the new language.

    Do you have any thoughts on where I might have gone wrong?

    Thanks!

  6. dannyboy84
    Member
    Posted 1 year ago #

    What do you mean by saved plugin config? I have entered all the details in the options page of the new language and hit the 'update' button. Is there something else I should be doing to save it? Thanks.

  7. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    The new blog has its own language in the general settings?

  8. dannyboy84
    Member
    Posted 1 year ago #

    Yes, new blog has its own unique language (Korean) in the general settings.

  9. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    You wrote

    So in the 'Multisite Language Switcher Options' panel of the menu, it still only shows the original two languages at the top, not the new language.

    This let me think that the setup is not completed. Did you notice a message regarding this (right after the activation) which came from the Multisite Language Switcher?

  10. dannyboy84
    Member
    Posted 1 year ago #

    Yes, there was a notice at the top of my dashboard saying something like 'Multisite Language Switcher Setup is incomplete. Click here to configure', but that has gone away now.

    I have just noticed that when I go to create a post, after I hit 'publish' this error message comes up:

    Fatal error: Call to a member function get_language() on a non-object in /home/freeespa/public_html/[redacted].com/wp-content/plugins/multisite-language-switcher/includes/MslsMetaBox.php on line 144

    The post still posts, but initially all you see is this error screen.

  11. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    I'm a little bit lost now. So you finished the setup in this blog? Or just in the other blogs?

  12. dannyboy84
    Member
    Posted 1 year ago #

    I finished setup of the language switcher other blogs several weeks ago, and they are working fine.

    Then I created a new blog in a new language last week, and it does not work. When I first created the new blog I had the 'incomplete' setup prompt, but after configuring the settings and hitting update that message went away.

    I only get the error message I mentioned in the new language blog. The original two languages both work fine.

    Hope that helps clarify?

    Thanks.

  13. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    What is the language code of the new language? It is ko_KR? Do you have a download-link for the language files so I can test it?

  14. dannyboy84
    Member
    Posted 1 year ago #

    Yes, ko_KR.mo.

    I just created blank language files in wp-content/languages for all of my languages. There's no content in them so I don't know how I would link to them?

    I have:

    en_US.mo
    zh_CN.mo
    ko_KR.mo

    US and CN both work, KR does not.

  15. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    OK, I will try a setup like yours and give let you know if there is anything strange. But if it works I could just check your installation by myself.

  16. dannyboy84
    Member
    Posted 1 year ago #

    Thanks. Let me know if you need any more info from me.

  17. dannyboy84
    Member
    Posted 1 year ago #

    Hi - Did you manage to recreate the issue? Or did it work fine for you? Thanks!

  18. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I made some tests during the last days but I had no problem. I cannot reproduce this problem. If you like I could check your installation.

    Cheers,
    Dennis.

  19. dannyboy84
    Member
    Posted 1 year ago #

    Hi Dennis - yes, it would be great of you could check my installation. What info do you need from me / what's the best way to get it to you? Thanks.

  20. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Please send me a login to my email address: re [at] lloc [dot] de

  21. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    We resolved this issue. Shortly: If you use code like this

    https://github.com/lloc/Multisite-Language-Switcher/wiki/Change-the-blog-collection

    there is a chance that you don't remember the fact any more . The solution is just to add the id of the new blog.

  22. dannyboy84
    Member
    Posted 1 year ago #

    Yes - all resolved. Thanks for your help, Dennis!

  23. manolis
    Member
    Posted 10 months ago #

    "The solution is just to add the id of the new blog. "
    Sorry If I am missing it, what is the actual solution? Where and how should the id be added?
    I have a network of 2 sites (greek main, english - subfolder) and msls is working fine at the english and it doesn't work at the main. It doesn't detect the second blog.
    I have one admin user, I have both files el.mo and en_US.mo in wpcontent languages/ dir. Both languages are available in general settings.

    Please, let me thank u for the great plugin.

  24. realloc
    Member
    Plugin Author

    Posted 10 months ago #

    Please create a new thread because this one is resolved. You can link - of course - this one here.

    Cheers,
    Dennis.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.