WordPress.org

Ready to get started?Download WordPress

Forums

New Installation went well then ...... (8 posts)

  1. jimjam
    Member
    Posted 2 years ago #

    I have a vbulletin forum in http://www.mysite/
    Today I added a WP installation in a new folder at
    http://www.mysite/magazine/

    Everything installed as it should, but when I go to login I get page not found. at http://www.mysite/magazine and at http://www.mysite/magazine/wp-admin

    I am guessing that this might have something to do with the .htaccess that I have in http://www.mysite/ which is for the forum

    Am i warm? Can anyone help me resolve this? Many thanks

    Dedicated server Centos/Plesk

  2. dkotter
    Member
    Posted 2 years ago #

    I would guess there's an issue with the .htaccess file. I've never installed both vbulletin and WordPress on the same server, but I know I've had issues in the past with other services that create a .htaccess file and then trying to install WordPress.

    So my advice would be to copy the .htaccess file, then delete it, and proceed with the WordPress install. Hopefully it will then work, and after that is done, re-upload the .htaccess file. In my experience, that's always fixed the conflict.

  3. jimjam
    Member
    Posted 2 years ago #

    Thanks, If I delete the htaccess file won't that make my 500,000 forum posts become unreachable?

    I am very sure that WP installed OK, it sent me the email as well, so its there, but none of the files can be found. Maybe I need to add something to the original htaccess file but I'm just guessing.

  4. dkotter
    Member
    Posted 2 years ago #

    Okay I guess I misread your original question. I thought you were still trying to get it to install. But if it's already installed, there must be a conflict with your .htaccess file from vbulletin, possibly a rewrite statement that is making your admin not accessible. Without seeing that file, it's hard to say exactly what you'll need to do to fix it.

  5. jimjam
    Member
    Posted 2 years ago #

    This is the hataccess that is in the site root
    ________________________________________

    Options +FollowSymLinks
    # Comment the following line (add '#' at the beginning)
    # to disable mod_rewrite functions.
    # Please note: you still need to disable the hack in
    # the vBSEO control panel to stop url rewrites.
    RewriteEngine On

    # Some servers require the Rewritebase directive to be
    # enabled (remove '#' at the beginning to activate)
    # Please note: when enabled, you must include the path
    # to your root vB folder (i.e. RewriteBase /forums/)
    RewriteBase /

    #RewriteCond %{HTTP_HOST} !^www\.mysite\.co\.uk
    #RewriteRule (.*) http://www.mysite.co.uk/$1 [L,R=301]

    RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

    RewriteCond %{QUERY_STRING} !vbseourl=
    RewriteCond %{REQUEST_URI} !(admincp/|modcp/|chat|cron)
    RewriteRule ^(.*\.php(/.*)?)$ vbseo.php?vbseourl=$1 [L,QSA]

    RewriteCond %{REQUEST_FILENAME} !\.(jpg|gif)$
    RewriteRule ^(archive/.*)$ vbseo.php?vbseourl=$1 [L,QSA]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
    RewriteRule ^(.+)$ vbseo.php?vbseourl=$1 [L,QSA]

  6. dkotter
    Member
    Posted 2 years ago #

    Okay nothing I see right off the bat, but I'd still say it's probably the rewrite rules that are the issue. To see if that is the issue, and solve it if it is, you can stop those rewrites on your WordPress directory.

    This forum post shows the code needed and some instructions. Basically this is what you'll need to add:

    RewriteRule ^no_rewrite/magazine - [L]

    Add this above the rewrite rules from vbulletin. Make sure to back up your .htaccess file before making changes, in case it messes things up you can revert changes.

  7. jimjam
    Member
    Posted 2 years ago #

    Thanks, that made no difference. :sad:

  8. Nikki Blight
    Member
    Posted 2 years ago #

    It looks like a lot of those rewrite rules are related to the vBSEO plugin for vBulletin. You might try disabling that plugin in your vB install temporarily and see if it's what's causing the conflict.

    That will at least tell you whether it's a WordPress/vB problem or a WordPress/vBSEO problem (and if it turns out to be the plugin, you could try asking at their support site, since they'd know a lot more about what their rewrite rules are doing).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.