WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New installation first run problems (7 posts)

  1. RobertoMason
    Member
    Posted 7 years ago #

    this is my first attempt at installing ubuntu-server feisty (7.04). I installed ubuntu using sourceforge howto to install LAMP.

    I then installed wordpress from ubuntu repositories. I used ubuntu howto https://help.ubuntu.com/community/WordPress to configure Wordpess, but right from the start on my first run of WordPress, at the point where I should see and click on run install.php, this is what i get

    ?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('wp-blog-header.php');
    ?>

    This is what i am running
    Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c Server at localhost Port 80

  2. whooami
    Member
    Posted 7 years ago #

    youre missing the opening in < in the index.php if you did a proper paste..

    It ought to read:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('wp-blog-header.php');
    ?>
  3. RobertoMason
    Member
    Posted 7 years ago #

    Actually it is there. I must have done a mistake in my cut and paste. here it is again

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

  4. mrmist
    Forum Janitor
    Posted 7 years ago #

    You say

    " should see and click on run install.php"

    You can't click on the icon of the file to run it, you have to view it through the server in your web browser. if you just click on it, I expect you'll get a window opening with the code in it. Which is what you get.

    So my question is, are you visiting the page, or clicking on the file?

  5. RobertoMason
    Member
    Posted 7 years ago #

    I'm visiting the page with my browser, that is http://localhost/wordpress.

    Since it's my first run, I should see the following line on my browser

    <<It doesn't look like you've install WP yet, try running install.php>>

    but instead I see the actual php code.

    This is a link to the image in the documentation.
    https://help.ubuntu.com/community/WordPress?action=AttachFile&do=get&target=wordpress1.jpg

  6. mrmist
    Forum Janitor
    Posted 7 years ago #

    OK, if you are browsing as you say, then the server itself is at fault. It needs to be set up to serve PHP pages properly.

    Not technically a wordpress problem really, it'd be a config option within your web server.

    Do other php pages work properly?

  7. RobertoMason
    Member
    Posted 7 years ago #

    Thanks for the info. Helped me figure out. Fault is mine. Tried to go fast. The only users i had defined in MYSQL was root user, so when configuring my set up with <sudo sh /usr/share/doc/wordpress/examples/setup-mysql -n (your mysql user) localhost> for my user, I entered root.

    Now what i did, what create a new user, with permissions all, host any, and re-installed wordpress with the new user, and voila, it worked.

    Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.