WordPress.org

Ready to get started?Download WordPress

Forums

new installation, blank screen, error message (7 posts)

  1. box1234
    Member
    Posted 1 year ago #

    Hello all,

    A couple of months ago, my wordpress site madicobosch.com went offline. When I asked my site host what the reason was, they wrote that they had changed Hardware and Hosting software due to hacking attacks on some customers websites.

    Now, I am attempting a new wordpress install for several days, without success.
    In the past, I have installed wordpress successfully with the same host, it also runs on my computer on localhost.

    When I try to run install.php I get a blank screen. I have now amended the wp-config.php file to show wp error messages and this is what I'm getting:

    Warning: ini_set() has been disabled for security reasons in /home/www/web454/html/home/www/webX/html/wp-config.php on line 3 Warning: ini_set() has been disabled for security reasons in /home/www/web454/html/home/www/webX/html/wp-includes/load.php on line 270 Strict Standards: Redefining already defined constructor for class WP_Widget in /home/www/web454/html/home/www/webX/html/wp-includes/widgets.php on line 93 Fatal error: Allowed memory size of 20971520 bytes exhausted (tried to allocate 122880 bytes) in /home/www/web454/html/home/www/webX/html/wp-admin/includes/post.php on line 112

    I am just a user and this looks like a whole bunch of problems. Any suggestion on how to solve this in simple terms is much appreciated.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Warning: ini_set() has been disabled for security reasons in /home/www/web454/html/home/www/webX/html/wp-config.php on line 3 Warning: ini_set() has been disabled for security reasons in /home/www/web454/html/home/www/webX/html/wp-includes/load.php on line 270

    This suggests a server configuration issue. Try contacting your hosts for assistance.

  3. box1234
    Member
    Posted 1 year ago #

    Thanks esmi,

    I have contacted my host on monday, and again yesterday, about my wordpress installation problems and haven't heard from them yet.
    If there's anything I can try at my end, I would try it. Otherwise, I'll have to look for a new host.

  4. websitehelp
    Member
    Posted 1 year ago #

    You could try to manually enable the ini_set function, although depending on your server configuration it may or may not work. Here is advice from a similar thread:

    In cPanel, Go to the PHP Configuration Editor then click on "Advanced Mode." This will let you view and edit all php.ini settings including disable_functions.

    If that doesn't work, you could try modifying your php.ini file.

  5. box1234
    Member
    Posted 1 year ago #

    Thanks for your help!
    I didn't make any progress on this install and have now changed host and domain.

  6. tilen
    Member
    Posted 1 year ago #

    Hello, everyone.

    I have very similar issue. But not with new installation, just .. error is the same :)

    When I'm trying to login to my admin panel in WordPress, I receive the following error:

    Warning: ini_set() has been disabled for security reasons in /home/domain_username/public_html/wp-includes/load.php on line 270
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/domain_username/public_html/wp-includes/load.php:270) in /home/domain_username/public_html/wp-includes/pluggable.php on line 881

    What the heck should be wrong here?

    wp-includes/load.php
    Lines 260-281

    function wp_debug_mode() {
    	if ( WP_DEBUG ) {
    		// E_DEPRECATED is a core PHP constant in PHP 5.3. Don't define this yourself.
    		// The two statements are equivalent, just one is for 5.3+ and for less than 5.3.
    		if ( defined( 'E_DEPRECATED' ) )
    			error_reporting( E_ALL & ~E_DEPRECATED & ~E_STRICT );
    		else
    			error_reporting( E_ALL );
    
    		if ( WP_DEBUG_DISPLAY )
    			ini_set( 'display_errors', 1 );
    		elseif ( null !== WP_DEBUG_DISPLAY )
    			ini_set( 'display_errors', 0 );
    
    		if ( WP_DEBUG_LOG ) {
    			ini_set( 'log_errors', 1 );
    			ini_set( 'error_log', WP_CONTENT_DIR . '/debug.log' );
    		}
    	} else {
    		error_reporting( E_CORE_ERROR | E_CORE_WARNING | E_COMPILE_ERROR | E_ERROR | E_WARNING | E_PARSE | E_USER_ERROR | E_USER_WARNING | E_RECOVERABLE_ERROR );
    	}
    }

    wp-includes/pluggable.php

    Lines 867-883

    function wp_redirect($location, $status = 302) {
    	global $is_IIS;
    
    	$location = apply_filters('wp_redirect', $location, $status);
    	$status = apply_filters('wp_redirect_status', $status, $location);
    
    	if ( !$location ) // allows the wp_redirect filter to cancel a redirect
    		return false;
    
    	$location = wp_sanitize_redirect($location);
    
    	if ( !$is_IIS && php_sapi_name() != 'cgi-fcgi' )
    		status_header($status); // This causes problems on IIS and some FastCGI setups
    
    	header("Location: $location", true, $status);
    }
    endif;
  7. Ian Dunn
    Member
    Posted 1 year ago #

    Details on the WP_Widget redefinition notice are available in #20801, along with a proposed patch.

Topic Closed

This topic has been closed to new replies.

About this Topic