WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] New install on WP 3.5 multisite, changes in settings are not being saved (22 posts)

  1. danielj@dtdo.net
    Member
    Posted 1 year ago #

    I just upgraded to WP 3.5, and then installed Subscribe2. I network activated it, and when I go into one of the network sites and try to change any settings under wp-admin/admin.php?page=s2_settings, and then click submit, everything is unchecked/unselected. None of the changes are sticking.

    I'm using this plugin on a few standalone sites without any problem on a different server.

    Any suggestions are most welcome.

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 1 year ago #

    @danielj,

    Subscribe2 should not be 'Network Activated' on WordPress Multisite but instead the plugins menu should be enabled with Subscribe2 then activated in a site by site basis. Try that and it should work better.

  3. danielj@dtdo.net
    Member
    Posted 1 year ago #

    Thank you for the suggestion. I network deactivated it and then activated it for one site. But again, if I change anything in the settings (such as the time to send digest notification), and click Submit, the setting immediately reverts.

    Daniel

  4. mattyrob
    Member
    Posted 1 year ago #

    @Daniel,

    The digest time setting is ignored if the frequency is less often than daily. But if it is applying to other settings then something strange is happening.

    What version of WordPress and Subscribe2 are you using? Have you checked for plugin and theme conflicts?

  5. danielj@dtdo.net
    Member
    Posted 1 year ago #

    WordPress 3.5 and Subscribe2 8.7.

    I just realized something very odd, too - I did the installation on my test server first, and it works fine there. They are both running the identical version of everything - WordPress, plugins, mysql, php, apache... Now I am really confused as to why this one is acting strangely.

    I deleted the plugin, including the wp_15_subscribe2, wp_16_subscribe2, etc. tables that did not get deleted during the deletion. I then reinstalled it. Same thing :(

  6. mattyrob
    Member
    Posted 1 year ago #

    @Daniel,

    That is very weird. First thing that springs to mid is to re-install WordPress on the live site and double check that all the settings are pointing to the correct database and domain (i.e. no cross over with the old test server locations).

  7. danielj@dtdo.net
    Member
    Posted 1 year ago #

    Unfortunately, that is not an option. The powers that be will say to forget about subscribe2 :( And I know it's the best choice of a plugin for what we need.

    I had actually copied the live server - the database and the wordpress directory - over to the test server environment before I upgraded the test server from 3.4.2 to 3.5 and installed subscribe2. Then I did the upgrade and install on the live server. So any problems in the live server *should* have propagated to the test serer.

    Any other suggestions? I just tried copying the subscribe2_options option_value from the test server to the live server for wp_15_options, but I'm still seeing the same behavior.

    a:40:{s:7:"autosub";s:2:"no";s:15:"newreg_override";s:2:"no";s:8:"wpregdef";s:2:"no";s:10:"autoformat";s:7:"excerpt";s:12:"show_autosub";s:3:"yes";s:11:"autosub_def";s:3:"yes";s:12:"comment_subs";s:2:"no";s:11:"comment_def";s:2:"no";s:17:"one_click_profile";s:2:"no";s:8:"bcclimit";i:1;s:11:"admin_email";s:4:"none";s:8:"tracking";s:0:"";s:6:"s2page";i:2;s:10:"stylesheet";s:3:"yes";s:5:"pages";s:2:"no";s:8:"password";s:2:"no";s:8:"stickies";s:2:"no";s:7:"private";s:2:"no";s:10:"email_freq";s:5:"never";s:10:"cron_order";s:4:"desc";s:10:"compulsory";s:0:"";s:7:"exclude";s:0:"";s:6:"sender";s:8:"blogname";s:12:"reg_override";s:1:"1";s:9:"show_meta";s:1:"1";s:11:"show_button";s:1:"1";s:4:"ajax";s:1:"1";s:6:"widget";s:1:"1";s:13:"counterwidget";s:0:"";s:14:"s2meta_default";s:0:"";s:7:"entries";i:25;s:6:"barred";s:0:"";s:15:"exclude_formats";s:0:"";s:8:"mailtext";s:215:"{BLOGNAME} has posted a new item, '{TITLE}'
    
    {POST}
    
    You may view the latest post at
    {PERMALINK}
    
    You received this e-mail because you asked to be notified when new updates are posted.
    Best regards,
    {MYNAME}
    {EMAIL}";s:20:"notification_subject";s:20:"[{BLOGNAME}] {TITLE}";s:13:"confirm_email";s:229:"{BLOGNAME} has received a request to {ACTION} for this email address. To complete your request please click on the link below:
    
    {LINK}
    
    If you did not request this, please feel free to disregard this notice!
    
    Thank you,
    {MYNAME}.";s:15:"confirm_subject";s:40:"[{BLOGNAME}] Please confirm your request";s:12:"remind_email";s:348:"This email address was subscribed for notifications at {BLOGNAME} ({BLOGLINK}) but the subscription remains incomplete.
    
    If you wish to complete your subscription please click on the link below:
    
    {LINK}
    
    If you do not wish to complete your subscription please ignore this email and your address will be removed from our database.
    
    Regards,
    {MYNAME}";s:14:"remind_subject";s:34:"[{BLOGNAME}] Subscription Reminder";s:7:"version";s:3:"8.7";}
  8. danielj@dtdo.net
    Member
    Posted 1 year ago #

    Unfortunately, that is not an option. The powers that be will say to forget about subscribe2 :( And I know it's the best choice of a plugin for what we need.

    I had actually copied the live server - the database and the wordpress directory - over to the test server environment before I upgraded the test server from 3.4.2 to 3.5 and installed subscribe2. Then I did the upgrade and install on the live server. So any problems in the live server *should* have propagated to the test serer.

    Any other suggestions? I just tried copying the subscribe2_options option_value from the test server to the live server for wp_15_options, but I'm still seeing the same behavior.

    a:40:{s:7:"autosub";s:2:"no";s:15:"newreg_override";s:2:"no";s:8:"wpregdef";s:2:"no";s:10:"autoformat";s:7:"excerpt";s:12:"show_autosub";s:3:"yes";s:11:"autosub_def";s:3:"yes";s:12:"comment_subs";s:2:"no";s:11:"comment_def";s:2:"no";s:17:"one_click_profile";s:2:"no";s:8:"bcclimit";i:1;s:11:"admin_email";s:4:"none";s:8:"tracking";s:0:"";s:6:"s2page";i:2;s:10:"stylesheet";s:3:"yes";s:5:"pages";s:2:"no";s:8:"password";s:2:"no";s:8:"stickies";s:2:"no";s:7:"private";s:2:"no";s:10:"email_freq";s:5:"never";s:10:"cron_order";s:4:"desc";s:10:"compulsory";s:0:"";s:7:"exclude";s:0:"";s:6:"sender";s:8:"blogname";s:12:"reg_override";s:1:"1";s:9:"show_meta";s:1:"1";s:11:"show_button";s:1:"1";s:4:"ajax";s:1:"1";s:6:"widget";s:1:"1";s:13:"counterwidget";s:0:"";s:14:"s2meta_default";s:0:"";s:7:"entries";i:25;s:6:"barred";s:0:"";s:15:"exclude_formats";s:0:"";s:8:"mailtext";s:215:"{BLOGNAME} has posted a new item, '{TITLE}'
    
    {POST}
    
    You may view the latest post at
    {PERMALINK}
    
    You received this e-mail because you asked to be notified when new updates are posted.
    Best regards,
    {MYNAME}
    {EMAIL}";s:20:"notification_subject";s:20:"[{BLOGNAME}] {TITLE}";s:13:"confirm_email";s:229:"{BLOGNAME} has received a request to {ACTION} for this email address. To complete your request please click on the link below:
    
    {LINK}
    
    If you did not request this, please feel free to disregard this notice!
    
    Thank you,
    {MYNAME}.";s:15:"confirm_subject";s:40:"[{BLOGNAME}] Please confirm your request";s:12:"remind_email";s:348:"This email address was subscribed for notifications at {BLOGNAME} ({BLOGLINK}) but the subscription remains incomplete.
    
    If you wish to complete your subscription please click on the link below:
    
    {LINK}
    
    If you do not wish to complete your subscription please ignore this email and your address will be removed from our database.
    
    Regards,
    {MYNAME}";s:14:"remind_subject";s:34:"[{BLOGNAME}] Subscription Reminder";s:7:"version";s:3:"8.7";}
  9. danielj@dtdo.net
    Member
    Posted 1 year ago #

    Sorry for the double post. The WordPress server threw an nginx bad gateway error, so I assumed it didn't post the first time.

  10. mattyrob
    Member
    Posted 1 year ago #

    @Daniel,

    Ah, now then, in copying the data between sites you may have inadvertently corrupted the serialised array that contains the options. Try hitting Reset on the Settings page and then you'll have to manually re-apply all of your settings, but if it fixes it it's worth a shot.

  11. danielj@dtdo.net
    Member
    Posted 1 year ago #

    Sorry if I was unclear - I did not install subscribe2 until after I copied the data between the servers. And the server that subscribe2 is not working on is the original live server, not the one I copied the data to.

    But, guess what - hitting Reset fixed the problem on the live server :-) Thanks!

  12. mattyrob
    Member
    Posted 1 year ago #

    @Daniel,

    My explanation and understanding wasn't quite correct then but the issue caused and the solution appear to have been right. I'm glad you are back working.

  13. timothygoss
    Member
    Posted 1 year ago #

    I'm having the same problem but don't see a Reset Button. Am I looking on Network Settings on the Dashboard?

    Tim

  14. mattyrob
    Member
    Posted 1 year ago #

    @Tim,

    Please download and try the development version, there is a bug that might be contributing to your issues that is fixed in the development code.

    http://downloads.wordpress.org/plugin/subscribe2.zip

  15. timothygoss
    Member
    Posted 1 year ago #

    Matt:
    So do I inactivate copies for all Subscribe2 users' on my multi-user network, delete the old version of Subscribe at the network level and then install the new version? Finally, active the user versions?

    Tim

  16. mattyrob
    Member
    Posted 1 year ago #

    @Tim,

    Inactivate the plugin if you can (may not be viable on huge Multisite installs), do not delete it or you will invoke the uninstall script and erase all settings.

    Copy the new code over the existing and reactive any sites where you deactivated the code.

  17. timothygoss
    Member
    Posted 1 year ago #

    Hi Matt:
    I was able to deactivate Subscribe2 for all 22 users in my multisite install. I have Subscribe2 deactivated at the network level as well. Now when I upload and install the new Development version and get this error:

    Unpacking the packageā€¦

    Installing the pluginā€¦

    Destination folder already exists. /opt/wordpress-sites/www/wp-content/plugins/subscribe2/

    Plugin install failed.

    Tim

  18. mattyrob
    Member
    Posted 1 year ago #

    @Tim,

    You will need to install the development version using the FTP method.

  19. timothygoss
    Member
    Posted 1 year ago #

    Thanks Matt. We installed it via ftp and it resolved the problem of not being able to save the settings. And, as an added bonus, the settings that were originally there showed back up, so I only needed to adjust a few.

    Thanks again for your help. Subscribe2 has been a big plus to our organization.

    Tim

  20. mattyrob
    Member
    Posted 1 year ago #

    @Tim,

    I'm glad you are back up and working and with little repair work to do after which is a bonus.

  21. timothygoss
    Member
    Posted 1 year ago #

    One more question. I get a warning at the top saying that the email address does not match the server domain and it might cause errors. Can you explain what that means? Our server is something like wordpress.bethel.k12.or.us and our email is bethel.k12.or.us.

    Thanks,

    Tim

  22. mattyrob
    Member
    Posted 1 year ago #

    @Tim,

    A lot of the non-sending issue I get reported are down to off-dimain sending attempts. Bascically that message is there to warn people that their blog is not likely to send emails without the correct configuration to send emails from an email address on the same domain (i.e. not gmail, hotmail or yahoo).

    You can ignore the message. I might look at making the domain comparison a little more fuzzy in a future release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags