WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New install directs to localhost private IP address (13 posts)

  1. Ohlssonj
    Member
    Posted 7 years ago #

    Just installed a new instance of WP. I can't load the blog from outside my home network because this instance of WP is trying to load from the private IP address of my server (192.168.1.103), and of course eventually times out.

    This is not a networking or database issue. My other two WP blogs on the same machine work perfectly. My wp-config.php file is identical to the other two WP blogs.

    Interestingly, I can load the .../wp-admin/install.php, .../wp-admin/setup-config.php and .../wp-admin/upgrade.php pages successfully. from the internet.

    This blog appears to work perfectly from my server console. The only difference I can see is my two functioning blogs are WP ver 2.0.4 and the new one is version 2.0.5.

    Any ideas?

    Jess

  2. Basic questions first:

    What values do you have for WordPress address and Blog address on the general options page?

  3. Chris_K
    Member
    Posted 7 years ago #

    This is not a networking or database issue.

    Of course it is.

    192.168.x.x addresses are non-routable. Nobody from outside your local lan will be able to access your blog.

  4. Ohlssonj
    Member
    Posted 7 years ago #

    HandySolo, intimately familiar with private IP address schemes. I'm looking for someone who may know what's different with the new WP install. The two existing instances of WP on the very same machine are working perfectly. Those two copies of WP do not try to direct http requests to my server's private IP address. It's the new install of WP that is doing that.

    Further, some pages of that new copy of WP are accessable from the internet. The ones named above. Try one at:

    http://www.ohlssons.be/vegan/wp-admin/install.php

    You will see my server respond and you will get the "Already Installed" message from WP. This makes it plain that the network is, as I said earlier, not the problem. Further, there are no database errors. This new blog communicates perfectly with the database I created for it in mysql.

    You can see my perfectly functioning WP blogs on the same machine at:

    http://www.ohlssons.be/blog/

    and

    http://www.ohlssons.be/adoption/

    What is different is how this copy of WP is directing http requests. At no point in the install did I specify what the IP address of my machine was.

    A puzzler.

    LesBessant,

    I can't load my general options page from where I am to answer your question, but I'll put that up as soon as I get home.

    Thanks.

  5. One of the values would seem to be set to:

    http://192.168.1.103/vegan

    The page does load, but the stylesheet doesn't.

  6. Chris_K
    Member
    Posted 7 years ago #

    http://www.ohlssons.be/vegan/wp-admin/install.php works.

    http://www.ohlssons.be/vegan/ tries to connect me to 192.168.1.103.

    What do you suppose are the odds that install.php doesn't use the URI values as specified at Options -> General?
    What do you suppose are the odds that 192.168.1.103 is associated with those same URI values?

    So, once the page finished loading (sans theme of course) I looked at the source and saw:
    <style type="text/css" media="screen">
    @import url( http:
    //192.168.1.103/vegan/wp-content/themes/oasis/style.css );
    </style>

    http://192.168.1.103/vegan/ would be from those same settings.

    You may be the expert. I may be the naif. I'm just saying, that's the "why" of it.

  7. Ohlssonj
    Member
    Posted 7 years ago #

    Gentlemen, I suspect you are correct about the general options setting, I am anxious to see what it is when I get home.

    It looks like the install script for the new version may have populated those two fields differently than the previous install scripts did.

    Will either have a closure for this or some more information for troubleshooting in about 3 hours. Thanks again.

    Jess

  8. Ohlssonj
    Member
    Posted 7 years ago #

    HandySolo and LesBessant, You were spot on about the general options page. That's where the install script populated those two fields with the IP address of my server. Replacing the IP address with the URL did the trick.

    Thanks again.

    Jess

  9. Chris_K
    Member
    Posted 7 years ago #

    Glad to hear you got it sorted out. :-)

    Mark this one as [Resolved] up at the top?

    Happy blogging!

  10. pcve02
    Member
    Posted 7 years ago #

    I had a similar problem, i installed WP on local server, but my IP changed. Originally I entered my (old) IP adres.
    in Admin > options >
    WordPress address (URL) xxx.xxx.xxx.xxx:port/wordpress
    Blog address (URL): xxx.xxx.xxx.xxx:port/wordpress
    After my IP changed the stylesheet didn't load
    and i couldn't acces the Admin > options > page , not even when i changed the redirected IP in the url. (but i might have made a typo)

    What i did was export the database [wordpress] and did a find/replace for old/new IP, dropped the old database, and imported the editted one. Worked !

    From what i read here only these 2 values had to be editted through phpmyadmin MySQL or MySQL Query Browser
    (no need for export/edit/drop/import)

    MySQL:
    SQL query: SELECT *
    FROM wp_options
    LIMIT 0 , 30
    [find these values and edit the IP in them]
    option_name
    siteurl
    home

    All in all i'm happy it worked, but i think it's a bit strange WP has to be changed everytime my IP changes.
    OK, i could get a DNS entry http://www.myserver.com, but i think such problems shouldn't arise i an otherwise fine CMS.

    BTW when i fill in only '/wordpress' without the IP in above fields in admin> options WP redirects to page with text (something like:)" you havent installed WP yet .. goto config.php" :)

    It's weird that WP uses these values within the site while it could use relative paths '/wordpress' or just '/'

    Or did i do something wrong in the install ?

  11. pcve02
    Member
    Posted 7 years ago #

    mm, my IP changed again
    editting only values siteurl & home in SQL didn't help;
    had to do find/replace, drop old database, and imported editted Db thing again :(

    I now installed with ip http://localhost/wordpress

    At least i can test it again locally ..
    anyone knows a solution ??

  12. Yes. Use a dynamic DNS service such as http://www.dyndns.com/

    Register a name with them (free for personal use), and either update it manually or run a small client program on your computer. Use the registered host name instead of your IP address for WP.

    When your IP address changes, the client program will automatically update the Dynamic DNS service, or you can do it manually through their website.

  13. pcve02
    Member
    Posted 7 years ago #

    I still think it's not needed for WP to have non-relative paths in the database at various lacations (and uses these for building the site, so themes and most links won't load after the adress changes). Using phpnuke i never had a problem like this :(

Topic Closed

This topic has been closed to new replies.

About this Topic