WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New Host , Restore database (23 posts)

  1. n3mesis
    Member
    Posted 9 years ago #

    I'm currently moving my blog to a new host and I made a backup of my db using the one click db backup but when I try to use it I just get the default install . I have also tried to install the db thu phpmyadmin but when I do it that way I end up with a white screen for my wordpress page . Anybody here got any ideas on what I can do ? Thanks for the help

  2. jonnyboy
    Member
    Posted 9 years ago #

    I'd love some help on this one too... I recently moved to Bluehost to support wordpress, but my database backup doesn't seem to fit. Anyone got any ideas?

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    jonnyboy - "doesn't seem to fit" What do you mean exactly ?

    n3mesis - how large is the backup file ? Do you have access to the original database ? The white screen - have you double checked that your Theme files are okay ? try uploading the default them ?

  4. jonnyboy
    Member
    Posted 9 years ago #

    Podz, I can't seem to make a database on bluehost without their username suffix. Where my old db was 'wordpress', the new one is 'username_wordpress'.

    I changed my wp-config.php to fit the new names, but that didn't help; it still displays the regular new-install posts.

    http://www.juliefilms.com/index.php

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The actual name of the db doesn't matter to anything except the connection in wp-config.php
    It's name does not affect the contents.

    How large is the sql file ? And do you have phpmyadmin ?

  6. Anat
    Member
    Posted 9 years ago #

    okie i guess u are installing wordpress on the new server. nopes u dont need to install. just dump wordpress onto the server and do not run install.php. now upload ur database, modify ur wp-config.php and point ur browser to /wp-admin/upgrade.php

  7. jonnyboy
    Member
    Posted 9 years ago #

    Oh really? I assumed that this was the problem. How about the tables? Usernames?

    The sql is about 1.5 megs, and yes, I've got phpadmin, but I've never used it before (the old host didn't have it).

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Here's the process:

    Install WP on the new host
    Login to cpanel and get to phpmyadmin
    DROP all the tables ( http://www.tamba2.org.uk/wordpress/empty-drop/ )
    Click the SQL tab - you'll see a large white box

    In Notepad or another plaintext editor (NOT a wordprocessor, or Dreamweaver or GoLive) open the sql file.
    Copy the contents and paste it into the white box.
    Wander off and make a coffee
    Come back and all should be good.

    If it is not, come back with the error and we'll try another way.

  9. jonnyboy
    Member
    Posted 9 years ago #

    Ok I'll do that now.

    Does it matter whether I had multiple blogs on the old site? Should I set up the other blogs (with virgin installs) first before dropping the tables?

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Where are the database files for these other blogs ?
    It shouldn't matter though as the config specifies which tables to use.

    How many blogs are there in this one database file ? (We need to do this right :) )

  11. jonnyboy
    Member
    Posted 9 years ago #

    Argh, it timed out.

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    How many blogs ??
    Time outs can be worked round.

  13. jonnyboy
    Member
    Posted 9 years ago #

    Ah ok, I've figured it out; two blogs in the same database... different prefixes.

  14. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If the sql import timed out, you need to split the file, though at 1.5meg it should have been fine.

    Open the file in a plain text editor.
    At the top will be something similar to this:
    -- phpMyAdmin SQL Dump
    -- version 2.6.1-pl2
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost
    -- Generation Time: Jun 21, 2005 at 04:39 PM
    -- Server version: 4.0.24
    -- PHP Version: 4.3.11
    --
    -- Database:
    wp_wordpress`

    Some way through the file that will be there again but with a different database name. Split the file in two, saving them both as .sql files
    Try importing those.

  15. jonnyboy
    Member
    Posted 9 years ago #

    ok, pasted and executed successfully.

    "Your SQL-query has been executed successfully:
    The content of your file has been inserted. (: 1510 Instructions) "

    Now the wordpress location comes up blank... DB_NAME, DB_USER, DB_PASSWORD and the table prefix are all correct.

  16. jonnyboy
    Member
    Posted 9 years ago #

    I can see all the appropriate tables on the left hand list, so I think the database is correct. As for what's screwing up the connection, I'm not really sure.

  17. Mark (podz)
    Support Maven
    Posted 9 years ago #

    On the new host, all the config info is correct ?
    What is happening to the blog ?
    Link ?

  18. jonnyboy
    Member
    Posted 9 years ago #

    http://www.juliefilms.com/index.php It's blank, just like if the db connection isn't working, right? Config info seems to be correct on the new host.

  19. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Change the theme.

    Whatever theme you have, choose Default.

  20. jonnyboy
    Member
    Posted 9 years ago #

    It's on default. Totally base install, except for the backup plugin is installed.

    ------------
    wp-config.php
    ------------

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'thrtwoth_wp'); // The name of the database
    define('DB_USER', 'thrtwoth_julie'); // Your MySQL username
    define('DB_PASSWORD', 'XXXXX'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'jules_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
    ------------
    ------------
    cpanel datbase stuff

    thrtwoth_wp
    Users in wp
    thrtwoth_julie (Privileges: ALL PRIVILEGES)

    connection string
    $dbh=mysql_connect ("localhost", "thrtwoth_julie", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());
    mysql_select_db ("thrtwoth_wp");
    ------------
    ------------

    Any ideas?

  21. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I am pretty sure it's a theme error.
    Download this theme:
    http://www.geeksmakemehot.com/daisyraegemini.zip
    Unzip, upload, activate.

    Also, using your ftp client, look through your install and make sure you have no files with a size of zero.

  22. jonnyboy
    Member
    Posted 9 years ago #

    Podz, you are a genius!

    I didn't realize that the theme would be dependent on information in the database... as soon as I logged in, it corrected itself.

    I cannot thank you enough!

  23. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Glad it's sorted :)

    n3mesis - Start a new thread so your problem doesn't get lost :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags