WordPress.org

Ready to get started?Download WordPress

Forums

  1. dinogomez
    Member
    Posted 1 year ago #

    Hi, great plugin!!

    I have a lot of galleries already on my site, when I installed the plugin, they weren't displayed properly with the defalt settings. Is there a way to leave the old galleries displayed as they are currently and just format the new ones using the plug in?

    http://wordpress.org/extend/plugins/photonic/

  2. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Didn't follow your question fully. If you are using a native WP gallery, unless that gallery has a "style" attribute passed in the shortcode, the gallery will display as normal. See http://aquoid.com/news/plugins/photonic/wp-galleries/. The first display is a regular gallery, that displays when I don't use a style attribute (or if I don't have Photonic). Subsequent galleries are displayed using specific Photonic features.

  3. dinogomez
    Member
    Posted 1 year ago #

    Can you please help me, I have removed the plugin entirely and it still shows problems in the thumb galleries, please take a look here: http://www.dinogomez.com/weddings/laura-tom-wedding-photos-gallery/

    I'm using native galleries, and after I installed your plugin it messed up the way new galleries are displayed, previous galleries before installation are displayed ok.

    thanks, this is very important to me so I'll appreciate very much your help.

  4. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Not really sure as to what you are asking - the definition of your styles for your galleries are coming from your theme. If you are asking why you are seeing new galleries on the front page and why aren't seeing old ones in your front page, that is a question for you and the author of your theme.

    I took a look at your page's source code - there is absolutely no trace of Photonic anywhere in your pages (you can do a search in the source code for Photonic), hence the issues you are facing are from another source, not Photonic.

  5. dinogomez
    Member
    Posted 1 year ago #

    That's exactly what I'm saying, after installing your plugin, the issue started hence it was your plugin what caused the problem. I have removed al trace of the plugin, even manually in the database since it left behind a lot of entries, even after deleting! The theme developer have already seen it and can't find anything wrong. AND I STILL HAVE AN AWFUL LOOK ON MY SITE DUE TO YOUR PLUGIN. Please help! I don't know what to do?

  6. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    AND I STILL HAVE AN AWFUL LOOK ON MY SITE DUE TO YOUR PLUGIN.

    Okay, you have to explain to me what the "AWFUL LOOK" is (and since I haven't done anything to aggravate / insult you personally, I would appreciate it if you avoided using ALL CAPS to yell.

    If you can explain to me what the expected behaviour is and what it is that Photonic is supposedly messing up (screenshots will help), I can provide you some direction. From what I can see, you are probably referring to your front page, since I am not seeing any material difference between old galleries and new galleries in the individual pages - http://www.dinogomez.com/cynthia-adam-wedding-dreams-los-cabos-resort-ttd/ (old) and http://www.dinogomez.com/randa-jim-intimate-wedding-preview/ (new) look very similar. So are you referring to your front page?

    The simple point I am making to you right now is that your galleries are not being styled by Photonic - they are being styled by WP. Check your source code. You will see this:

    <style type='text/css'>
    			#gallery-1 {
    				margin: auto;
    			}
    			#gallery-1 .gallery-item {
    				float: left;
    				margin-top: 10px;
    				text-align: center;
    				width: 33%;
    			}
    			#gallery-1 img {
    				border: 2px solid #cfcfcf;
    			}
    			#gallery-1 .gallery-caption {
    				margin-left: 0;
    			}
    		</style>

    This is from WP, not Photonic. Photonic doesn't use the "gallery-*" id for any gallery.

    Also, what I see in your page source code is this:

    <!-- see gallery_shortcode() in wp-includes/media.php -->
    		<div id='gallery-1' class='gallery galleryid-7521 gallery-columns-3 gallery-size-thumbnail'><dl class='gallery-item'>
    			<dt class='gallery-icon'>
    				<a href='http://www.dinogomez.com/wedding-setups-sheraton-hacienda-del-mar-los-cabos/wedding-photographer-dino-gomez-201/' title='Wedding Photographer Dino Gomez'><img width="120" height="120" src="http://www.dinogomez.com/wp-content/uploads/2013/03/Wedding-Photographer-Dino-Gomez102-120x120.jpg" class="attachment-thumbnail" alt="Wedding Photographer Dino Gomez" /></a>
    			</dt></dl><dl class='gallery-item'>

    That markup is not from Photonic - it comes from WP. Photonic's markup would have the word "photonic" show up in the class name at different places.

    The basic questions you have to ask yourself are:

    1. Do you want the gallery thumbnails on your front page?
    2. If you don't want gallery thumbnails in your front page why are you seeing them? My suspicion is that you have defined a manual excerpt for them, and your manual excerpt is using the [gallery] shortcode. If you correct your manual excerpt to remove the gallery shortcode, then that will take the thumbnails off the front page.
    3. If you don't want gallery thumbnails on your front page and if you don't have manual excerpts, the question becomes, do you have another plugin that evaluates shortcodes before printing excerpts? Or, did you make any change to your theme template file to evaluate shortcodes in the excerpt generation.
    4. If you want gallery thumbnails on your front page, then those are being styled by the WP styles - Photonic has nothing to do with them. Try including the thumbnails for your old galleries on your front page - you will see the same result.

    The answer to your problem is in the questions above, not in Photonic.

  7. dinogomez
    Member
    Posted 1 year ago #

    Please don't be sensitive, I'm not yelling, just stressing my problem!
    There's nothing personal going on here, just asking for support, apologise if it seemed that way.

    Those thumbs should look nice and square, not lons and messy.

    There are manual exerpts on some, but only the ones after the plug in was installed display the thumbs. I don't want the thumbs there, and not sure whay are they there. Only older posts prior to plug in installation look ok. Newer posts after plug in installation show the problem.

    I have disabled all plugins to see if it was other one causing the problem to no avail.

    What is curious here is that eventhough the plug in was removed the problem persists.

    Photonic caused the problem and it persists after it was removed, thats whay I ask for your support.

  8. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Those thumbs should look nice and square, not lons and messy.

    This is what I am trying to tell you: Photonic has nothing to do with those thumbs or their styling.

    You are seeing thumbnails because you probably have the [gallery] shortcode in your manual excerpt. If you remove the [gallery] from your manual excerpt you will not see those thumbnails. If you want I can log into your site and fix this in a few minutes - it is a content issue, not a plugin issue. If you take a fresh site with your theme and don't put in Photonic there, if your manual excerpt has the gallery shortcode, that site will also reflect the same problem.

  9. dinogomez
    Member
    Posted 1 year ago #

    There's no gallery in the excerpts, only text? Before the plug in everything looked nice and square. It was only when I tried to use ans set thumbs size within the plug in it all started.

  10. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    My offer to fix it by looking at your site still stands. If you want you can create a login for me. My email is my first name (Sayontan) at gmail.com.

  11. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Your theme has a function called unisphere_custom_excerpt, which is not working properly. I took a look at your theme's shortcodes.php file which has this code in the function unisphere_recent_posts_shortcode:

    if( intval( $numberwords) > 0 )
    			$output .= '<p class="excerpt">' . unisphere_custom_excerpt( get_the_content(), $numberwords ) . '</p>';

    I changed it to this:

    if( intval( $numberwords) > 0 )
    			//$output .= '<p class="excerpt">' . unisphere_custom_excerpt( get_the_content(), $numberwords ) . '</p>';
    			$output .= '<p class="excerpt">' . get_the_excerpt() . '</p>';

    The new function I used, get_the_excerpt is a standard WP function which prints out your manual excerpt if you have one, or prints out the first 55 words from your post if there is no manual excerpt.

    As you can see, all gallery thumbnails are gone. To re-emphasize my original point, none of the thumbnails you were seeing on your front page originally was from Photonic - your theme's custom excerpt function was doing something wonky. It wasn't even printing your manual excerpt if you were specifying one.

  12. dinogomez
    Member
    Posted 1 year ago #

    Thank you.

    But I'd like to stress out that it was ONLY until I installed the plug it this started to happen, so it must have conflicted the correct function it had before.

    All solved now, thanks again.

  13. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    That is what the police would refer to as circumstantial evidence.

    You might have noticed the problem after using Photonic, but I checked out your whole site - you have no trace of Photonic anywhere. I looked at your database options - there isn't any option that has Photonic listed (you can even do a string search on Photonic there). You might have done a theme upgrade sometime around when you installed the plugin, and that might have triggered your issues.

    Photonic only touches the gallery shortcode - nothing else. If your theme is executing the shortcode when it shouldn't (i.e. in the excerpt), your theme is a culprit, not the plugin.

  14. dinogomez
    Member
    Posted 1 year ago #

    I MANUALLY deleted all the plugin's entries that were left behind in the database AFTER I deleted it from the WP plugins list, it does leave a lot of entries, that's why you cant find any entries NOW. I re-installed WP and theme trying to figure it out to no avail, but I had to go manually deleting the entries.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.