WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New fatal error (7 posts)

  1. chrisebbeck
    Member
    Posted 4 years ago #

    Hi,

    So I was getting fatal errors on my dashboard and also when i tried updating to 3.0

    I did all of the memory limit changes here and the only thing that worked for me was to create my own php.ini file and load it to wp-admin folder.

    So I did this and it fixed all of the fatal errors I was seeing and allowed me upgrade to WP 3.0

    All good I thought, until I went to my web address http://www.hairlooms.com.au and all I see is the following fatal error:

    "Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/hairloom/public_html/wp-includes/post.php(975) : runtime-created function on line 1"

    Ok, so deleat the php.ini file and i still have the same fatal error so it is not the php.ini file. I am thinking the cause of this is WP 3.0.

    How can I fix this?

  2. Try decativating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme (WordPress 2.9) or the TwentyTen theme (WordPress 3.0) to rule-out a theme-specific issue.

    If that still doesn't work, move the php.ini file that you had in the /wp-admin/ directory to the /public_html/ directory.

  3. chrisebbeck
    Member
    Posted 4 years ago #

    Thanks! It was my WP-Contact plugin that was causing this. I would still like to use this plug-in, is there anything i can do to keep it?

  4. chrisebbeck
    Member
    Posted 4 years ago #

    Thank you! The first one works great!

  5. You're welcome!

  6. stenforsarchtects
    Member
    Posted 3 years ago #

    I placed my favicon on my wordpress site and add a small change to my header php and I was getting a Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 6721 bytes) in /data/5/0/74/81/237407/user/241166/htdocs/site/wp-includes/formatting.php on line 203 and or
    500 INTERNAL SERVER ERROR.

    I uninstalled a recent plug-in that I activated and everything worked fine!
    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic