WordPress.org

Ready to get started?Download WordPress

Forums

New Error (8 posts)

  1. pathfinder
    Member
    Posted 6 years ago #

    When I go to my Dashboard I am getting the following error:

    Not Acceptable
    An appropriate representation of the requested resource /wordpress/wp-admin/index-extra.php could not be found on this server.

    The Dashboard works fine. This is just on the left where I generally see the news from WordPress.
    Is this a temporary thing due to the feeds?

  2. whooami
    Member
    Posted 6 years ago #

    disable mod_security:

    IF YOU DO NOT HAVE an .htaccess in your wp-admin/ directory:

    create a text file on your desktop:

    put the following inside it:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    name it anything you like and save the file.

    Upload the file to your wp-admin directory.

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    Edit it and add:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
  3. pathfinder
    Member
    Posted 6 years ago #

    I'll try this in the morning. Funny that it would just start tonight. It has been fine all along.

  4. pathfinder
    Member
    Posted 6 years ago #

    Thank you. I tried it now and it works.
    Any idea why that just started happening now? It was fine this morning.

  5. whooami
    Member
    Posted 6 years ago #

    not funny actually - your host may have upgraded Apache and in the process may have compiled in mod_security. They may have even just compiled in mod_security to their old Apache.

    Theres no telling...

  6. altfg
    Member
    Posted 6 years ago #

    Hello,

    I have WordPress 2.2.3.

    I tried that solution (disabling mod_security) just now -- as I've been stuck all day with a post that just won't work once it's published. (In previews it looks just fine. Once it's published I get the following message: "Directory has no index file. Browsing this site or directory without an index file is prohibited.")

    The expressioin that causes all the trouble is "home companion" (the post is about the Robert Altman movie).

    Even if I do a mere search for that word combination, the whole look of the admin panel gets distorted -- and then I get a "forbidden" error message.

    My .htaccess (htdocs/blog/ directory) has the following:

    Options -Indexes

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
    # END WordPress

    Any assistance would be much appreciated. I've never run into this sort of problem before in the two years I've been using WordPress.

  7. altfg
    Member
    Posted 6 years ago #

    Update:
    I've taken the
    </IfModule>
    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
    out of the htdocs/blog/ directory.

    I've placed it into the wp-admin/ directory. (I created a new .htaccess file.)

    I've cleared the Firefox cache. Tried again. The same problem happened.

    Any suggestions re: what I'm doing wrong?

  8. roguesun
    Member
    Posted 6 years ago #

    Okay that worked. I had to do the mod in Wordpad. Can I go to bed now?

Topic Closed

This topic has been closed to new replies.

About this Topic