WordPress.org

Ready to get started?Download WordPress

Forums

New Entries Not Showing Up Correctly (5 posts)

  1. beyourpet
    Member
    Posted 1 year ago #

    In short, my new entries (entries from April 2013 and anything after March 10th) are not showing up on my main page. The most recent entry showing up is from March 10 2013 and there have been about 20 or so new posts since then. They only thing that seems to correct it and allow the posts to appear again (in the right order and everything, like nothing was ever wrong) is if I go in and edit the newest post, or post a new entry without scheduling it. And sometimes even doing these things do not fix it, it just continues to show the post from March 10th and before. (As of the moment I'm posting this, it seems to be working. But this is occurring every single time I make a post).

    I have never had this issue until recently and the only change I think I've implemented is that I've been saving quite a few draft posts (to come back to and post later), and I've been scheduling posts more and more often (almost every post is now being posted at a scheduled time instead of immediately because of the convenience of writing multiple posts at once). I have quite a few plugins and thought they might be disrupting things, but I haven't added anything recently and this is a new problem, only in the past month this has been happening.

    I hate to just stop using the schedule feature as that's making my life a lot easier, but I'm not sure what in the world is going on with the posts not showing up. It's not just happening to me, other users viewing the blog have reported the same issue with the posts.

    The posts are viewable if visited from their direct links, but they're not showing up on the main page or on the calendar.

    As I said, it doesn't seem to be happening right this moment, but it's happening consistently.

    My blog is: http://beyourpet.com/diary, I'm using an edited Patchwork theme, and a large list of plugins. I can provide more info if needed.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    This is what shows at the bottom of your page:

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    
     Served from: beyourpet.com @ 2013-03-11 02:27:45 by W3 Total Cache -->

    This problem is very likely related to that plugin - you may want to make sure it's working correctly - post on the plugin support page if you're not sure how to do so.

  3. beyourpet
    Member
    Posted 1 year ago #

    Thanks I'll try to get help on their forums. I use that plugin for security, is there better alternatives if I need to disable the plugin?

  4. triathlon
    Member
    Posted 11 months ago #

    Did you find the answer to this question. I've been having a similar problem with W3 Total Cache on my new site. The only way I could get this to work was to disable 'Cache fron page' under 'Page Cache' > 'General Settings' and then empty the cache to rebuild.

  5. beyourpet
    Member
    Posted 11 months ago #

    @triathlon
    No I haven't. WPyogi (above) suggested I ask for help on the plugin's help page but no one has responded to me there. :/
    Lately I haven't been having the issue, I haven't been scheduling posts though... I'm not sure if that's making the difference, but it is unfortunate since scheduling makes it so much easier...
    I'll try the disable cache thing.

Topic Closed

This topic has been closed to new replies.

About this Topic