WordPress.org

Ready to get started?Download WordPress

Forums

New domain needs to point to current site (9 posts)

  1. Nemesisss
    Member
    Posted 4 months ago #

    Hi,

    I'm new to WP and struggling to understand how to get this to work. On my server I have my WP site installed in http://www.myParentDomain.ca/subfolder/myWPsite.

    That is the server location that I created the site on. Now, I have the domain registered for that site and normally what I would do is point the new domain to my server. I would then create a parked domain on my server using that new domain name. I would point that parked domain to the folder on the server that contains my site. I have done that as I normally would but the site doesn't work as expected. The main home gallery does not load, and clicking the other pages on the site loads the pages, but the URL shown for those pages is using the myParentDomain.ca/myWPsite.

    I don't know what to change to get my WP site to load from the correct folder on my server using my new parked domain.

    Any help would be greatly appreciated.
    Thanks.

  2. Nemesisss
    Member
    Posted 4 months ago #

    Oh no!!! I really need some help with this right now. I accidently made a change to one of the settings in the general settings tab.

    I changed the wordpress address to an incorrect domain/folder location and now I can't get to the site at all. What can I do? This is really bad.

  3. Nemesisss
    Member
    Posted 4 months ago #

    Ok, I fixed that. I had to make a change in the database table but I now have it back to my original question I posted. panic, averted.

    Just need the site correction.

    thanks.

  4. Nemesisss
    Member
    Posted 4 months ago #

    With all your WP pro's out there and nobody can steer me in the right direction.

    I need to point a new parked domain on my server, to the existing install location of WP. I don't need to move the installation. The installation does not exist on the root directory, it's in a subfolder.

  5. antk3
    Member
    Posted 4 months ago #

    In your dashboard, under the settings tab.

    Try changing the wordpress address url to:
    http://www.myParentDomain.ca/subfolder

    The site address url should be:
    http://www.myParentDomain.ca

  6. Nemesisss
    Member
    Posted 4 months ago #

    Thanks for the response, I hope it's that easy. I was reading the documentation on codeplex which is very confusing. There is also some posts that I have read where it says that the serialization of some of the URLs in the database will also be affected.

    If this is all I have to do though, that's awesome.

  7. bemdesign
    Member
    Posted 4 months ago #

    To the serialization question - run a find & replace over the database to update URLs after your "virtual move". There's also plugins in the repository that provide this functionality.

  8. esmi
    Forum Moderator
    Posted 4 months ago #

  9. Nemesisss
    Member
    Posted 4 months ago #

    Last night I found this plugin called Duplicator, which I'm currently attempting to use. To use that though, I am moving the install to a new folder. I must say, thats one for Joomla over wordpress. Ease of moving a site.

    If the duplicator plugin doesn't work well, I will look at the other plugin that has been posted. Thanks for the information.

    I'll keep you posted.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.