WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
New dependency for Azure Blob Storage (7 posts)

  1. netripper
    Member
    Posted 1 year ago #

    It appears that an addiitonal dependency is required to use Azure Blob Storage:

    [28-Feb-2013 04:25:10] 1. Try sending backup to a Microsoft Azure (Blob) …
    [28-Feb-2013 04:25:10] WARNING: require_once(HTTP/Request2.php): failed to open stream: No such file or directory
    [28-Feb-2013 03:25:10 UTC] PHP Fatal error: require_once(): Failed opening required 'HTTP/Request2.php' (include_path='.;C:\php\pear;C:\DWASFiles\Sites\blogict\VirtualDirectory0\site\wwwroot\wp-content\plugins\backwpup\inc/sdk/PEAR/') in C:\DWASFiles\Sites\blogict\VirtualDirectory0\site\wwwroot\wp-content\plugins\backwpup\sdk\WindowsAzure\Common\Internal\Http\HttpClient.php on line 33
    [28-Feb-2013 04:25:10] ERROR: require_once(): Failed opening required 'HTTP/Request2.php' (include_path='.;C:\php\pear;C:\DWASFiles\Sites\blogict\VirtualDirectory0\site\wwwroot\wp-content\plugins\backwpup\inc/sdk/PEAR/')

    Is this an intentional new depency? Maybe add a check for it? And can we have it packaged with the plugin?

    Not sure if we can install PEAR packages on an Azure Website.

    http://wordpress.org/extend/plugins/backwpup/

  2. netripper
    Member
    Posted 1 year ago #

    I noticed the HTTP_Request2 PEAR package is included with the plugin, but not properly added to the include_path.

    I added this line below the current set_include_path statement in plugins/backwpup/inc/class-destination-msazure.php and it fixed the issue:
    set_include_path( get_include_path() . PATH_SEPARATOR . __DIR__ . '/../sdk/PEAR/');

    Hope you can fix this in the next release.

  3. netripper
    Member
    Posted 1 year ago #

    File backup to Azure doesn't seem to work when the backup takes a long time.

    [02-Mar-2013 16:18:59] Archive size is 42.04 MB.
    [02-Mar-2013 16:18:59] 3455 Files with 65.35 MB in Archive.
    [02-Mar-2013 16:18:59] 1. Try sending backup to a Microsoft Azure (Blob) …
    [02-Mar-2013 16:19:00] Connected to MS Azure container "backup-ictblog".
    [02-Mar-2013 16:19:00] Upload to MS Azure now started …
    [02-Mar-2013 16:24:26] Job restart due to inactivity for more than 5 minutes.
    [02-Mar-2013 16:24:26] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with OpenCloud\PersistentObject::Create($params = Array)
    [02-Mar-2013 16:24:26] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with OpenCloud\PersistentObject::Update($params = Array)
    [02-Mar-2013 16:24:26] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with OpenCloud\PersistentObject::Delete()
    [02-Mar-2013 16:24:26] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with OpenCloud\PersistentObject::UpdateJson($params = Array)
    [02-Mar-2013 16:24:26] 2. Try sending backup to a Microsoft Azure (Blob) …
    [02-Mar-2013 16:24:27] Connected to MS Azure container "backup-ictblog".
    [02-Mar-2013 16:24:27] Upload to MS Azure now started …
    [02-Mar-2013 16:26:42] WARNING: fwrite(): SSL: An existing connection was forcibly closed by the remote host.
    
    [02-Mar-2013 15:26:42 UTC] PHP Warning:  mysql_ping(): MySQL server has gone away in C:\DWASFiles\Sites\blogict\VirtualDirectory0\site\wwwroot\wp-content\plugins\backwpup\inc\class-job.php on line 1079
    [02-Mar-2013 16:26:42] ERROR: Microsoft Azure API: Error writing request
    [02-Mar-2013 16:26:42] Job done in 1064 seconds.

    When I do a small backup (only the DB) the transfer to MS Azure is fine.

    I haven't had this problem with the 2.x version of BackWPup. Hope you can fix this.

  4. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    OK, th path i have changed.

    for the other problem i must find a wahy to get a wreit callback on upload. I will lok waht can do.

  5. delaneybill
    Member
    Posted 1 year ago #

    Same exact problem for me using 3.06. I also tested with smaller job and it works fine. 2.17 was working fine just 2 days ago. I may just revert to that.

    Daniel, for the record, my backup job is working to create the archive file locally. I watch that happen in realtime via FTP. But then when WPbackup reaches the point of contacting Azure, it seems to hang for quite a while making the upload (not that big, just over 10mb. The entire process takes about 8 minutes. The archive file is completed in about 6 mins.

  6. delaneybill
    Member
    Posted 1 year ago #

    Not sure if this helps, but the end of the backup log gives this output:

    [21-Mar-2013 08:15:19] Starting upload to MS Azure …
    [21-Mar-2013 08:17:27] WARNING: fwrite(): SSL: An existing connection was forcibly closed by the remote host.

    [21-Mar-2013 09:17:27 America/Chicago] PHP Warning: mysql_ping(): MySQL server has gone away in C:\DWASFiles\Sites\venturewp\VirtualDirectory0\site\wwwroot\wp-content\plugins\backwpup\inc\class-job.php on line 1093
    [21-Mar-2013 08:17:27] ERROR: Microsoft Azure API: Error writing request
    [21-Mar-2013 08:17:27] One old log deleted
    [21-Mar-2013 08:17:27] Job done in 370 seconds.

  7. Daniel Hüsken
    Member
    Plugin Author

    Posted 1 year ago #

    I must find a way to get the upload prozess back. In moment i don't have it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic