WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New Clean 3.0 first login endlessly returns to login form (6 posts)

  1. gazouteast
    Member
    Posted 4 years ago #

    This is a brand spanking new completely clean install that I have not even been able to look into the admin let alone try to add any themes or plugins.

    I have done everything on the codec page about login troubles and none of it fixed the issue.

    Basically, it completed the install, gave me the button to go to login, I did so, entered the admin user name and password chosen by me during install. The screen refreshes back at the login form. Re-enter a few times to be sure I got it right, do the forgotten password thing, do the database hack to set the password again with an MD5 yadda yadda yadda - got the T-shirt (and the password reminder emails).

    polite version - it's broken !!!
    (that is not at all what I want to say is its condition).

    Remember this is a brand new fresh install, made from an uploaded file package that was downloaded off wp.org a few hours before uploading it to the server (an hour ago).

    There is nothing in wp-config about any of the multisite configs or defines. There is no htaccess file in the root folder. After spending the last week trying to debug WP 3.0 multisites, it all looks rather bare and empty.

    .... and I have no idea why it will not allow me to login to admin.

    Anyone got any clues?

  2. Try downloading WordPress again and delete then replace your copies of the /wp-admin/ and /wp-includes/ directories with fresh copies from the download.

    Even though it's a fresh install, some of the files could have been corrupted and/or missed during the upload.

  3. gazouteast
    Member
    Posted 4 years ago #

    tried that, same situation

    Lot of very fast blaming of the FTP connections being done by moderators this week - think you need a different answer for next week guys ;)

  4. Ok, I'll get back to you next week then. Let me know if you find a solution.

  5. gazouteast
    Member
    Posted 4 years ago #

    Hi MacManX

    The resolution was far simpler than anyone thinks, and I'm very surprised I got caught by it again as I have a long-standing bug report in trac about it.

    In WPMU 2.9.2 and earlier, the final screen of install is about 3 screen heights tall - at the top it gives the master admin username and password followed by a "login now" button. A LONG way down that page it says to delete or rename the /wp-admin/install.php file BEFORE trying to login.

    WP 3.0 does not have that warning anywhere in the install screens, nor the readme, nor anywhere in the codex. On a hunch, I tried doing exactly that - BINGO - got straight in.

    When I get a minute, I'll file another bug report in trac about this.

    Hope it helps you all
    Gaz

  6. Thank you for sharing your solution!

Topic Closed

This topic has been closed to new replies.

About this Topic