WordPress.org

Ready to get started?Download WordPress

Forums

Lightbox Plus Colorbox
[resolved] New classes used for 3.5 galleries removed by LBP (6 posts)

  1. hexagongirl
    Member
    Posted 1 year ago #

    Further to my comment here, I discovered that LBP removes some of the new(?) classes WP 3.5 uses for galleries.

    This was what caused my styling to go out of the window (because styling was based on these removed classes).

    In particular, I had used the gallery-columns-[n] class (fits nicely with a grid).

    Here's an example of the gallery classes without LBP:

    gallery galleryid-6 gallery-columns-6 gallery-size-thumbnail

    And with LBP enabled/use for WP gallery checked:

    gallery galleryid-6

    Thanks!

    http://wordpress.org/extend/plugins/lightbox-plus/

  2. Dan Zappone
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the info. I think I need to update the gallery shortcode modification to reflect this. Will do that first and make a test update available.

  3. Dan Zappone
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, after some investigating I find that strange because on my 3.5 install with LBP 2.5.3 I get all those styles. I can't replicate the style problem or the single gallery image problem.

    Unfortunately it also seems that it will lightbox gallery images even if Use for WP Gallery is unchecked. But that's another problem I'll have to address.

    Here's the development version with updated shortcode function. Give it a try and let me know if it makes any difference.

  4. hexagongirl
    Member
    Posted 1 year ago #

    Development version seems to have done the trick re. the classes - thanks!!

    I'm still getting wierd styles when the image is opened in lightbox (right and bottom sides of lightbox are not visible, include next/previous links), but that might just be something wierd I'm doing - will investigate further.

  5. hexagongirl
    Member
    Posted 1 year ago #

    Solved the wierd styles (missing right & bottom borders) thing - it was due to using border-box in a reset stylesheet:

    * {
    	-webkit-box-sizing: border-box;
    	-moz-box-sizing:    border-box;
    	box-sizing:         border-box;
    }

    Fixed by overriding for #colorbox:

    #colorbox {
    	-webkit-box-sizing: content-box;
    	-moz-box-sizing:    content-box;
    	box-sizing:         content-box;
    }

    Dan - this may be something you want on your radar as the use of border-box picks up? See http://paulirish.com/2012/box-sizing-border-box-ftw/ for reference.

  6. Dan Zappone
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the heads up and thanks for testing!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic