WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] New Blog Entries Don't Appear - Weird Entry Numbering (3 posts)

  1. cryptosmith
    Member
    Posted 5 years ago #

    If I visit my blog with a "clean" browser - after clearing the cookies and history - the latest entry on my blog is dated 3 Jan 09. In fact, I've posted several entries since them.

    The only odd thing I've noticed is that the 3 Jan entry is numbered 441. The 2 entries posted since then are numbered 466 and 470. I don't know why the numbering is so radically non-sequential.

    If I visit the WP login page and return to the blog home page, all the missing entries appear. If I revisit without clearing the cookies, the missing entries remain visible.

    If I clear cookies, the newer entries disappear again.

    If I use external links to visit the new blog entries, I can read the entries, but it doesn't make them visible. In fact, they won't even appear in the Jan 2009 archive unless I visit the login page first.

    The blog is at http://www.cryptosmith.com - feel free to try it yourself!

  2. cryptosmith
    Member
    Posted 5 years ago #

    OK, I see the reason for the bizarre post numbering - the autosave and revisioning code is incrementing the number if I take a long time to write a post (I usually do).

  3. cryptosmith
    Member
    Posted 5 years ago #

    The problem is resolved.

    I run WP Super Cache. I cleared the cache and the problem disappeared. I'm beginning to realize that if I'm running the cache and I have blog problems, I should clear the cache.

    The 3 Jan posting was the last one I posted BEFORE I upgraded to 2.7 and, around the same time, upgraded to a new version of Super Cache (at least I'm pretty sure cache upgrade was in there somewhere, too). For some reason, all this upgrading process did NOT automatically clear the cache.

Topic Closed

This topic has been closed to new replies.

About this Topic