WordPress.org

Ready to get started?Download WordPress

Forums

new auto update for plugins not working (43 posts)

  1. ronavroberts
    Member
    Posted 6 years ago #

    Auto update for Akismet 2.02 pulls this error message: Fatal error: Cannot redeclare class pclzip in /home/savoring/public_html/wordpress/wp-admin/includes/class-pclzip.php on line 162

    Is this something I can fix?

  2. edutecha
    Member
    Posted 6 years ago #

    I'm getting the same sort of error:

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/edutecha/public_html/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/edutecha/public_html/wp-admin/includes/class-pclzip.php on line 5489

    The rest of 2.5 is running fine. Is this a bug or is it a problem in my wordpress?

  3. Alison Foxall
    Member
    Posted 6 years ago #

    Strange, mine was working just great.

  4. seomartin
    Member
    Posted 6 years ago #

    All of my plugins are doing this with the auto-update in 2.5

  5. Rodrigo M
    Member
    Posted 6 years ago #

    I'm just getting a blank page when I try to update plugins. I can see the menus and the header of the Dashboard but the rest is blank.

  6. Dion Hulse
    WordPress Dev
    Posted 6 years ago #

    Those recieving the "Fatal error: Cannot redeclare class pclzip in" error will find its due to a plugin, most likely the "WordPress Automatic Upgrade" plugin.

    Disable WPAU and see if you can complete the upgrade.

    I believe theres an updated version of WPAU available for install too.

    Cheers,
    Dion

  7. simulationelson
    Member
    Posted 6 years ago #

    I deactivated the WPAU plugin and now I have this:

    Downloading update from http://downloads.wordpress.org/plugin/stats.1.2.zip

    Unpacking the update

    Could not create directory

  8. xzeed
    Member
    Posted 6 years ago #

    Looks like some missing rights.

  9. ronavroberts
    Member
    Posted 6 years ago #

    Disabling WP Automatic Update did it for me. All the plugins updated. I am dancing the "hallelujah" dance of relief. Funny that I had to disable WPAU to do the update to WPAU, but that worked, too. Once I updated everything, my NextGen gallery started working again, ending hours of frustration.

    Thank you to dd32!!!

  10. edutecha
    Member
    Posted 6 years ago #

    Yep, if you also update the WPAU from .80 to it's new 1.0 everything works great....Thanks to everyone for their input!

  11. simulationelson
    Member
    Posted 6 years ago #

    I tried CHMOD-ing the plugins directory to 777 but it still didn't do the work.

  12. cregenda
    Member
    Posted 6 years ago #

    Disabling WPAU worked for me. Thanks! :)

  13. wildjokers
    Member
    Posted 6 years ago #

    I'm also getting the following errors on all auto updates of plugins (even after disabling WPAU)

    Downloading update from http://downloads.wordpress.org/plugin/robots-meta.2.9.5.zip

    Unpacking the update

    Removing the old version of the plugin

    Could not remove the old plugin

    Any ideas guys?

  14. alfonso100
    Member
    Posted 6 years ago #

    I'm receiving the same error as wildjokers:

    Removing the old version of the plugin
    
    Could not remove the old plugin

    I've removed the WPAU too

  15. simulationelson
    Member
    Posted 6 years ago #

    Looks like there's more to what I'm having.

    Guys, any suggestions please?

  16. wildjokers
    Member
    Posted 6 years ago #

    Still no fix for this yet? I've tried virtually everything now. Where's the Guru's?

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    The permissions need to be set properly for the auto update to be able to modify the plugin files. Make sure that the files and directories aren't read only or something.

  18. wildjokers
    Member
    Posted 6 years ago #

    Hi Otto42, checked and double checked; permissions are set fine but the errors still persist. Any other ideas?

  19. wildjokers
    Member
    Posted 6 years ago #

    Come now guys, this is quite important as I'm not the only one having this problem. Just got off AIM and 2 of my friends are also experiencing this in 2.5

    It seems to be a problem in 2.5 so it needs a fix...where are the freakin Guru's at?

  20. cartermason
    Member
    Posted 6 years ago #

    Yeah, this is not working for me, either. I've changed the permissions to 777 on the plug-ins directory, the individual directory for the plug-in I was trying to upgrade, and it did not work. Help!

    I changed the permissions back to 755, since this did not resolve the issue.

  21. cartermason
    Member
    Posted 6 years ago #

    If you can ssh in to your server... A recursive chmod'ing of the plugins folder worked for me. I don't know why it didn't work when I chmod'd the plugins folder and the folder I was trying to upgrade, but I suspect it was because every single file in the folder needed the permissions changed in order for the upgrade to go through.

    Now the automatic plugin upgrade feature works for me.

    Try this, with the full path to your plugins directory at the end from the command line in an ssh session:

    chmod -R 777 /the/path/to/your/plugins/directory

  22. franklaughter
    Member
    Posted 6 years ago #

    Add Sticky to the list of plugin problems. When its activated with 2.5 all the post disappear and a message is in the main area that says "what you're looking for isn't here" or some such thing. Its causing the same problem on all updates (7 test sites and three live blogs). I've run through every possibility I can think of... even committing the Einstein sin of doing the same thing over and over: Permalinks, new copy of Sticky, configuring Sticky in all possible ways, etc. Nothing works.

  23. cartermason
    Member
    Posted 6 years ago #

    Also, if you are paranoid about permissions like I am... you need to do another recursive chmod'ing back to 755 or whatever you'd like when you're done. Kind of takes the fun out of an "automatic plugin upgrade" but it is easier than downloading, unpacking, and reuploading.

  24. wildjokers
    Member
    Posted 6 years ago #

    Hi Cartermason, I tried your fix above and didn't work for me. Still getting the exact same error. Thanks for the reply though.

    Anyone else have any clues?

  25. ambcompte
    Member
    Posted 6 years ago #

    I was getting the same error, so I changed the permission for the directory of the plugin i was trying to update to 777 and it worked...

  26. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Also, if you are paranoid about permissions like I am... you need to do another recursive chmod'ing back to 755 or whatever you'd like when you're done. Kind of takes the fun out of an "automatic plugin upgrade" but it is easier than downloading, unpacking, and reuploading.

    WordPress normally does a "direct" method to access files when doing the upgrade, but it does have alternate methods.

    The main other method is FTP. It will make an FTP connection back to itself and put the files in that way. This bypasses permission problems if you'd like to use it in this way.

    Normally, it only uses this when it detects that files it creates have the wrong owner name, but you can modify the code to force it. Edit the wp-admin/includes/file.php file. At the end of the file, you'll find this function:

    function get_filesystem_method() {
    ...

    Modify it to this:

    function get_filesystem_method() {
    /*	$tempFile = tempnam(get_temp_dir(), 'WPU');
    
    	if ( getmyuid() == fileowner($tempFile) ) {
    		unlink($tempFile);
    		return 'direct';
    	} else {
    		unlink($tempFile);
    	}
    */
    	if ( extension_loaded('ftp') ) return 'ftpext';
    	if ( extension_loaded('sockets') || function_exists('fsockopen') ) return 'ftpsockets'; //Sockets: Socket extension; PHP Mode: FSockopen / fwrite / fread
    	return false;
    }

    All I did was to remove the "direct" check. Now it'll be forced to use FTP, if that is available to it.

  27. simulationelson
    Member
    Posted 6 years ago #

    Finally! Thanks a lot Mr. Otto42!

  28. Jay Mayu
    Member
    Posted 6 years ago #

    Error: There was an error connecting to the server, Please verify the settings are correct.

    I'm getting this error!! can some one help?

  29. gatewayy
    Member
    Posted 6 years ago #

    Mine was working but now I am recieving the same error as mayooresan whenever I attempt to preform FTP updates.

    ow do you disable or reset the preferences from the auto update? Id like to see if I get errors if I do not try to update via FTP just to try to isolate points of failure.

  30. marcoart
    Member
    Posted 6 years ago #

    Make sure you have not uploaded any other directories within your plugin directory.

    I realised that windows had added a : _vti_cnf subdirectory to some of my plugin directories and so the auto upgrade could not remove the old plugin and update

Topic Closed

This topic has been closed to new replies.

About this Topic