WordPress.org

Ready to get started?Download WordPress

Forums

Picasa and Google Plus Express
New Auto Gallery albums only showing one photo (4 posts)

  1. scottnath
    Member
    Posted 1 year ago #

    Hi there,

    I use an Android phone, which uploads photos automatically to Picassa/Google+ into separate albums (by date) into an album called "Auto Backup". I can change these separate albums (the date-based sub-albums of "Auto Backup") into actual albums that then show up as a unique album in the main list of albums.

    When I try to access these new albums created from an "Auto Backup" sub-album, it only shows one photo in that album - the last one. This is happening both in the pop-up album selector as well as in the results of the shortcode.

    I can download these albums to Picasa on my mac, create a new album from them, then upload that as a new album and all of the photos show just fine.

    I have put both versions on a page to show the difference:
    http://scottnath.com/2013/07/04/july-4th-2013-johns-roof/

    On the above page I have included the rss output of the shortcode. What's interesting is that the rss output looks like it's including the other photos - they're just not being picked up by the plugin for some reason.

    Please let me know if I can elaborate further.

    thanks for a great plugin!
    Scott

    http://wordpress.org/extend/plugins/picasa-express-x2/

  2. diRiccardo
    Member
    Posted 1 year ago #

    Hi there,

    I am having the same problem too. I have created an album on my Google+ account and now I'd love to have the gallery tile view in my post but when I add the album it only shows me the last photo.

    I've tried deleting and recreating the album 3 times all with the same result. I've also reshared publicly all photos individually and as a group with no result.

    Any ideas?

    Thank you,

    Hayley

  3. scottnath
    Member
    Posted 1 year ago #

    When comparing a working rss feed and one that only shows one photo, the only difference I could see was that the one-photo one has the authkey in the link to the images. However, all images are included in the rss feed.

    I haven't been able to find a fix.

  4. scottnath
    Member
    Posted 1 year ago #

    Aha! I figured it out.

    Did some delving into the code, turns out by choosing to sort by date (Settings->Sorting images in album) we're making all of the images in these albums the same. It seems that when my Android device (Samsung Galaxy S4) uploads images to to Google Plus, that it uploads them all at the exact same time. So, when we select to sort the images in an album by date, then they all have the same exact date.

    So, at line 1718 of picasa-express-2.php is this code:

    case 1: $key = strtotime($this->get_item($item,'pubDate',true)); break;

    Which then makes the $key the exact same for each image. Thus, when making the $images array,

    $images[$key] = array (...)
    [array starts at line 1722]

    the $key for each image is the same and it therefore wipes out each other image except the last one.

    Sadly, it looks like the actual rss feed from Google only has one date, and that's the pubDate. So, the code for this plugin needs to be re-written to check if the $key made is repeated and if it is, it should create a different $key. Or it could just add the imageTitle to the pubdate key, thus making it unique.

    If you want immediate results as a user, just change the sort order of your images on the settings page.

    Hope this helps everyone,
    Scott

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic