WordPress.org

Ready to get started?Download WordPress

Forums

Never done this before, very confused help needed! (6 posts)

  1. Phate
    Member
    Posted 7 years ago #

    Hi people, I'm a complete Virgin to this and found it by google and want to give it a go, as my html skills are poo, and I'm looking to make a photoblog hopefully using wordpress.

    I've got my domain and hosting.

    Now I've uploaded everything to my server (I checked these forums to make sure I got them in the right place).

    Now in my "site administrator" page I made a "test" MySQL database, as I knew that wordpress needs to use one.

    So my wp-config.php file looks like this currently.

    // ** MySQL settings ** //
    define('je-design_co_uk_-_test', 'wordpress'); // The name of the database
    define('********', 'username'); // Your MySQL username
    define('*********', 'password'); // ...and password
    define('localhost', 'localhost'); // 99% chance you won't need to change this value

    (I've got everything else there from the file but didn't paste it)

    Now under the MySQL service its got the name of the database. (as above) and i've typed and retyped the username and password in and so they are deffinately correct. But for some reason, when i get to the "...install.php" bit i simply get

    "Error establishing database connection"

    Now I've never delt with MySQL databases before, so I'm pretty sure the problem lurks somewhere here, when i created the database under the MySQL page I didn't make any tables for it or anything. Should I?

    Or can someone else see where my problems lie?

    Thanks for any and all help :)

  2. Samuel B
    moderator
    Posted 7 years ago #

    The installer creates the tables if you have the DB created.

    Let's look at your config:
    // ** MySQL settings ** //
    define('je-design_co_uk_-_test', 'wordpress'); // The name of the database
    define('********', 'username'); // Your MySQL username
    define('*********', 'password'); // ...and password
    define('localhost', 'localhost'); // 99% chance you won't need to change this value

    You must REPLACE wordpress, username, password and localhost with the actual names (though localhost is probably correct).

  3. newflesh
    Member
    Posted 7 years ago #

    You just entered the data in the wrong place, it should be something like this:

    define('DB_NAME', 'je-design_co_uk_-_test'); // The name of the database

    ...and so on for the others. With the four "DB_" properties left intact it should work. :)

  4. Phate
    Member
    Posted 7 years ago #

    Those stars are where I have inputed my username and password, do i need to have it the other way round so it shows itself as
    "define('username', '********'); // Your MySQL username
    define('password', '********'); // ...and password"

    ?

    Thanks for the help

    Aha, just seen newsflash's post, i'll give it a go

  5. Phate
    Member
    Posted 7 years ago #

    Excellent got it working!

    Thanks guys!

  6. newflesh
    Member
    Posted 7 years ago #

    You're welcome. Have fun with WordPress! :)

Topic Closed

This topic has been closed to new replies.

About this Topic