WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] network super admin missing in dashboard (17 posts)

  1. getluckybyme
    Member
    Posted 9 months ago #

    when i try to access network this following error occurred
    http://classifieds.airtet.in/wp-admin/network/

    You do not have sufficient permissions to access this page.

    all plugins are disappeared only askimet configure page appearing when i click the plugins http://classifieds.airtet.in/wp-admin/admin.php?page=akismet-key-config

    unable to access http://classifieds.airtet.in/wp-admin/plugin.php

    i removed the directory and re uploaded this caused all the above errors
    the word press timetables

    wp_2_comments ,
    wp_2_links ,
    wp_2_options ,
    wp_2_postmeta ,
    wp_2_posts ,
    wp_2_terms ,
    wp_2_term_relationships ,
    wp_2_term_taxonomy ,
    wp_3_commentmeta ,
    wp_3_comments ,
    wp_3_links ,
    wp_3_options ,
    wp_3_postmeta ,
    wp_3_posts ,
    wp_3_terms ,
    wp_3_term_relationships ,
    wp_3_term_taxonomy ,
    wp_aiowps_failed_logins ,
    wp_aiowps_login_activity ,
    wp_aiowps_login_lockdown ,
    wp_blogs ,
    wp_blog_versions ,
    wp_commentmeta ,
    wp_comments ,
    wp_links ,
    wp_options ,
    wp_postmeta ,
    wp_posts ,
    wp_registration_log ,
    wp_signups ,
    wp_site ,
    wp_sitemeta ,
    wp_terms ,
    wp_term_relationships ,
    wp_term_taxonomy ,
    wp_usermeta ,
    wp_users ,
    wp_wpsd_trends

  2. getluckybyme
    Member
    Posted 9 months ago #

    wp-config.php

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'classifieds.airtet.in');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    please help anyone

  3. getluckybyme
    Member
    Posted 9 months ago #

    wp_capabilities a:1:{s:13:”administrator”;s:1:”1″;}

    i found the wp_user_roles in wp_options a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:13:”Administrator”;s:12:”capabilities”;a:62:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;s:12:”delete_users”;b:1;s:12:”create_users”;b:1;s:17:”unfiltered_upload”;b:1;s:14:”edit_dashboard”;b:1;s:14:”update_plugins”;b:1;s:14:”delete_plugins”;b:1;s:15:”install_plugins”;b:1;s:13:”update_themes”;b:1;s:14:”install_themes”;b:1;s:11:”update_core”;b:1;s:10:”list_users”;b:1;s:12:”remove_users”;b:1;s:9:”add_users”;b:1;s:13:”promote_users”;b:1;s:18:”edit_theme_options”;b:1;s:13:”delete_themes”;b:1;s:6:”export”;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:6:”Editor”;s:12:”capabilities”;a:34:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:6:”Author”;s:12:”capabilities”;a:10:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;s:22:”delete_published_posts”;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:11:”Contributor”;s:12:”capabilities”;a:5:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:10:”Subscriber”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}}

    wp_sitemeta site_admins found this

    a:2:{i:0;s:5:”admin”;i:1;s:2:” “;}

    what to do

    when i trying to login with correct username and password again asking login password without any error message

  4. Try deleting all your cookies at this point.

  5. getluckybyme
    Member
    Posted 9 months ago #

    which cookies browser cookies or others

    login correct username caused from wp-confing.php when i removed multisite install code from wp-confing.php i am logged in to dashboard

    define('WP_DEBUG', false);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'classifieds.airtet.in');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    /* That's all, stop editing! Happy blogging. */

    when i removed this part

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'classifieds.airtet.in');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    and added
    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    i am gets my dashboard in network setup
    warning message is network already detected. and the following codes to wp-config.php
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'classifieds.airtet.in');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    and htaccess
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    i did that after that i am not able to login

  6. which cookies browser cookies or others

    Are there cookies other than browser cookies? I mean, you could throw out all the ones in your kitchen, but I know my family'd get pissed at me...

  7. getluckybyme
    Member
    Posted 9 months ago #

    how can i solve this problem please provide me details steps or other wise need to take backup of network sites and import it newly created database after installing network admin

  8. which cookies browser cookies or others

    Delete your browser cookies. All of them.

  9. getluckybyme
    Member
    Posted 8 months ago #

    deleted cookies and tried and also in different browsers not worked please help!

  10. I just re-read the WHOLE thread and you and I both missed something.

    wp_sitemeta site_admins found this

    a:2:{i:0;s:5:”admin”;i:1;s:2:” “;}

    Does that look wrong to you? It should. There's only ONE username.

    a:1:{i:0;s:5:"admin";}

    Change it JUST to that and log in as the ADMIN account. See if that works. If so, restore admin capabilities from there.

  11. getluckybyme
    Member
    Posted 8 months ago #

    changed but not worked

    freshly installed on wpmu network on other sub domain adpost.airtet.in and copied wp2 wp3 whole tables and wp posts and posts meta

    super admin working but main network domain installed in adpost.airtet.in
    other network domains hyderabad.classifieds.airtet.in
    warangal.classifieds.airtet.in working properly but classifieds.airtet.in

    installed in adpost.airtet.in i am able login wp admin via class

    http://classifieds.airtet.in/wp-admin/

    but site url
    wordpress url

    i need to change one of this
    i had changed wp-options table site name wp -blog table

    in configuration wpmu site as classifieds.airtet.in
    My question is how to change url of network main home site
    sorry for grammar and spelling mistakes

  12. getluckybyme
    Member
    Posted 8 months ago #

    I just re-read the WHOLE thread and you and I both missed something.

    wp_sitemeta site_admins found this

    a:2:{i:0;s:5:”admin”;i:1;s:2:” “;}

    Does that look wrong to you? It should. There's only ONE username.

    a:1:{i:0;s:5:"admin";}

    Change it JUST to that and log in as the ADMIN account. See if that works. If so, restore admin capabilities from there.

    thank you very much its worked.

    just checked the new database i had renamed the wp-admin username
    and i repalced a:1:{i:0;s:5:"admin";} with a:1:{i:0;s:5:"custom username";}

    its now working Now

  13. For anyone following along, the s:5 ALSO has to change to match the LENGTH of the username.

    So if your admin name was 'foobarlicious' then it would be s:12 :)

  14. torlun
    Member
    Posted 8 months ago #

    For anyone following along, the s:5 ALSO has to change to match the LENGTH of the username.

    So if your admin name was 'foobarlicious' then it would be s:12 :)

    THAT did it for me - I tried everything else but this, but now it is working. Thanks a lot Ipstenu :)

  15. steve.athenainsurance
    Member
    Posted 8 months ago #

    yikes.. I an see Network Admin but not Super Admin in dash board.

    I set up mysitetoday.com as the primary with mapping to mysitetonight.com I followed the instruction as well as I could

    installed wp-multi network
    Inserted the code in the wp-config.php file
    Insered the code in the .htaccess file
    added a record *.mysite

  16. prsolans
    Member
    Posted 2 months ago #

    Thanks Ipstenu!

    I was unable to access wp-multi network admin capabilities, but I checked the wp_sitemeta site_admins, added my credentials, and was all set.

Reply

You must log in to post.

About this Topic