WordPress.org

Ready to get started?Download WordPress

Forums

Network Solution/Wordpress Domain Help Please (9 posts)

  1. venison66
    Member
    Posted 1 year ago #

    Hi All,

    I have a WordPress hosting package through network solutions, and my domain name is registered with NS as well.

    My problem: When I publish a page, it's xxx.netsolhost.com/about, but I want it to be thesupporteconomy.com/about.

    How do I change that?

  2. Jorge
    Member
    Posted 1 year ago #

    If you're using a single installation:

    Go to the Dashboard, then General Settings, and update the "Site Address".

    If you're using a network installation:

    Go to the Network Dashboard, then Sites, choose which site to edit, and update the Domain and Path respectively.

    Hope this helps.

  3. @Jorge: that will not fix URLs currently in the database, such as in menus and post/page content.

    @venison66: beware that you have /wordpress/ in your URL, so need to leave that in the URL settings, or move your site to root: see http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    And you will need to find/replace the old URLs in the database and change them to thesupporteconomy.com. That's a separate operation; see http://wordpress.org/plugins/velvet-blues-update-urls/

  4. venison66
    Member
    Posted 1 year ago #

    @songdogtech THank you for the links. I'm inexperienced with these kinds of things, so I have a couple of probably basic questions. I hope that you'll bare with me:

    1) I don't see the root directory on the Wp Editor...where is it?
    2) What is the best FTP client to use for this?

    Thank you!

  5. Jorge
    Member
    Posted 1 year ago #

    @songdogtech I'm going the easy route first, but you are right.

    You can access the root via FTP using a program like FileZilla.

  6. Jimbo41
    Member
    Posted 1 year ago #

    @songdogtech Could you look at my post, http://wordpress.org/support/topic/changed-site-url-and-wordpress-url-in-settings-locked-out?replies=1

    I followed the instructions you gave @venison66, but made a mistake.

  7. venison66
    Member
    Posted 1 year ago #

    @Jorge: thank you for the input. unfortunately, that method didn't work.

    @Jimbo41: that happened to me too. had to reinstall wordpress.

    @songdogtech: i downloaded cyberduck, input the server name and all necessary information, but it says that there are "0 files."

  8. Jimbo41
    Member
    Posted 1 year ago #

    What happened to your content? Did you have to start over?

  9. venison66
    Member
    Posted 1 year ago #

    @Jimbo41: yes, unfortunately!!

    @songdogtech: strike what i said before (wrong setting). it says that my login failed, even though i put in my url and my wordpress login info.

Topic Closed

This topic has been closed to new replies.

About this Topic