WordPress.org

Ready to get started?Download WordPress

Forums

Network Solutions URL + WordPress = Problem (13 posts)

  1. rpolicarpio
    Member
    Posted 3 years ago #

    Hi,

    I'm having the same problem described in this topic.

    http://wordpress.org/support/topic/page-name-url?replies=2

    http://www.lifestreamz.com - I am hosting at Network Solutions. My home page url is fine - however all subsequent pages, when accessed, are appearing at page names not mapped back to my domain. For example the "About" page appears at http://030c7c0.netsolhost.com/WordPress/?page_id=2 I've emailed Network Solutions tech support and they are absolutely useless in resolving this issue. Is there a setting in WP admin that needs to change? Or is this something at the server configuration for this installation and if so could someone please advise exactly what the issue is so I can relate to Network Solutions "tech support".

    I followed the recommended advice which was to hardcode the URL into the wp-config.php file. It worked in the sense that all the pages displayed the expected URLs (i.e. "example.com/blog, example.com/contact"). However, it appears to have broken the link to my hosting (Network Solutions) as the images I had stored in my WordPress media library no longer appeared anywhere throughout the site.

    Any help would be greatly appreciated as I'm fairly green to all this and have gone a little cross-eyed in looking for an appropriate fix.

    Thanks in advance

  2. govpatel
    Member
    Posted 3 years ago #

    You need to use permalinks
    Click on Settings>>>>Permalinks
    Select Custom Structure
    in box Enter /%postname%/
    and save

  3. rpolicarpio
    Member
    Posted 3 years ago #

    Thanks for the quick reply.

    However, I'm already using permalinks and as they apply to the latter section of my links, they work fine.

    My website is located @ djrefresh.com and that works and loads per expectations.

    But if I click on any of the other pages (i.e. "Bio", "Contact", etc), the URL isn't "djrefresh.com/bio" or "djrefresh.com/contact" but rather a Network Solutions hosted link.

    I've already contacted NS but they have told me that this is a WordPress configuration issue.

  4. govpatel
    Member
    Posted 3 years ago #

    In Settings General what do you have as urls?

  5. rpolicarpio
    Member
    Posted 3 years ago #

  6. govpatel
    Member
    Posted 3 years ago #

    That is reason why
    have you changed DNS on domain name to point to the Network Solutions server

    They should be
    http://djrefresh.com/wordpress

  7. rpolicarpio
    Member
    Posted 3 years ago #

    I'm not sure I fully understand.

    So I have to change the WordPress Address and Site Address so that they are both

    WordPress Address: http://djrefresh.com/WordPress
    Site Address: http://djrefresh.com/WordPress

    Is that right? Please correct me if I'm wrong

  8. govpatel
    Member
    Posted 3 years ago #

    I checked and clicked on the url http://djrefresh.com/WordPress
    gives me error

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    so check if you have your wordpress folder in root
    and as I can go to your website by
    http://djrefresh.com
    and you have this as site url
    http://03285d1.netsolhost.com/WordPress
    makes me think how can that be possible so looks like server is not configured properly and is redirecting some how.

  9. rpolicarpio
    Member
    Posted 3 years ago #

    my wordpress folder is located at root: /htdocs

    full path: root: /htdocs/WordPress

  10. kosmikkarma
    Member
    Posted 3 years ago #

    I'm having the same problem - I see the links are working correctly now on your website djrefresh.com

    Could you tell me what you did to get them to work?

  11. vwebworld
    Member
    Posted 3 years ago #

    What was the solution?

    Did you have to change all the links/url's for existing posts and pages?

  12. phillynotes
    Member
    Posted 2 years ago #

    You have to go into the General Settings and set BOTH the WordPress URL and the Site URL to your url. For example, my site is phillynotes.com, so in both of the fields I entered the full URL of my site:
    http://phillynotes.com/phillynotes

  13. jimholley
    Member
    Posted 2 years ago #

    Wow! Thanks so much phillynotes! I have limited experience with WordPress and this problem has been bothering me since day 1. I must have read and re-read countless complaints from NetworkSolutions customers and many technical post about the htaccess file and all it was was this simple little change on the General Settings page. Why doesn't Networksolutions know this or at least have it as an FAQ for their customers.

Topic Closed

This topic has been closed to new replies.

About this Topic