WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Network setup not working (11 posts)

  1. 1503wmike
    Member
    Posted 4 months ago #

    I've carefully followed the guides for setting up a network - made the appropriate changes to the .htaccess and wp-config.php files, checked and checked again.

    Network setup tells me there is an existing network - however, there are no Network tools displayed in the dashboard. So, how do I get this to work?

    Stuck.

    Any suggestions, anyone, please?

    Cheers,

    Mike

  2. Did you ever have a Network set up before?

    Check your database. See if you have the following tables:

    wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    Also, what's in your multisite section for your wp-config.php?

  3. 1503wmike
    Member
    Posted 4 months ago #

    Hi Mika,

    Followed this very carefully - http://codex.wordpress.org/Create_A_Network#Step_2:_Allow_Multisite

    Then followed the WordPress directions on my fresh install (no plugin - nothing) - edited the wp-config.php and ,htaccess exactly as directed.

    No network features present - just the setting up network screen.

  4. Did you check the database like I asked?

    And what's in your wp-config for Multisite?

    Can't help you if you don't follow directions :)

  5. 1503wmike
    Member
    Posted 4 months ago #

    As I first said - the dashboard tells me that a Network exists- no network menu available.

    Added to config:

    define('WP_ALLOW_MULTISITE', true);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.rnmedics.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Database:

    wp_blogs - exists
    wp_blog_versions - exists
    wp_registration_log - exists
    wp_signups - exists
    wp_site - exists
    wp_sitemeta - exits

    Cheers,

    Mike

  6. As I first said - the dashboard tells me that a Network exists- no network menu available.

    And as I asked, twice now, did you check the DATABASE. The reason things are asked the way they're asked is to try and break down possible reasons (infinite) into something calculable :) It goes faster when you play along :D

    Database:

    wp_blogs - exists
    wp_blog_versions - exists
    wp_registration_log - exists
    wp_signups - exists
    wp_site - exists
    wp_sitemeta - exits

    YES. This is exactly why WP thinks there's an extant Multisite :)

    So.

    1) DELETE those tables.
    2) REMOVE this from your wp-config:

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.rnmedics.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    3) THEN go back through network setup.

  7. 1503wmike
    Member
    Posted 4 months ago #

    I did respond as requested - and I'm not playing along?

    I have now done 2 clean installs on this site - so fresh database each time.

    I have carefully followed WP own instructions - same result each time.

    I am forced to do a new install each time because I want to use a folder structure - not sub-domains.

    So I guess no Network for me.

    Thanks anyway.

    Mike

  8. You're doing something wrong, but I'm not sure what since I don't know what you're actually doing.

    Let's take this one step at a time.

    I've carefully followed the guides for setting up a network - made the appropriate changes to the .htaccess and wp-config.php files, checked and checked again.

    Which guide are you following?

  9. 1503wmike
    Member
    Posted 4 months ago #

    Well, I am surprised that carefully following WordPress guides results in it not working - http://codex.wordpress.org/Create_A_Network - this, of course, is direct from WordPress. Not unreasonable to expect this to work.

  10. No, it's not unreasonable :) But perhaps you'd be surprised the myriad people who find random directions on other sites and complain here that they don't work. Again, I'm not you. I can't see in your brain, so I have to ask these overly simple questions to figure out where you went wrong.

    FWIW, I follow those directions daily to make sure they're still good.

    Reset. Get ALL the way back to Step 2, where ALL you have added in your wp-config are those two lines.

    Delete the tables I mentioned in your DB.

    Make sure your .htaccess is back to normal.

    Get THERE and only there.

  11. 1503wmike
    Member
    Posted 4 months ago #

    Thanks.

    I'll give it a miss - has broken my site 3-4 times now - really not worth the bother.

Reply

You must log in to post.

About this Topic