WordPress.org

Ready to get started?Download WordPress

Forums

Network settings missing (17 posts)

  1. cinematic
    Member
    Posted 4 years ago #

    I have installed a brand new wp 3.0 alpha and can't find any link to the network settings ...
    tools lists only import and export. Is it only me?

  2. MichaelH
    Member
    Posted 4 years ago #

    No that was intentional. You need to add this to your wp-config.php

    define('WP_ALLOW_MULTISITE', true);

    See http://lists.automattic.com/pipermail/wp-testers/2010-March/012212.html

    [moderated code fixed]

  3. cinematic
    Member
    Posted 4 years ago #

    Ah ... there it is ... thanks a lot for this info! I didn't take notice of that and wondered where the network tab was ...

    (maybe it would be a good idea to include this tag in config.php so that the line only needs to be set true in order to be used?)

  4. cinematic
    Member
    Posted 4 years ago #

    I just added the tag to config.php and it didn't change anything at all. Only after an automated update to the latest nightly build the network tab showed up. Could it be that the tag only works if being set before installation? Then I can imagine that this change will cause some confusion ...

  5. MichaelH
    Member
    Posted 4 years ago #

    WP_ALLOW_MULTISITE wasn't available via the nightly build until late March 9th (or early March 10, 2010). Prior to that it was WP_ENABLE_MULTISITE -- but they renamed it to WP_ALLOW_MULTISITE -- that's what the testers thread was all about.

  6. ruhig
    Member
    Posted 4 years ago #

    Parse error: syntax error, unexpected ':' in /usr/www/users/ooooo/ooo/wp2/wp-config.php on line 36

    What did I do wrong?

    Is it to late after the Installation?

  7. Kim Parsell
    Volunteer Moderator
    Posted 4 years ago #

    Open wp-config.php and change the line MichaelH had you add to this:

    define('WP_ALLOW_MULTISITE', true);

    The error is due to a colon at the end of that line - should be a semi-colon.

  8. MichaelH
    Member
    Posted 4 years ago #

    Good catch kpdesign. I will edit that code above.

    Thanks.

  9. ruhig
    Member
    Posted 4 years ago #

    trying the latest trunk define(‘WP_ALLOW_MULTISITE’, true);
    is not working, I dont get the network possibility.

  10. massayoshi
    Member
    Posted 4 years ago #

    I did just like it says:

    /** MULTI USER! */
    define('WP_ALLOW_MULTISITE', true);
    define('VHOST', 'no');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'my.domain.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('WP_ALLOW_REPAIR', true);

    But when I refresh the admin, it says the db needs to be repaired, when I comment the VHOST line, it goes back to normal but nothing happens.

  11. pswheeler
    Member
    Posted 4 years ago #

    I get the same error as him. I do not know what is wrong yet.

  12. Don't put all that in there at once.

    Put define( 'MULTISITE', true ); in your config file FIRST.

    Then go visit the Network menu.

  13. pswheeler
    Member
    Posted 4 years ago #

    ok now i get can not conect to db. and all the info is right.

  14. Elina Miller
    Member
    Posted 3 years ago #

    define('WP_ALLOW_MULTISITE', true);
    Adding this line in wp-config does not let network option under tools...in wordpress 3

  15. It should. Did you but it above the 'stop editing here' line?

  16. Elina Miller
    Member
    Posted 3 years ago #

    network link appeared

    i put this line before
    /* That's all, stop editing! Happy blogging. */

  17. There you are then :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.