WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] network not showing up in tools (20 posts)

  1. Babs
    Member
    Posted 3 years ago #

    Hi,

    I'm at a loss; I've tried everything I can think of & still no "network" under tools. I was able to successfully create the A host in the DNS with the *. I followed the WordPress installation. Edited the wp-config.php file, even tried multiple things there. I removed WordPress & installed WordPress MU (don't do this LOL), and resorted to downloading the 3.0 and manually installing. Previously, I had just upgraded to 3.0 but not from WordPress MU, just WordPress (finding there were 2 kinds took some time to figure out as well).

    I'm tired, so maybe not recalling what else I've done, but whatever logical step that should be done, I tried it. I'm using the default BuddyPress theme, and I have now upgraded the default theme. Still, nothing. Hmmm, I haven't tried it without the BuddyPress theme though. I could not get BuddyPress to work right using another BuddyPress theme.

    Oh, I remember; I also have my blog in a subdirectory folder (meaning the WordPress files are not separate from the main index file and such but they are not in root). I read that may be a problem, so I backed up my root files, moved them and installed my WordPress there. Nothing (meaning my site worked as it did prior to moving to the root; still no network under tools).

    I disabled plugins and whatever else. Everything is the same. No network. :( I'm hosting with godaddy (don't judge lol).

    I'm looking to do subdirectories, multiple blogs.

  2. Roy
    Member
    Posted 3 years ago #

    Did you see this?:
    http://codex.wordpress.org/Create_A_Network

    I've done a few networks now, all installed within minutes.

  3. I'm hosting with godaddy (don't judge lol).

    goDaddy will not support the Network on their bottom-line shared hosting account.

  4. Babs
    Member
    Posted 3 years ago #

    Yes, thank you, that would be where I started more than a week ago. That's how I know I am supposed to see a "network" under tools, which I do not.

    I also spoke to GoDaddy re: do they support this per those aforementioned instructions, & GoDaddy emailed me there own help link, which is a condensed version of the WordPress one (without the A host and such). However, GoDaddy's version said to place the multi user string in a location that was, in my opinion, very vague as to what they meant. So, I tried it in several logical areas.

    I would suspect that DNS/hosting aside, I still should be seeing this link under Tools, am I right? If I add that multi-user string to wp-config, that should show up in my admin panel. I have placed it according to the instructions in the Create_A_Network link along with all of the other things I wrote that I have already tried. Currently, we are back to where I started more than a week ago, just a lot of time lost. yea.

    Thank you for any assistance & advice.

  5. Babs
    Member
    Posted 3 years ago #

    Andrea, do you know who will? Naturally, GoDaddy didn't mention that (and I called them more than once).

  6. have placed it according to the instructions in the Create_A_Network link along with all of the other things I wrote that I have already tried.

    Just for giggles:

    - you placed this line
    'define('WP_ALLOW_MULTISITE', true);'

    somewhere in the middle of wp-config.php. Yes? Not at the beginning, not at the end. all on its own line.

  7. Babs
    Member
    Posted 3 years ago #

    Specifically,

    I placed it between "defin (WPLANG) and before "that's all..." in various places such as with a blank line between, without, etc. above "that's all..." below "that's all... and some other places nearby including at the end, but currently it's before "that's all" and after define:

    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    /* edited for reference only so it will post to support: define ('WPLANG', ''); */

    /* That's all, stop editing! Happy blogging. */

    (This is copied from another site, as well, so it's not the wp-config from that site; however, should be the same info if I recall correctly.)

  8. Babs
    Member
    Posted 3 years ago #

    /* define ('WPLANG", "); */
    /* Currently, I have the text here without this written info: define('WP_ALLOW_MULTISITE', true);
    */
    /* Would have left That's all, stop editing! Happy blogging." here */

  9. enjaytee
    Member
    Posted 3 years ago #

    This drove me mad and it was all down to the 'hyphons'! around 'WP_ALLOW_MULTISITE' I copied it into the config from somewhere on the web into notepad.

    After pulling my hair out as to why the Networks hadn't showed up I opened wp-config in notepadd++ and it showed me the errors (and I think I heard it snigger at me)

    I know I'm stupid but if it helps anyone else .....

    Now can I post this as Anonymous?

  10. Babs
    Member
    Posted 3 years ago #

    hmmm, well, notepad++ is another issue. lol That is installed on my other (main desktop) computer & doesn't work! I've just gone on without it. However, I have been editing text in Crimson. I do have dreamweaver, but am not editing text in that because I read that it can create errors.

    re: notepad++ issue, it doesn't even open. However, the icon is changed recognizing it where notepad used to be and such. I just can't get it to launch. Followed the directions precisely.

    I can't see the hyphons being the problem, as I know I need them and don't see anything wrong with them. I'll go look again when I'm done with the jobs that actually pay me something. :sigh: :) Thank you for the additional info.

  11. Babs
    Member
    Posted 3 years ago #

    Ok, guess I missed my window to fix my error, I meant hyphens.

  12. He didn't mean hyphens he meant the quotes. :) On windows they are often converted to "smart quotes" and mess things up when copy-pasting.

    when in doubt, type it in directly.

  13. Babs
    Member
    Posted 3 years ago #

    Ha! You two are wonderful! Thank you!!!! Problem fixed. Couse, now I see a lot of the same issue in support search, but I did not see any yesterday. You have to physically type in that string of info.

  14. enjaytee
    Member
    Posted 3 years ago #

    I did mean quotes! Where did I get hyphens from lol! I didn't even spell it correctly.
    Crazy day yesterday sorry. Must have had a panic. I don't comment alot.

    Glad you are up and running. Have fun

  15. spherical
    Member
    Posted 3 years ago #

    Not showing up in mine either. I started with WPMu 2.7 as my first choice when switching to WP. Upgraded from 2.9.2 to 3.0 and all of the "blogs" just showed up as "sites". Domain mapping worked. There's a "Super Admin" menu. There's a "Domains" sub-menu. No "Network" menu anywhere, though. Seeing this thread, I decided to check on what someone else may have found. Interestingly enough, all of this worked without my having edited wp-config.php to add that line. Probably the fact that the database was already in the correct configuration.

    Ah-ha! "Okay, I'll put that line in!" and .. nothing. No "Network" menu still.

    EDIT: Found it. the line:

    define('MULTISITE', true);

    has to be in there for the "Network" menu to show. (No "WP_ALLOW_")

  16. spherical
    Member
    Posted 3 years ago #

    BUT (edit capability timed-out before I could get back in to change it) Don't put that line in. Once I logged out and back in again, I got a database connection error with it in there. So, it appears that once you set up Multisite (didn't actually have to with mine 'cuz I was WPMu going in) the Network menu no longer appears. It'd be great if this was shared somewhere in the docs. Did I miss it?

  17. So, it appears that once you set up Multisite (didn't actually have to with mine 'cuz I was WPMu going in) the Network menu no longer appears.

    Still appears for me.

    And like you discovered, if you upgraded from MU, you do not have to do this. Havign the Network menu show after it's working is kinda.... irrelevant. :) You never need it again, especially if you were running mu.

  18. spherical
    Member
    Posted 3 years ago #

    Good to finally know what the deal is. Thanks for the confirm. Might be a good idea to have someone edit the instructions. With all of these people and instructions talking about the "Network" menu entry, and mine not showing, I thought my install was borked. I can't remember how many hours I spent searching for the answer.

  19. Might be a good idea to have someone edit the instructions.

    Which ones and what lines?

    Because it does state in the codex entry on upgrading MU to 3.0, that you don't have to set up the network. (at least I think I put that in there)

  20. firesika
    Member
    Posted 3 years ago #

    I can't get the network option to show up in the tools menu either. I upgraded a couple weeks ago from 2.9.2, and now I'd like to do the multisite option.

    I've tried

    define('MULTISITE', true);

    define('WP_ALLOW_MULTISITE', true);

    define('WP_ENABLE_MULTISITE', true);

    in my wp-config file. All of them, and all of them individually, just above the That's it line. On separate lines like above.

    I've tried editing my wp-config lazy like, with all my plugins still enabled, but I've also disabled all of them, and it didn't make a difference.

    I have bluehost, and some people say you can't do multisite on it, but others say they have and it works. I was able to add the wildcard subdomain.

    I can't access the httpd.conf file to add the serveralias line. Some people have said you can use your .htaccess file to override, but I haven't seen any explanations on how.

    Also, I'm not sure if the network option should be showing up before I get all that done anyway.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic